No phone calls or messages when on my work WIFI network

What phone do you have? Google Pixel 3

What plan are you on? My Choice + 1GB

Does your plan include data, or just talk & text? data also


Issue Description

I am unable to send / receive texts or place/receive phone calls when on WIFI at my place of work.
I have (very strong) WIFI access for data, but can’t text or call.
The republic app says:
On Cell
Calls or cell. No access to messages or voicemails.

However I can’t even make a phone call over cell. I did the VOIP reset, including the restart but that didn’t help.

It is only when I am on my work network that I have this problem.

My previous phone (Moto X 1st gen) had this issue also. I thought it was just cause the phone was old, but my new pixel 3 is the same.

Certain ports are required to be open and your work is probably blocking some of them. I suggest contacting your IT department and asking them to open the ports. They are listed in a section in the document below.

Your co-workers that use non-Republic WiFi calling might be happy about it too. If you know any that could use WiFi calling, see if they’ll suggest it too. (Not all the ports would be the same, but there are some similar ones).

1 Like

Thanks for this info. I used those links to test the 2 ports. They were both open.

While connected to work WiFi… run the diagnostic tests from your RW app under Advanced Settings…that should give you more info on what aspects of WiFi are not working.

2 Likes

Thanks for the diagnostics suggestion!

The diagnostics show a fail for MQTT connected.

1 Like
  • I would try the RW diags again, as a Port 443 failure (MQTT) should also indicate that you would not be able to connect to any HTTPS or Secure link, which would be very unlikely
  • Considering you had the same problem with the Moto X1, you may want to show the required Ports & Protocol section that @theresar referenced above to your IT folks, and see if they can provide any help in determining why you can’t connect through their firewall. We have seen in the past where enterprise level security would preclude WiFi usage by the RW app (but rarely)

Is your company internet connection provided by a Satellite based service? The latency of the Satellite based service makes it unusable for WiFi calling.

I ran diagnostics again. It is still showing the MQTT failure.
However, when I ran this to check the 443 port it was OK.
http://portquiz.net:443/

No I work for a large company. We wouldn’t use Satellite service.

Thanks for the feedback, it appears that the folks in France behind the portquiz have fixedit. I will update the Tips & Tricks to reflect your findings.

Any feedback from the IT folks on the connectivity problem you are experiencing?

Just want to chime in my experience. On WiFi (not my employer, I’m on a site visit) - it works sometimes but often it drops to calls on WiFi, messages and data over WiFI. When I run the diagnostic, it fails one test: “SIP Connected” - not connected on a general WiFi.

In these times I switch to Google voice which I have configured to make calls over WiFi - and it works just fine, so something with the Republic wireless is more sensitive where google voice works with very good quality. Slack voice calling also works (quality not as good as google voice). Down side is that my normal number not used by google voice, so people think that I am spamming them.

note: port 443 worked (though portquiz noted that I reached the page on port 80, not 443)

Message an
Expert customer