No text without wifi


#1

I am a new customer. I can’t seem to send or receive text messages without being connected to wifi. I am on a no data plan, but I have always been able to text without data with Verizon. Is this normal for Republic? I am not having a good initial experience.


#2

By the way, I can call and receive calls whether on wifi or cell. And I am trying to text another Republic phone, so I don’t think this is related to the current issue with texting from new phone numbers.


#3

do you have data turn on in the android setting (roaming data needs to be turn on also)
Republic hybrid VoIP/cell system used data to send text (even on the no data plan and this data is never counted against the data in any data tier you may purchase


#4

yes, both are on


#5

The basic answer is that texting with Republic requires that the phone have data, cellular or wifi. This does not mean CUSTOMER DATA, but rather a data connection to the network. Even on the $15 plan, with no customer data the phone still has a data connection to the network that is used by the phone for sending/receiving texts.


#6

Right, but I have the data On, but can’t text without Wi-Fi. Is there a solution to my problem?


#7

When you have the wifi turned off, do you have a cellular signal? If yes, do you see letters near the signal bar letting you know you have a data connection? (Like an LTE or 4G or 3G or an H+)?


#8

I have a strong cell signal, but I have never seen any indicators such as you have mentioned (LTE,etc.) I can’t imagine that nowhere in Charlotte that I have gone today is there access to data. If that is the case, this is really the wrong network. Is is possible my phone just doesn’t state that information? I have a Galaxy J3. How do I tell if there is data coverage where I am?


#9

Try this:

Please try the following steps to resolve this issue:

  1. Reboot the phone in an area that has a strong cell signal. (Some people have simply needed to step outside and reboot.) If this fixes it, stop.

  2. Please ensure the data is turned on in Android Settings. Settings > Data Usage > Cellular Data (some phones may say Mobile Data). If this fixes it, stop.

  3. This one is more complicated. This step will clear out any saved connections for Wi-Fi and Bluetooth that you may have already made. We’re going to reset the network settings.
    Go to Settings > Backup and Reset > Network settings reset
    Read the warning, tap “Reset settings.” You will be warned a second time. Tap “Reset settings” to confirm. The process will usually take 5-10 seconds and the cellular signal bars icon will go away for a moment. Once the cell signal bars icon returns, you should reboot the phone.


#10

The reboot worked, and I see “LTE” on my phone now. Will this be expected to be a permanent fix, or will I have to do this every time I come out of wifi?


#11

You should not need to repeat it.


#12

Thank you very much for your help!


#13

But I should say, it is good phone “hygiene” to restart your phone every few days.


#14

Got it.


#15

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.