No texts on roaming cellular G5+

#1

I’ve been having an issue where I can’t send/receive texts while roaming off Sprint.

Sprint coverage in my area is spotty at best, which is why I changed from another Sprint reseller.

It’s really disconcerting to pull into my driveway, and as soon as my Moto G5+ connects to my home WiFi, I get delayed texts.

I’m always able to make/receive voice calls.

Tried changing from Android messenger to Anywhere with no improvement.
Also tried deleting app data.

Anything else to try before putting in a support ticket?

0 Likes

#2

Have you verified that you have roaming data enabled in the phone settings? (Settings – More – Mobile Networks – Data Roaming)

1 Like

#3

While checking, you may also want to be aware that the ‘roaming data’ that @louisdi called out, may be under (Settings – More – Cellular Networks ) in the Android settings
Republic provides a Setting in the RW App under Advanced Settings that will Notify you if you inadvertently set either Cellular Data or Roaming wrong

0 Likes

#4

Is Data Roaming turned on? You don’t pay for this, it’s used to send and receive texts when on cell service.

0 Likes

#5

Echo much?

0 Likes

#6

Yes. Checked that before posting.

0 Likes

#7

I went to the RW advanced settings you imaged, and found another setting that I needed to change, ‘Allow SMS messages from email’.

0 Likes

#8

Just happened again.
Pulled into the drive and got notified of an SMS sent 4 hours prior.
I KNOW that I was in a good Sprint coverage for at least part of the time, so it seems that NO SMS is being delivered via cellular at all.

0 Likes

#9

Putting in a support ticket suggested uninstalling the RW app and then reloading.
Well, I couldn’t.
All I could do was disable it, uninstall the updates, and go back to the factory installed version. Then I updated from the Play Store
After the update installed, there was a message that 'DataSaver can cause problems, and to turn ON ‘Unrestricted data usage’.
I turned it on, and we’ll see what happens.

0 Likes

#10

Thanks for the feedback, this and the results you have is how the community learns, let us know if this is successful

0 Likes

#11

If you had data saver on, this was almost certainly the cause. Data saver prevents apps from accessing the internet in the background while on data. The end resuilt would be exactly what you experienced.

0 Likes

#12

Had it happen to me again today. Pull into WiFi range and get a bunch of text notifications.

This is the first mention of ‘background’ data.

I’ve turned ON Background Data, which now shows me the ‘Unrestricted data usage’ option

0 Likes

#13

Basically, restricting data to the phone in general, by whatever method, is likely to have adverse impacts on the functioning of the Republic calling/texting system. If you impose any data restrictions, you must exempt the Republic App from those restrictions. It works better to instead impose restrictions on the specific apps you are targeting.

0 Likes

#14

Well, looks like I got it fixed.

Turning ON Background Data, and allowing Unlimited use by the RW app seems to have done the trick.

Got and sent several SMS messages today while on cellular.

Just a note for those trying to assist, be EXTREMELY explicit when you say to do something.
I consider myself more than a tech newbie, but I’m not well versed in Android and all it’s flavors and nuances.

0 Likes

closed #15

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

0 Likes

Message an
Expert customer