No voicemail listed on the Voicemail tab of the Phone app on Motorola and Pixel phones

You do realize the Phone App isn’t put out by Republic, right? That’s a Google app that Google keeps breaking. Republic continues to try and work around Google’s bugs and then Google creates a new one. This issue doesn’t just impact Republic, I’ve experienced the same thing on a phone activated with Tello (and their advice was to find a 3rd party app to fix it, they don’t even offer a workaround). You may want to review Mint’s advice here: https://www.mintmobile.com/faqs/how-do-i-set-up-visual-voicemail/ which clearly indicates that they don’t even support Visual Voicemail on certain Android phones and that you should use a “3rd Party Visual Voicemail App” in those situations. The grass isn’t aways greener on the other side, it just looks that way until you actually get up close.

3 Likes

The Visual Voicemail page shows on my Pixel 3a, but activation is unable to complete. The button in voicemail settings changed from blue to red. When I checked last night, no visual voicemails showed. But when I called, there were 2. I was having no problems until recently. My 3a is on Android 12 now, but this started while it was still on 11.

Thank you, Thank you… It worked for me. Thank ■■■. Peace

1 Like

What phone do you have? Moto Version 6.1.11

What plan are you on? Basic

Does your plan include data, or just talk & text? 1 G data


Issue Description

Voiecmail tab says Can’t activate visual voicemail. If I reset Visual Voicemail, with toggle back on, it says Change Pin… Visual voicemail is not activated yet, please try again later.

Always have to manually go to voicemail to retrieve messages.

Hi @stephend.we6wpw and welcome to the Community!

Generally, with Republic service, this warning may be ignored.

I’m uncertain what steps were taken to “reset voicemail”. I do not recall being prompted for a PIN related to visual voicemail. Republic does require a PIN when dialing into voicemail.

The above said, please see if the steps noted here restore your visual voicemail:

I’m also moving your post to an already existing topic on this subject. You may wish to read through it starting here:

1 Like

Southpaw:
My Pixel 4a/5g is on Android 12 now (with all apps updated and R.W. app at 3.30.3.13).
When I open Voicemail immediately after reboot I get:

Activating Visual Voicemail:
You might not receive voicemail
notifications until visual voicemail
is fully activated. Call voicemail
to retrieve new messages until
voicemail is fully activated.

It then has a button to “Call Voicemail”

That’s the same as on my Pixel 3a. That message doesn’t change since visual voicemail never activates.

At this point, the discussion may belong in the topic discussing visual voicemail issues, however, for what it’s worth this is what I see on my Pixel 4 XL running Android 12:

The “Can’t activate visual voicemail” message is a glitch with Google’s Phone app that precedes Android 12.

That said, it sounds like both @larc919 and @muerte33 are seeing a different error message. If I’m understanding @larc919 correctly, the error message he’s seeing also precedes Android 12. @muerte33 did your experience precede Android 12 or is this new since the update.

Would either or, better yet, both of you be able to post a screenshot? Have either of you tried toggling off visual voicemail, restarting the phone, then toggling visual voicemail back on to see if you’re able to get to what my screenshot shows.

This is nothing new for me, it was happening on Android 11 too. Here is a screenshot:

You get an audible alarm when the voicemail arrives, but had to reboot the phone to see the voicemails frequently (so they would show up in the list of voicemails).

Also, RolandH…
I did the turning off Visual voicemail, reboot, turning it back on, and it still shows the same message I posted above, but as a bonus, it looks like the voicemails populate the list now without rebooting, so thanks.

1 Like

I’m getting exactly the same message that @muerte33 is getting. It happens after a normal reboot and a reboot following a RW credential reset. It always fails to activate. When I go to Settings > Voicemail immediately, the Visual Voicemail button is on and blue. When I recheck later, the blue has often changed to red. Since I always turn my phone off overnight, it has at least one daily chance of restarting the activation process.

Have you toggled it off and back on?

Have you tried what @muerte33 said worked for him, above?

Turn off the Visual Voicemail in the phone app’s settings.
Reboot the phone
Turn on the Visual Voicemail in the phone app’s settings.

You can ignore that message. It remains even when the voicemail list populates the voicemail tab.

Thanks, @southpaw. Time will tell, but that may have worked. The settings button was red when I turned it off and still red after I rebooted and turned it back on. But I do now have a message that I don’t have any voicemails. The last time I had the message that I had none, I called and had 2. The voicemail settings button is still red instead of blue, BTW.

Wow, this is bad, ALL of my voicemails - GONE. Just vanished.

Moto G Power - Android 11

Hi @miker.smtc6x,

They are still there. They just aren’t loading into the phone app.

Please try some of the options in republicwi.re/vm and let us know if you have any success.

If the loss of your voicemail messages would be tragic, please save them somewhere other than the Republic voicemail server. It’s not meant to be a long-term storage option.

I have a MotoX4 Android 9.
I go to Settings > Apps & Notifications > Phone > 3 dots in upper right hand corner > uninstall updates and it’s “fixed”

I was just wondering how best to do this one second before seeing this.
Thank you

The only problem is - it tends to revert and you have to redo it again. It only takes a couple of seconds tho - still better than calling voicemail, imo

3 Likes

Right I forgot to add that this is a rinse and repeat operation lol

Workarounds that have to be repeated regularly shouldn’t be necessary for more than a short period. I’m trusting a fix is currently being worked on, although I don’t recall seeing any statement to that effect. Maybe I somehow missed it. I’d hate to think we’re going to have to live with this until DISH decides to institute whatever system changes they are planning.

Granny48, have you tried using Republic Wireless own spam call blocking? I’ve been using it for quite a while now and get zero spam calls. To set it up go to the Republic Wireless app, “your phone info”, “configure spam call blocking”.

1 Like