No WiFi calling problem resurfaced

I’m not sure this has to do with the new app versions but I have been experiencing this issue again for the last 3 days.

At times I can flick WiFi off and on and the WiFi calling will work. Testing it less then a minute later it’s back to the no WiFi calling message. As of today, I can hardly get it to work at all.

I have tried moving between the 2.4 and 5 GHz bands and 2 different routers (3 if you include Xfinity’s hot spots).

No luck with resetting the WiFi mobile and Bluetooth setting either.

Disabling spam call blocking…no change.

Cell call are not an issue (other than I can’t get a cell signal at my home.)

Again, I’m not sure this has anything to do with the newer app version but it happen around the same time.

@southpaw, If you feel this is not related please let me know. I might need to open a ticket.

Hi @SuperT,

Let’s start at the beginning and make sure we have a thorough checklist of everything you’ve done.

  1. Reboot the phone
  2. Reboot your WiFi network, then after it is fully rebooted, reboot the phone.
  3. Tried different WiFi networks
  4. Reset network settings
  5. Disable spam call blocking

Have you tried?

  • Refreshing the Republic activation
  • Making certain the phone is not in Airplane mode (Okay, that’s probably just my own little oversight… don’t judge)
  • Uninstalling and re-installing the RW app
  • Making sure there are no updates to the Phone app
  • Clearing the phone app’s cache?
  • Making sure the phone has functionality on the internet when the phone is in this state?

Could you share a screenshot of the error, or do you have any way to determine whether the error is coming from the RW app?

Could you try both enabling and disabling the phone’s WiFi calling function to see if it works one way or the other?

Hi @southpaw and thanks for looking at this,

In order:

  • Refreshing avtivation does not help
  • I need to be in Airplane mode at home due to a very weak cell signal.
  • Uninstalling and reinstalling the Republic app does not help.
  • Phone and apps are up to date.
  • Clearing the phone app cache does not help.
  • The phone can get to the internet, texting, browsing is not affected.

The Pixel 3a does not have a switch to turn it on or off. This is what I get when I press “Enable” (from screen shot above)

The Republic article does not seem to apply to my Pixel. This is what I see under Network and Internet:

The only way I have found to bring WiFi calling back is to turn WiFi off and on (on the phone). It will then sometimes work. It won’t drop a call when it is working… but it can go back to not working after the call.

@SuperT - Just curious what the Republic Wireless app notification is reporting when you are in Airplane Mode with just WiFi enabled.

When you swipe down once on the notification bar are you getting –

“Airplane Mode: Not connected to the cellular network”

Like this notification with a small blue arc –

Blue Arc Screenshot_20200711-141313

Which my understanding means

  • Airplane mode is enabled. This state is unaffected by WiFi being enabled and/or being connected for Republic calling.
  • Empty blue arc

All we have are Moto G6s in the house so can’t do any direct comparisons with a Pixel 3a. We run our phones for weeks at a time in the same configuration as you (Airplane Mode On/WiFi On - no cell service) when we are in Mexico and they work great.

Just trying to seeing how the app might be responding on your phone. One more data point!

Sorry, I should have been more clear. Make certain that WiFi is enabled when you are in airplane mode.

Interesting. One of our engineers did see this same behavior, but did not indicate if/how he got around it. I’m not sure if this is specific to the version of the app you’re on, but do you want to try rolling back to a previous version? (If so, I’ll DM you some details.)

hi @freddyp :slight_smile:
Yes, mine looks like your screenshot.

Added: I also get the green filled in arc saying connected to WiFi.

When WiFi calling works… I have see it in both those states.

Ok, I think that would be a good trouble-shooting step :slight_smile:

My phone also had a monthly security update from Google on the 6th (maybe 7th). :face_with_monocle:

(Just to throw that into the mix)

Hi @SuperT,

Thanks for continuing the discussion with me in our DM. I just want to sum up some things we went over, so others who might be experiencing calling problems on Republic app versions 3.28.2 and 3.28.3 have some context. Please let me know if I miss anything of importance.

Our developers became aware of some calling issues related to the Spam Call Blocking feature in these two versions of the app. When you initially posted, the description you gave was not similar to what our developers had seen, so I thought your issue might be unrelated to the issue they were working to resolve.

However, when you indicated you were seeing WiFi calling error went to a black screen when tapped, that did align with some of the examples our developers had provided. The workaround for calling issues in 3.28.2 and 3.28.3 is to disable the spam call blocking feature and then reboot the phone.

When you took those steps, the calling issues you had experienced went away. You even were kind enough to test re-enabling the feature to confirm the calling issues returned and could again be banished by disabling and rebooting.

Meanwhile, our developers spent the weekend working on a solution and releasing an update to the app. Republic app 3.28.4.0 has been released to the Google Play Store but is not immediately available to everyone. You have now installed that, re-enabled Spam Call Blocking, rebooted, and will be testing that over the next day or so.

Yep :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer