No WIFI calls available after updating Pixel 3 to Android V10

What phone do you have?
Pixel 3
What plan are you on?
New +1G
Does your plan include data, or just talk & text?
Both


Issue Description

After completing update message said it could not find WIFI for phone calls

Hi @mattheww.skgnsy - Does the phone connect to any WiFi at all? If so, have you updated the RW app? The latest version has “Improved performance for users on Android 10.”

You might also try updating the Data Profile using the following How to How to Update the Data Profile for Android 10 – Republic Help

I do not have a Pixel 3 or a phone running Android 10 so have no way to compare operation after an upgrade. Did find the following article about troubleshooting WiFi internet issues on a Pixel 3 XL. Might try running down the steps and see if anything helps.

There might be some others members in the Community that has faced this on their Pixel after the upgrade. If so, I’m sure they will weigh in with some suggestions.

1 Like

Thank you

We are using WiFi, but was concerned about message after completing update to V10

MPW

@mattheww.skgnsy have you made any calls over WiFi since the upgrade?

Wouldn’t hurt to reboot the phone and then do some test calls. Could have been a message left over from update that simply did not clear correctly.

1 Like

Doesn’t android 10 have a form of wifi calling? Maybe it needs to be disabled or reconfigured? It might be interfering with rw wifi calling.

1 Like

I will try a reboot; happened with both new phones; republic plan moved from Sprint Coverage to T-Mobile when we had to change away from our original Republic Wireless plans

MPW

@mattheww.skgnsy - just confirming, the phones were working properly over WiFi and cell before the Android 10 update, right? You got an error message after Android 10 update and now you are not sure you can make calls over WiFi?

Are you still getting an error message? Have you tried making WiFi call using How to Test Calls information sent earlier?

The CDMA (Sprint) vs GSM (T-Mobile) coverage should only be a factor for cell coverage. Just making sure I understand the problem :smiley:

Hi @mattheww.skgnsy,

Could you please make sure the Republic Wireless app is up to date?

If you need CDMA coverage, please let our help team know:

2 Likes

Phone says connected to WiFi. Phone is working. We still get message saying couldn’t complete setup for WiFi Calling and when we click on the message it opens a blank page titled WiFi Calling, but doesn’t load anything.

MPW

Hi @mattheww.skgnsy - If it’s not too much trouble can you take a screenshot of the message and post it. Might help determine the source of the problem.

Here’s a Google page with steps to take a screenshot if you’re not familiar with the steps.

https://support.google.com/pixelphone/answer/2811098?hl=en

Thanks!

1 Like

Hi

Here is my screenshot after I restarted my phone

Image

MPW

@mattheww.skgnsy had a problem posting the screenshot to his other post but I was able to get it through a DM. Here’s the screenshot so everyone sees the notifications on the phone –

Please see this article:

3 Likes

I will keep trying; within our Mobile Network section and Advanced, there is not a WiFi Calling option

MPW

As indicated in my post you were pointed to:

If the option isn’t present on your phone, then unfortunately only a network settings reset will fix the issue.
Before you take this next step, please note it deletes all Bluetooth and wifi connections, as well as resetting the cellular connection.

Go to Settings > System > Advanced > Reset Options > Reset Wi-Fi, mobile & Bluetooth
Read the warning, tap “Reset settings.” You will be warned a second time. Tap “Reset settings” to confirm. The process will usually take 5-10 seconds and the cellular signal bars icon will go away for a moment. Once the cell signal bars icon returns, you should reboot the phone.

2 Likes

Thank you

Upon reboot, error message did not appear!

MPW

2 Likes

Looks like I’ll have to do that step each time Android is updated :pensive:

Message an
Expert customer