No wifi calls or text

I have a moto E gen2 will not make calls on wifi. or text. app shows connected. I have no cell service here only wifi. It keeps trying to use the CELL. Tried airplane mode. then turned back on the Wifi. try to call same thing. If i get to Cell service area it will call and text. Funny with just the Wifi other apps work? Facebook twitter? so the it is connected and able to get data. Republic app will not call or text on Wifi? app is up to date. Like its always trying to use cell?

I tried calling from next door to the Republic phone just got voice mail. So no incoming calls too. Reset wireless No help same.

Hi @thomasw.6d1q5c,

Can you confirm you are connected to your own network?

What does the status notification for the Republic app indicate? Does it say “Cell calls and SMS, WI-Fi Data”?

Have you tried rebooting the phone?

Have you tried the troubleshooting steps, including resetting the Republic credentials, here: https://community.republicwireless.com/docs/DOC-1959-make-and-receive-a-phone-call#jive_content_id_If_Your_Phone_Is_Stil…

Does the issue persist on a different Wi-Fi network?

Message an
Expert customer