Not getting voicemail notifications or seeing them in the phone app - Republic App version 3.30.0.80

What phone do you have? Moto G(7) play

What plan are you on? 2G data/voice/text

Does your plan include data, or just talk & text? All of the above


Issue Description

Several people told me that they left me a voicemail yet my phone is not showing that I have any voicemail.

  • Check to ensure the following:
    • You are using Google Messages :messages:
    • Within the app you have turned off RCS (Chat feature, not supported by RW)

Hi @robbiem,

When you dial into voicemail are you able to hear the messages?

1 Like

Do you mean by holding down the “1” key? When I do that it says “Please enter your password followed by the #.” As soon as I enter my code it hangs up.

Could you please try entering the password with either the call on mute, or by first putting the phone on cell before pressing one? Sometimes calls on WiFi do not do a good job of transmitting the DTMF tones to validate the password.

Google Messages is for texting, right? How does this stop me from getting my voicemails (which is a brand new problem)?

I think @jben may have misread the question. Google Messages is not related to voicemail.

1 Like

Yes, my too rapid and too wobbly reading … work with @southpaw on this one

So, I went in to the RW app and hit the button requiring a passcode for voicemail and it prompted me to add in a 4 digit code. I entered a new code (even though I had done this in the past) and then tried to access voicemail again and it worked! So, if the button for requiring a passcode was off, then it shouldn’t have required a passcode and it should have just given me my messages.

Regardless, it’s now working and I was able to get those messages that I knew were there but couldn’t access. Thanks All!!!

The password is required for the security of your account, regardless of whether the toggle is on.

I’m still concerned why you’re not seeing a voicemail notification and why you’re not seeing the messages listed in the Phone app.

1 Like

Hi @robbiem,

Thanks for bringing this matter to our attention. With some help from @rolandh who also noticed he was not seeing Visual Voicemail or his voicemail notification after his Pixel 4XL’s battery was replaced, we’ve noted that this seems to be happening in Republic app version 3.30.0.80. I’ve alerted our app development team, and I’ll let you know when we have a solution so you don’t have to keep checking your voicemail manually.

p.s. I’m editing the title of your topic to clarify for others browsing the Community that this is specific to the latest app version, which is not yet available to everyone.

What phone do you have? Moto E

What plan are you on? ?, but 15.00 a month

Does your plan include data, or just talk & text? talk and text, wifi


Issue Description

Visual voicemail not working. It was before but app updated and now it won't . Tried uninstall but it not uninstall the update that makes it fail. My wife's Moto E works just fine.

Hi @tomp.aspypb,

Is your Republic app version 3.30.0.80? If so, we have had a couple of reports this weekend of Visual Voicemail failing to load and no voicemail notification. You can still dial into voicemail to listen to your messages, but clearly having to check to see if you have any is not ideal, and I hope we’ll be able to roll out a solution very quickly.
If you’d like to move back down to the previous app version and then just ignore the prompts to update to 3.30, just let me know and I’ll help you do so by personal message.

I am having the same voicemail issue. How do I set up a password to be able to check it? 2 people said they have left me voice mails.

Hi @janedvt and welcome to the Community. See if this helps, assuming you have a 3.0 phone - How to Set Up or Change Your Voicemail Password on 3.0 Phones

And here’s a link if you have a 2.0 phone - How to Set Up or Change Your Voicemail Password on 1.0/2.0 Phones

Hope this helps!

How would I know if I had a 3.9 phone?

Hi @janedvt - sorry for the typo, should be 3.0. Anyway, see if this link helps you identify what phone you have.

Or let us know what phone you have any someone can check the list.

I have a Moto that I got in 2020. So probably not a 3.0. When I tried to follow the directions, I did not have a “call and voicemail settings” choice.

I just found out that I was not receiving voicemail either. I just checked and I have the update to 3.30 and no visual voicemail. I have to dial in to check. No problem with the pin working, just no longer having VV. In fact, no notification of voicemail in any form. I hope y’all get this fixed soon, it is a pain.

Hi @janedvt,
A phone bought new in 2020 would be one of our 3.0 phones.
The instructions in How to Set Up or Change Your Voicemail Password on 3.0 Phones – Republic Help are the right instructions for your phone.

Message an
Expert customer