Not receiving calls over wifi in Canada

Hi @amackay2,

Please check your Republic app and see if it is either of these version. ( 3.28.2 and 3.28.3)
If your Republic app is one of those versions please:

Open the Republic Wireless app.
Then tap the settings gear :gear: at top right.
tap call and voicemail settings
tap configure spam call blocking
and make sure it’s set to allow all calls.

Once that’s selected, reboot the phone.

This would be a temp fix till you get the new app version which is currently being released at which point you can return the setting back.

Hi @amackay2,

When calls go straight to voicemail, has the phone been sleeping for an hour or more?

Checked the app version and the settings. It was already set to allow all calls. I keep calling my phone and it seems to be working at the moment. I’m going to try giving it an hour and see if it will still ring as suggested by rolandh below to see if it will go straight to voicemail.

It seemed to work most of the day and I checked frequently by calling my phone. However, it has stopped receiving calls again. It was asleep for more than an hour this evening but had also been asleep previously during the day for just as long.

@jben, might this be a manifestation of the doze issue? To the extent I understand that, it generally presents itself when doze turns off WiFi in the presence of a weak cellular signal. In Canada, cell signal would be about as weak as it gets as in non-existent as far as a Republic activated phone is concerned.

@amackay2, an additional question if you’ll indulge me? What SIM type is your phone using? Here’s how to tell:

I checked and it’s GSM

Unfortunately, the timing of when Doze goes into effect varies by phone and the ability to detect with any certainty is questionable. I am still working with Macrodroid to try to come up with something to offer, but at this point I would suggest trying KISS-30 in Managing Doze Mode - (phone is on WiFi) calls via cell | calls go to voicemail | calls are missed

1 Like

Hi @amackay2 – I can offer some simplified download and installation instructions for KISS-30 if that’s something you want to try. Here’s a link to some of the background and technical information for KISS-30 located later in the thread @jben posted.

This might help you decide or you might find the information TL:DR :grinning:

KISS-30 is easy to install and get running. KISS-30 is a brute force method that simply turns the display on every 30 minutes. The display shuts off after 15 sec so there is very little battery drain. Turning the display on every 30 minutes keeps the phone from going into DOZE mode which in turn keeps the WiFi on. We basically set KISS-30 and forget it on our Moto G6s.

1 Like

Thank you. I downloaded macrodroid and am trying to understand how it works and have created a macro that looks the same as kiss-30.

In the ‘Managing Doze Mode’ link it states that the phone won’t enter doze mode when the phone is plugged in. I have the issue with calls going straight to voicemail even when my phone is plugged in and it doesn’t begin receiveing calls again until I restart my phone. Dose that mean it’s not a doze problem?

@amackay2 - if you still have the problem when phone is plugged into the charger then it is not a DOZE issue (as I understand it). You can always try the macro and see if it helps. Not sure what differences there might be between models of phone and Android DOZE implementation. Had my :crossed_fingers: that KISS-30 would help :confused:

Curious - did you get the latest RW app update? Would be worth doing an RW app update through the Playstore. Not sure it will change anything but knowing you’re on the latest version might help others looking for a solution too. Let’s see if others have some other ideas :thinking:

The app is version

Hi @amackay2 - thanks for providing the app version. Have been reviewing the thread and scouring the web to see if there is anything the Community may have overlooked.

There is another troubleshooting step that has not been tried. Some third party applications have been known to cause problems with Republic Wireless phones and service. So to test, boot your phone into Safe Mode. According to this document, if your Moto x Pure is running Android 7.0 Nougat (or above) the RW app will continue to work. Turn on Airplane Mode and then turn on just WiFi (same configuration you have been testing). If this helps, it would indicate that a 3rd party app is causing an issue.

If this does not help, we’re at a point where I would suggest you open a help ticket if you are still having problems. Would point them to this thread so they can see what steps have been tried and the information shared. Support might see something the Community has overlooked.

Thank you so much for your help! I have my phone in safe mode and will continue to test it today to see if it solves the problem.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer