Not receiving emergency alerts on my Samsung S10+

I am not receiving emergency alerts on my Samsung S10+. The settings for this are located in the Samsung messaging app, and they are all enabled. But they do not work because I have to use the Android messaging app as my default for republic wireless, which then I turn appears to disable all of the Samsung messaging apps functions when it is not the default application ( I just double checked by setting Samsung’s app as default, then setting it back to Android messages, all the while my wife’s Moto was getting flash floods warnings). So what are my options? Am i stuck with either no emergency alerts or some non functions messaging features? Is there another app I can get or another work around? Thanks

Hi @bobp,

You are quite correct that Samsung has made the curious choice to locate emergency alert settings in its Messages app. That said, I’ve not seen those settings become disabled when Samsung’s app is not being used as the default messaging app, however, my newest household samsung phone is running Android 9 rather than Android 10.

So, when you try the following when Samsung’s Messages app is not the default:

Open Messages
Tap three stacked dots upper right
Tap Settings
Tap Emergency alert settings
Tap Emergency alerts

Are Extreme, Severe and AMBER alerts all toggled off? If so, will they toggle on?

When I open the Samsung messages, I get an OK or Cancel. Clicking OK I then get prompted to set my default messaging app, which is currently set to Android messages. I then can either switch or cancel it. Clicking cancel takes me into the app. Once in the app, All options under Emergency alert settings> Emergency alerts > are on (toggled to the right). They are set to vibrate, and play alert sound, as well as a reminder to go off every 15 minutes. Location based alerts are on. and the preview plays loud and clear.

I would try toggling everything off an back on. After that, there’s not much that can be done. The FEMA estimates that about 75% of eligible cell phones actually receive an alert when it is issued ( PSA: All US Cell Phones to Receive ‘Presidential’ Alert Today | PCMag) A variety of circumstances from the tower you’re connecting to, to the state of your phone when the alert is issued could cause you not to receive it.

The process of toggling does not fix my issue, I have tried this a few times over the past few months. My steps:

  • Open Samsung messaging
  • Set Samsung messaging as default when prompted
  • tap 3 dots
  • tap emergency alerts settings
  • tap emergency alerts
  • toggle all options off
  • toggle all options on
  • Switch out of Samsung messaging
  • Open Android messaging
  • set android messaging as default
  • Wait for emergency

I’m not a Samsung user, but I pilfered this from AT&T:

Enable/Disable Emergency Alerts

  1. From the home screen, swipe down from the Notification bar then select the Settings icon .

  2. Select Connections , then scroll to and select More connection settings .

Image 3

  1. Select Wireless Emergency Alerts , then select Settings .

Image 4

  1. Select Alert types . Select the desired switches to enable or disable the desired alerts.

Note: Learn more about Wireless Emergency Alerts (WEA).

Image 5

Unfortunately, that option is not located on the Samsung, on the more connections screen. It is (as far as I know) only under the Samsung messaging app. Which I feel now, Samsung did to try to force using their app vs others. :frowning:

1 Like

Cool, thank you cbwahlstrom! Just downloaded it and I will give it a try.

1 Like
Message an
Expert customer