Not receiving MMS w/ pic from a Verizon customer

What phone do you have? 1 Moto g5+ and 2 Moto G7

What plan are you on? Talk & Text Only

Does your plan include data, or just talk & text? Just talk & text


Issue Description

Sometime after March 14 all three our Republic phones are not receiving the MMS w/ a pic attached from a Verizon postpaid customer - me. I disabled the chat feature on the Moto g7 first as mentioned in a couple other posts. I also updated the dialer. Neither fixed the problem. A MMS pic attachment from What’s App is rec’d on the moto g7. It doesn’t work on cell either. Last night when on cell phone the symbol displayed was a LTE & an x. Both cell & roaming data are on. The Republic phones all seem to be able to send MMS w/ a pic to each other… It’s a mystery. :slight_smile:

Once I get one phone working, I will tell my college kids how to fix their phones. Maybe we need to open a help ticket??? Thanks for the help.

  • Normally if something fails with only one input (your Verizon postpaid phone) one would suggest that to be the culprit.
    • However, you may want to start by ensuring that you have done the following on now the RW Phones, to test.

How to Refresh the Republic Wireless Activation – Republic Help

Thanks for the suggestion to refresh the Republic Wireless activation! I did that last night. Used the wrong wording in my post. I don’t think it’s Verizon because I can send a MMS w/ a pic from a different source - WhatsApp from Verizon to our Republic phones. (But I could be wrong) Maybe something is wonky with sharing from google pics & MMS? Or the Android Message app? But we all have it - Verizon & Republic. How does one determine & fix it?

For the sake of clarity WhatsApp does not use MMS. MMS is used for picture messaging and group messaging between mobile phones on various networks. WhatsApp, like Apple’s iMessage does indeed send/receive picture attachments, however, is a proprietary implementation that bypasses MMS.

If you’re seeing an x next to the cell strength indicator, the tower your phone(s) are connected to isn’t providing cell data or your phone isn’t accessing it.

It’s entirely possible it’s the tower and not the phone. Might we trouble you for a zip code (nothing more) for the purpose of assessing cell coverage in your area. We would also need to know the Republic phones’ SIM type(s). The how to on that is linked here: How to Tell If a Phone Is Active on GSM or CDMA – Republic Help.

To be certain we are understanding the issue correctly; the Republic phones are able to exchange picture messages with each other (not WhatsApp) on WiFi?, Cell? Or, both?

And, is it your phone that’s on Verizon or someone else’s phone?

We are a family of 4 with 3 Republic phones (2 Moto G7 & 1 Moto g5+) & mine is Verizon but also a Moto g5+. One Moto G7 is hubby’s & the one to try things out on.

I didn’t realize WhatsApp doesn’t use MMS. I initiate a text (Verizon), choose my attachment (my photos in Google photos or ones that come through WhatsApp. On my phone it says a MMS was sent. I assumed my text was indeed a MMS. I am the only one that has WhatsApp.

The Republic phones are able to exchange picture messages with each other on WiFi. Haven’t tried cell yet. It’s hard to nail down college kids. :slight_smile: They just say they are not getting my picture apps via Verizon.

Zip code is 46703. All Republic phones are on cdma. When we got them the GSM sim card didn’t work well but maybe that has changed??? Our wifi is usually pretty good so we aren’t aware of cell lacking or noticing the symbol so much…

I will also reach out to Verizon to see if they could help also. Thank you for your help!

Let’s leave WhatsApp out of the equation for now. Are you using Messages by Google as the default text messaging app on your Moto G5 Plus with Verizon? If so, have you turned off RCS Chat on your phone as well as your family’s Republic phones?

Thank you! According to the coverage maps, CDMA coverage is still superior to GSM in your area. You mentioned seeing an x near the cell strength indicator. Is that on your Verizon phone, your husband’s Republic phone or both?

Hubby’s phone has the X. Mine is fine.

My phone has no x. Coverage seems fine with Verizon.

Hi @paulat.0p5ea5,

My apologies for all the questions, I’m trying to narrow down the source of the problem. The x next to the cell strength signal indicator on your husband’s Moto G7 indicates his phone is not receiving cell data from the tower to which it is connected. Without a cell data connection, he wouldn’t receive MMS away from WiFi though he should receive MMS when connected to WiFi. If I’m understanding correctly, he is connected to WiFi and is able to exchange MMS with your family’s other Republic phones? If that’s the case, I’d suggest resetting the network settings on your husband’s phone as described by Republic here:

Resetting his phone’s network settings will delete all previously saved WiFi networks, so he would need to sign into those again.

On another note, are you able to exchange MMS messages with folks not using Republic?

OK, I will try resetting his phone shortly.

I can exchange MMS with other Verizon customers. Haven’t tried other providers other than Republic :slight_smile:

Yes, hubby is receiving MMS w/ images from other Republic customers on wifi. Which is our kids mostly.

What about on cell? It wouldn’t be necessary to know whether the kid’s phones are on WiFi or cell.

Knowing whether you are able to successfully exchange MMS with folks not using either Verizon or Republic would narrow down whose problem this is likely to be. If you’re unable to exchange MMS with folks using neither Verizon or Republic, it would suggest a Verizon issue.

1 Like

Ok, will try MMS with others this evening. On a chat now with Verizon to see if anything is on that end. Thanks!

1 Like

Sorry for another question - do I still need to reset the network setting for hubby’s Moto G7? I see after watching it, it is going between 3G & LTE x, although it likes LTE X more this afternoon.

I was able to send a mms & image on cell coverage from his phone to my Verizon & to our Republic daughter. It did take a few moments & I missed the symbol. I am guessing it went out under the 3G.

Verizon has been less than helpful. They wanted me to log out of Google on my phone. I didn’t think that was wise but I am open to opinions here. Thanks so much for the help!

I have successfully sent a MMS image from Verizon to an ATT friend. ATT friend send MMS image to hubby on Republic cell. Didn’t try WiFi. Wanted to test cell without having reset his network. Does that help?

To a degree, yes. Regardless of whether it’s exchanging MMS messages with your phone or others, your husband isn’t going to be able to do so when his phone is showing an x near the cell strength indicator and he’s away from WiFi. MMS requires a data connection (WiFi or cell). For his phone to exchange MMS messages, it either needs to be on WiFi or have access to cellular data. Ideally, he wants to see LTE. 3G may work but neither will work if the x is present. The previously suggested network settings reset might help with the x situation. A cellular settings reset also might help:

Otherwise, if you continue to have difficulties exchanging messages with your husband’s and other family Republic phones and you know they are connected to WiFi or cellular data (no x), then there may be a routing issue between Verizon and Republic. Candidly, that might be on either end and for Republic to investigate would require a ticket.

1 Like

Ok, thanks for explaining the need for cell. Will reset the network & go from there. You have been very helpful & patient with me. I appreciate it!!!

2 Likes

Due to family commitments & church, I haven’t yet done everything suggested. Will be back in touch this evening after all is done.

1 Like

On hubby’s Republic Moto G7:
I disabled the chat feature
I reset the reset network settings
Reset cellular settings.
All phones in family are using Messages app by google that came on our Moto phones.

My phone w Verizon, the chat was already disabled

Still he is not receiving MMS w an image from me/Verizon. No difference whether my phone is WiFi or on cell data when sending.
He can send me MMS w image both via WiFi and cell.

His phone is still going between 3g & LTE w x in the 1/2 hr I have been watching.

I had success sending MMS w image yesterday to an ATT customer.

Did I miss anything? Is it time for a help ticket?

Hi @paulat.0p5ea5,

I’ve seen a couple of help tickets that look similar, so I’m going to pull them together and create a master ticket so we can better track this issue.

Would you be available to help with some testing tomorrow, if our engineers need examples of text messages that aren’t reaching our server?

Message an
Expert customer