Not receiving text messages from iphones

What phone do you have? I have a Samsung s20.

What plan are you on? 2G

Does your plan include data, or just talk & text?

Issue Description

I just switched from Republic’s iPhone beta to Android this week. I am not receiving text messages from iPhone users. I have turned off imessage on my old phone as instructed. Not sure what else to do. Thanks for any help!


Hi @roselounsbury,
Welcome to the Community! :slight_smile:

Are you using Google Messages or Republic Anywhere for your texting? :thinking:

I’m using the app recommended by republic. Its called Messages but it is not Google messages.

It looks like this

The only 2 messaging apps supported by Republic (for Android anyway), are Google Messages and Republic Anywhere.

Please try installing Google Message…tho I gotta say that icon you just posted sure looks like Google Messages. :thinking:

If so, make sure the RCS feature is off:

And see if that helps :slight_smile:

Added I also don’t see the Republic arch in the upper left corner of your screen shot.
This is probably what we need to look at :face_with_monocle:

Does your Republic app open and everything look normal?

Just checked and yes, it is Google Messages. I also disabled RCS feature as you said. Any other ideas?

Yes, my Republic app opens and everything looks normal to me there.

I’m not an Iphone/Apple person but…I’m gonna give this a go anyway :wink:

When you said:

Did that mean “Deregister”?

So my husband was finally able to text me by turning off imessage on his phone, messaging me, and then turning imessage back on. I’m concerned that my other friends, clients, group texts I’m in where I’m on the thread as an imessage originally will obviously not know to do this. Is there anyway to make sure I get text messages from people who have me on a thread as an imessage originally?

Thanks for your help! Yes, I turned off imessage and Facetime on my iphone device and then went online to officially deregister on the apple site, too. So imessage is 100% deregistered for me.

We’ll need to wait for other Community members that have some experience with iphones. :slight_smile:

I see @rolandh typing away…I am sure he will have a good a solution for you!

1 Like

Hi @roselounsbury,

Presuming the move from iPhone to Android just happened today, I suspect it will clear up of its own accord in the next day or so as your correspondents’ iOS devices communicate with Apple’s iMessage servers and are “informed” your number is no longer in the Apple ecosystem.

Otherwise, I’m afraid there isn’t a global solution here. If you hear from others they’ve messaged you and you’re not receiving their messages, ask them if they’re still seeing blue bubbles rather than green bubbles when they message you. If so, their devices are still trying to reach you over iMessage. They would then either need to delete, then recreate your contact entry on their device or try your husband’s solution.


Thanks @rolandh - guess I just need to wait and see if it sorts out as Apple recognizes that I’m no longer in their ecosystem. I appreciate your response and help!

Just wanted to update and let you all know that deregistering iMessage plus waiting overnight seemed to be the fix. I was able to send and receive texts from iPhone users this morning. I am now going back through all the messages I’ve sent in the last couple days and resending to those that sent as iMessage. I can tell because those messages show up as a dark blue bubble. So there’s a bit of catchup work but I feel hopeful that this is solved. Thanks to all who helped me! Much appreciated.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer