Often get 'Cell Data Restricted' message


#1

I live in zip code 19087, which is part of the western suburbs of Philadelphia. According to the Republic coverage map the 4G LTE reception is ‘strong’ in my area. Yet I find that I often get a message to the effect that ‘Cell data is restricted’ - no internet, just SMS, etc.’ - I forget the actual wording of the message but it is something to that effect. Today I decided to take a local hike (just a few miles away) and for about half of the hike (which was on level ground, not in a valley) I got this message. Irritating.

If it matters, I have a moto e4plus (most recent generation) and a 3GB plan (and I am not close to tapping it out this month).

Wondering what can account for this. Simply being out of range of a tower or something else? Thanks


#2

Is there a possibility that you have turned ‘Data Freeze’ on? This would limit you cell data to just that that is required by Republic for calling, SMS, MMS ando other functions it needs (the data used is not deducted from the data you purchased)

  • This can be found in the Republic App on the home page as data tools or if not there (Thanks @davidw.ctd2jy who found it under Settings/Data Tools/Data Freeze

#3

Thanks for taking the time to reply.

Yes, Data Freeze was indeed on. I didn’t bother checking that since I did not remember fooling with those settings, but apparently at some point I had.

Thanks again.


#4

There are a couple of other things in The RW App, that you may want to turn on … they caught me a couple of times :blush:


#5

Thanks for the note. Strangely, when I try to get to ‘Advanced Settings’ in the Republic app, nothing happens. That is, I don’t get the page that you show above. I can drill down to the other settings from the summary settings page (e.g. Data Tools, Voicemail Settings, etc.) but not Advanced Settings. Weird.

I checked Android settings to see if there might be something analogous there but did not see anything. Thanks again.


#6

What level is your RW App? RW App/Settings/About …3rd line under your phone number


#7

It is 3.23.0.65


#8

Same as mine, I don’t have an E4 to test, but AFIK the RW App should render the same for all phones … anyone know of differences or having an E4 to verify on, please chime in

  • Have you powered off/on and tried in Safe Mode and still don’t see it?

#9

Well, this is the damndest thing. I just tried it again and this time the Advanced Settings page popped up.

Before, when I touched the Advanced Settings line on the summary page the line would just brighten for a second and then dim, going back to its original appearance. I have not restarted the phone so cannot account for why it is suddenly working.

Thanks again for all the help.


#10

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.