Ok Google is not working


#1

I have a Motorola moto X pure. When I try to use OK Google like ‘remind me to xyz’ it stops in the middle and says unable to reach Google. I think the Google assistant and the Moto app are interfering with each other. Help.


#2

OK Google needs data to work. If in wifi no problem but cell maybe an issue depending on native data or roaming data. There isn’t roaming data!


#3

It happens on wifi


#4

Hi @jefferyb,

Some good troubleshooting steps would be:

  • reboot the phone
  • make sure your google-related apps are up to date
  • clear the cache
  • test for Wi-Fi connectivity by making sure the phone can do other things when on Wi-Fi

#5

I am having the same problem with a Moto X2. I have rebooted the phone numerous times, made sure all apps on the phone are up to date, cleared the system cache and cache of apps that I think might be involved. Also, tried in safe mode on both wifi and cell data and uninstalled apps that I think might have a conflict.

In addition to the “can’t reach Google” sometimes the error message is that the internet connection is not reliable. I am not sure how long this has been an issue. I became aware of it a few days ago after pairing the phone to a new bluetooth car speakerphone. Once I realized that the problem was with the phone rather than the speakerphone, I turned off the phone’s bluetooth and have been trying to problem solve.

I don’t want to do a factory reset just yet. I hope someone has a solution.


#6

Hi @jefferyb, @davidm.ewm7yv ,
I have a Moto X2 & when I had issues with my “Ok Google” I had to find and delete all updates on the apps that controlled it. Then I rebooted my phone after the reboot I updated all the apps I deleted previously then rebooted the phone again. Ok Google still works as of today.


#7

bocephous, Thank you for the suggestion. I did as you advised for every app that has the option to uninstall updates which was 32 apps for me. I did several tests and it seems to be working. Thanks a lot!!!


#8

I have the same problem on my MXPE unless I turn off Moto Voice in the Moto app. I think you’re right that the conflict arises because both apps are trying to access the microphones.


#9

Hey @davidm.ewm7yv
Glad I could help you out with the answer. I really like the hands free OK Google when I am on the road. It beats getting a ticket and the texts are read aloud where I can hear them clearly. My answers work now too.


#10

@jonathane.3d74pp
Delete the updates to the google apps in the app drawer reboot the phone. Update all the apps again then reboot one more time. @davidm.ewm7yv did what I suggested and he is working again. Apparently something gets corrupted and refreshing the updates is a fix for it.


#11

How does one delete updates? The only option is Uninstall?


#12

Yes I meant uninstall updates to the factory app. Reboot the phone then do updates to the apps that need updating.


#13

Hi what is the factory app? There are several Moto apps and several Google apps? Do you mean uninstall them, reboot, and then install them again? Once again there is no choice to “uninstall updates.” The only options I see are “uninstall” and “open.”


#14

Hi @jefferyb
Ok here’s how to do this. Tap the app drawer button :appsicon: —>long press an app that may control Ok Google ----> a window opens and then tap app info. Tap uninstall updates, click on OK in the new window. Do you want to replace this app with the factory version? OK again! Repeat process till you have all google apps updates that could control Ok google uninstalled. Reboot the phone and open the playstore :playstore: tap the :menu: in the search bar. Click on My apps and games & update all that needs updated and reboot the phone again.
Different model phones have different name apps controlling Ok Google or I would name them but it could be confusing. This way you can learn without hurting anything.


#15

I went through that process and still no success. Only one service will work at a time. If I turn off Moto Voice, saying Ok Google starts working again, and vice versa.


#16

Hello. I did that and it still doesn’t work @jonathane.3d74pp thinks it’s because the two apps are conflicting with each other. I tend to agree. When the app asks me, “OK do you want to save this?” It gives me a blank white screen with “Unable to reach google” on the bottom. If I back up, I can manually press save. But I don’t get the option to say “yes” save the reminder.


#17

Well it looks like you are the winner to make a support ticket out . I have run my course and that’s all I got.


#18

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.