Once again, public WiFi is not working

What phone do you have? Moto G6

What plan are you on? MyChoice

Does your plan include data, or just talk & text? Data + Talk & Text


Issue Description

Lately, just about EVERY time I go into a store that has WiFi available to the public, I seem to connect to their WiFi, but I get absolutely NO internet access.
Let me tell you, I really don’t give a ■■■■ about connecting to their WiFi, it’s the internet access I need. This has happened in Starbucks, McDonald’s, Taco Bell, a restaurant called Culver’s, and a number of supermarkets that have public WiFi for shoppers…
WTH am I paying for service for if I can’t use the phone properly???
To give some additional info, the screen says I’m “connected”, but I have no internet, or the phone will say “on cellular”, or “calls on cellular”, etc…
In addition, I know MOST of these places want you to confirm by “logging in” to their WiFi in some way, but for ALL of the places that do not work, I haven’t been asked to log in at all.
So, WTH is going wrong???
This has happened before and I don’t think it was ever actually resolved as I received nothing but more questions that didn’t pertain to what I was asking.
I’m attaching two photos of the screen from two different merchants to show that I’m not getting internet even though I’m supposedly “attached”.

I’ve tried “Forgetting” the networks I’m attaching to in order to get the freaking phone to force me to sign into their network again, but that does nothing.

I’ve got a Moto G6 with MyChoice, and enough of a data plan to handle logins, etc…
So what do I do???

Hi @kevinh.5mc20k,

The next time you connect to a network but are not prompted to sign agree to their use terms, please open the browser and try to navigate to some website you’ve never before used.

Some people have found it helpful to try to navigate to the site of the place where you are located. For instance, if you’re in Wal-mart, try to go to walmart.com.
One of our staff members recently mentioned that he has found trying to navigate to internet.com works for him.

The idea is to force the browser to try to connect to the internet by making it try to access content it has never cached. When the browser tries to access the internet, the captive portal should then hijack the browser and present the terms of use agreement.

2 Likes

southpaw,

Ok, I will try that next time, hopefully that will work.

Isn’t there a way to get the phone to “forget” my prior connections so that it will “ask” me to log in?

I’ve tried this on the individual connections under the belief that when I remove a prior connection, it will forget that I logged in and will prompt me to log in again, but that hasn’t worked, the connection just comes back immediately and tells me I’m logged in (without internet access, of course, since I didn’t really log in).

I’m also finding this a big problem. I’ve been going to places that worked flawlessly with automatically logging into verified hotspots and now no longer work or even give you the login screen. Going to fake or real http addresses also don’t work. Some sites will give me a log screen and allow sign-in but it’s not all sites. I’ve also seen several instances or real saying there are open hotspots here, but the wifi connect screen shows only password locked connections. This happens at locations that used to automatically login as verified hotspots.

I would love to have the verified hotspot option restored. I am finding that I really miss that option. Especially with the new problems mentioned above.

2 Likes

Thanks Majorninth. You point out something interesting here.
I had been on a trip in the western US where even cell coverage was spotty at best, although my friend traveling in the same auto with me kept getting texts from his family while my phone had no coverage whatsoever (he has Sprint, from Sprint itself).
Because I had been away for quite a while, I’m not sure when they turned off this verified hotpots thing, but it could be right around the same time when I first noticed the WiFi at a restaurant called Culvers didn’t work, which was around August 17th, I believe.

Furthermore, I’d like to point out that my wife, with a very old Moto X and a very old Republic Wireless plan which didn’t have anything to do with Verified Hotspots, IS able to connect to McDonald’s, the grocery store, etc. and use their internet without ANY problem whatsoever.

Hi @kevinh.5mc20k,

This part is not relevant to the ability to connect to Wi-Fi networks, but since you bring it up…

Open the Republic app and tap the settings gear. Then tap About. If the “Sim Type” listed is not CDMA, then your cellular coverage is not with Sprint and we would not expect it to be identical to that of the friend traveling with you.

To forget a previous network, take these steps:

  1. Open the Settings App
  2. Tap Wi-Fi
  3. Tap the gear :gear: at the top right corner
  4. Tap Saved Networks
  5. Tap the name of the network you’d like to forget
  6. Tap forget.

Hi southpaw,

I noticed that I no longer had Sprint working on my phone prior to the trip.

I actually thought that would be good because I thought that Sprint + my T-Mobile would be complementary, where I might have service where my friend might not.

Although maybe I was noticing his service much more because his family kept including him on group texts, and I was doing most of the driving on the trip, so I didn’t look at my phone at all while driving (and I wasn’t getting many texts).

I’ve deleted saved networks in the way you described before, only to have them return and NOT ask me to log in.

Furthermore, other people have responded to report the same problem I described originally, so this is not limited to my phone, apparently, this seems to be a(n) RW problem.

If you think it’s a Republic Wireless problem, disable the RW app before your next visit to one of the stores or restaurants with a network you’re having trouble joining. I believe you’ll find that the Republic Wireless 3.0 app is not involved in the joining of Wi-Fi networks. It does nothing to enable nor obstruct that process.

1 Like

I didn’t say it was the RW app itself, it’s something that RW should address.

That’s basically asking Republic to fix a “problem” in Google’s operating system. I’m quite sure they wish they had the power to do so, but don’t. In my family we have phones on Republic, Cricket, T-Mobile and Project Fi. Every one of them behaves the exact same way and often have struggles connecting to public wifi. On my LG G7, on Project Fi, I open Chrome, navigate to sample.com and then refresh the page. 99 times out of 100 this works. My daughter does the same on her Moto G4 on Republic with the same results.

3 Likes

Actually, it isn’t. As another poster here noted, yhe failure to properly connect has coincided with RWs removal of trusted connections, and although I don’t have a definitive date as to exactly when these connection problems started occurring again on my phone, the timing of it points to the removal of this “feature”.

Furthermore, since RW pushes its service based upon the fact that prices are supposedly lower thanks to the use of WiFi, then they should feel responsible for assuring that WiFi works when it is available.

I’m reasonably certain that was at least part of the reason for offering the certified WiFi hotspot feature in the first place. Unfortunately, the partnership didn’t work out and the feature has been withdrawn.

By design, the Republic Wireless app does nothing to facilitate or make more difficult connecting to public WiFi. I’m confident Republic would like it to be seamless everywhere, however, when one does not control the WiFi networks in question, that’s difficult to impossible.

It’s a blunt instrument but the other thing you might try is resetting your phone’s Network settings. Doing so wipes out any saved WiFi connections, in theory, providing a fresh start.

2 Likes

FWIW, I have found I cannot connect to many free WiFi hotspots that I had previously used…(McD’s, Wendy’s, Target, etc.).

Opening a Chrome tab and entering 1.1.1.1 in the address takes me to the login page, and seems to work just fine after the accepting the terms.

1 Like

rolandh,

Thanks.

“Resetting your phone’s Network settings”, certainly sounds like it’s worth a try, can you explain how to do that?

That’s probably better than the suggestions to go to a website to try to force the merchant’s login page to appear. I believe in the past that hasn’t been possible because once I’m “connected” to their network without officially logging in, I’m completely without internet on their network, and any attempt to go to a website is impossible, it’s as though you are trying to go to a website on your home computer when your router is down, it doesn’t work, so those suggestions are missing the mark.

I’ll certainly try those suggestions, I believe I’ll be passing a Starbucks sometime today and I can drop in to give it a shot, but I’d certainly like to try your suggestion about resetting the phone’s network settings if you can tell me the steps to do so.

Actually, the suggestions are only applicable when you don’t have internet access. The point is that trying to go to a non encrypted page forces the browser to attempt to connect, and if the issue is that the merchant’s authentication or terms pages isn’t presenting, you’ll be redirected to that page and therefore it will start working.

1 Like

The how varies depending upon the brand, model and generation of one’s phone. As I don’t know which phone you have; the best I’m able to do for now is suggest you go to Republic’s Help Center, then use the search string “how to reset network settings”. Resetting your phone’s Network settings won’t necessarily resolve your experience, however, it’s the sledgehammer approach to forgetting every WiFi network, your phone has ever connected to.

In theory, the various means suggested by others of forcing a particular WiFi’s owner’s captive portal (the page where one sees and accepts terms and conditions before being granted Internet access) to show itself should work for you. The reality is no one method of forcing a recalcitrant captive portal to show itself works on every WiFi network out there.

No one here is making these suggestions with the intent of absolving Republic of responsibility. That said, by design, it’s the operating system that’s supposed to handle connecting to WiFi (public or otherwise). This is true of every smartphone I’ve used (both Android and iOS).

1 Like

c1tobor,

Thanks for that tip. I’ll try that today when I pass by a Starbucks.

In my experience, it’s not a Republic Wireless problem. It’s a phone/secure site problem. I’ve only been a RW customer for 3 months, and had this problem with Sprint previously. I’ve also helped my Verizon friend, AT&T friend and TracFone friend. I also worked customer service for hotel chains using splash pages for internet access and had the same problem.

Basically, if your phone tries to open a https site, which is the default for the majority of sites, then the splash/connect page doesn’t show up. For me, I type in http://neverssl.com and either I’ll get the splash page or my phone will give me the notification to connect. This site is set up for this purpose.

6 Likes

Thank you! This is a fantastic resource. I’ve been using sample.com because it is not SSL, but it isn’t guaranteed to stay that way.

1 Like
Message an
Expert customer