Only receiving Text msgs & Phone msgs if connected to wifi. Why?

I recently received a new republic phone and I’m still learning the new OS that comes with it.
It appears I only receive text msgs and phone msgs if I’m connect to WiFi. I thought I should receive these
any where there is Republic Network service even if I have no data. I’m assuming I just need to change a setting but have no idea which one to change. Any help would be appreciated.

This is usually a result of having cellular data turned off in your Android Setting. Without knowing the model of phone I can give you a couple of places to check this, but it may not be right for your phone.

Once possibility is Android Settings. Settings > Data Usage > Cellular Data (some phones may say Mobile Data).
Another may be Settings > More > Cellular Data

1 Like

Thanks for the suggestion, …. but I checked and my MobileData is set ON. Any other suggestions?
FYI … my phone is a Moto X4 if that helps. Thanks

When you have wifi off, does your phone show a cellular signal? If yes, are there letters near the signal bars (like LTE, R, H, etc)?

With the wifi off it shows LTE by the signal bars.
FYI … also with wifi off I just noticed the following Republic Wireless Main Notification
“Calls over cell. No access to messages or voicemail”. Not sure why this is happening if Mobiledata is truly ON.

Again with WiFi off, is there a little “x” on the signal bars?

Yes, …. In the bottom right of the signal bars there is a little x.

Well, that’s the cause of the issue. Let’s see if we can fix that.

Please try the following steps to resolve this issue:

  1. Reboot the phone in an area that has a strong cell signal. (Some people have simply needed to step outside and reboot.) If this fixes it, stop.

  2. Please ensure the data is turned on in Android Settings. Settings > Data Usage (or More) > Cellular Data (some phones may say Mobile Data). If this fixes it, stop.

  3. Reset your Republic credentials by opening the dialer as if making a call and enter *#*#8647#*# (and on a Samsung phone hit the dial button). The screen should clear, when it does, restart the phone. If this fixes it, stop.

  4. This one is more complicated. This step will clear out any saved connections for Wi-Fi and Bluetooth that you may have already made. We’re going to reset the network settings.
    Go to Settings > More > Network settings reset
    Read the warning, tap “Reset settings.” You will be warned a second time. Tap “Reset settings” to confirm. The process will usually take 5-10 seconds and the cellular signal bars icon will go away for a moment. Once the cell signal bars icon returns, you should reboot the phone.

Hey, …. So no luck. Here is what is going on.

Step 3: The credentials did not reset. When I pressed the dial button I received “Dialed number not allowed”. Without pressing the dial button nothing happened. What am I doing wrong here?

Step 4: The reset settings was in a different location then you suggested looking, but I was able to find it. The cellular signal bars did not go away for a moment, …. but it does appear the setting were reset as I need to re-enter the wifi password after the reboot.

Thanks for the help

When you open the Republic App is there some sort of message there or does it just open normally?

Hey Louis, … I guess Step 4 fixed it as late yesterday I started receiving text msgs when wifi was off. I still have the little x in the signal strength symbol, …. but I’m getting text msgs. So for now this issue is resolved. Thanks for the help.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.

Message an
Expert customer