Oreo 8.1 Bluetooth pairing with a Subaru


#1

What phone do you have? Moto G5 plus

What plan are you on? 3.0

Does your plan include data, or just talk & text? data


Issue Description

I have been having problems with the bluetooth handsfree connection to my 2016 Subaru. The dealer has worked on it several time including updating to latest software. In researching I see that Bluetooth AVRCP version has been an issue. Oreo 8.1 developer mode allows trying different versions. Is this update to Oreo 8.1 available ?


#2

have you gone over to setting
location
scanning
and turned off wifi and bluetooth scanning


#3

Hi @mdm,

Developer builds are not supported on our service.


#4

To get to Developer Option tap on Build Number in the phone 7 times. This can be found in Settings, About Phone

If you make any changes, keep a record of what they were should they mess up your phone or not work. After you make the change restart the phone and see if it will pair with your SuBe.


#5

I have android 7.0 ( I guess that’s Nougat). I said developer “mode”, and should have said developer “option”. The developer option in 7.0 does not allow changing the Bluetooth AVRCP version, nor does 8.0 but the notes on 8.1 say the developer option does permit this change between AVRCP 1.3 1.4 1.5 1.6. Unfortunately not possible in 7.0, I have seen others having car pairing issues that they solved by changing the BT version. I turned off wifi and bluetooth scanning with no success. Thanks for the advice. When will Oreo 8.1 be available ???


#6

Motorola is now rolling out official Android 8.1 Oreo OTA update for the Moto G5 and G5 Plus

The new firmware build comes with Android 8.1 based on August 2018 Security Patch.

  1. Unpair audio device.
  2. Go to Applications > show systems apps
  3. Find “Bluetooth” and “Bluetooth MIDI”, clear data for both of them
  4. Go to developer settings, change AVRCP to 1.5 or 1.6
  5. Restart phone.
  6. Pair audio again.

#7

thank you for the information, will give it a try.


#8

It does allow changing AVRCP in 8.0. I can do it on my phone which is on 8.0. Did someone tell you you can’t?

I suggest waiting for the update to come OTA and not download through a website.


#9

it was suggested to try the older AVRCP 1.3 which was not available on 8.0 but added to 8.1.
I was just moving the oreo 8.1 for 5G Plus .zip file local and enabled storage for the Motorola Update service. Is this a bad idea to proceed, will I brick this ?


#10

I don’t know if you will brick it, don’t know if this build will match OTA, don’t know the reliability of this update, or the phone will become incompatible with Republic Wireless or not. This is why it’s always a good idea to wait for the OTA and the announcement from RW staff.

@southpaw If this update is installed, will it nullify the warranty on the phone?

Did you by any chance check to see if your phone is actually compatible with your SuBe?


#11

The G5 Plus is not listed as compatible, but we’ve been using it all year. Every month or so it loses pairing. I complained about this to the dealer during a regular maintenance visit recently and they said they would see if they could fix it, supposedly updating software on the head unit – which has totally broken the pairing. It has been back twice with no resolve except that subaru doesn’t support the phone. I’ll wait until the 8.1 OTA. Thanks for the ideas.


#12

I have an old Sube and doesn’t have Bluetooth, so I use this app with a Bluetooth speaker:

https://play.google.com/store/apps/details?id=com.nuance.balerion&hl=en_US

or sometimes this app:

https://play.google.com/store/apps/details?id=com.google.android.projection.gearhead


#13

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.