“Other” phone number

How do I make certain that MY phone number shows when I call\text.?

The other phone number (unrecognized by my contacts) has been showing. I have a pixel 4a. I have been with RW for several years.

Thank you

Hi @jeanb.01d11j,

Please make sure the RCS is disabled in the Messages app: How to Disable the RCS Chat Features in Messages by Google – Republic Help

Please also make sure that you have the Republic app excluded from the Pixel’s battery management feature. Optimizing your Google Pixel battery settings for Republic Wireless:

2 Likes

Thank you for your prompt response. This was not a new issue, but I just kept forgetting to ask how to remedy it.

The links you provided were pretty easy to follow, a must for me.

I hope this works, it’s freaking my friends a d family out, not to mention confusing other contacts. Ha!

Always a pleasure.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.

Message an
Expert customer