Phone activation error

What phone do you have? Moto E4
What plan are you on? The 2gb
Does your plan include data, or just talk & text? It includes everything.


Issue Description

I’ve had my phone activated for a week or so. Woke up this morning to an error saying I need to activate my phone. That it says I have no network and I need to buy some card. I have a SIM card and activated plan. It did this error after it was uploading or downloading or updating some app. I have no phone to call out on or to text with this error. Seriously frustrated… Help!!!

This will likely be resolved by installing the updates that are waiting. Go to Settings – About Phone – Software (or System) Update and apply the waiting update. Once applied and the phone has restarted, go back and check for a second update. Once all waiting updates have been applied, you’ll find that the issue is resolved.

More info here: No Service and Republic Wireless App Asks to "Buy a SIM Card" on Moto E4 – Republic Help

  1. I’ve seen the same messages before, just ignored and gone to the home page. Once back home all was well and didn’t get another error message.

If #2 doesn’t work follow louisdi’s advise.

On the E4 this is actually terrible advice. The updates should be done because this is a known issue that is only resolved with the updates. If you manage to swipe away and hope for the best what happens when you’re in the middle of nowhere, it stops reading the SIM card for good and you don’t have wifi to download the updates?

I have the same problem - I have a Moto X Pure. Its software is up-to date. Four or five times, I have received an error message that the phone needs to be activated, despite the fact that the phone is activated. I ended up stranded today because I got the error message and I needed to make a phone call. I wasn’t near a wi-fi source. What gives?

So I had no service yesterday, until I connected to WiFI, then I could get
all my notifications and text and call. No issues. I left the WiFi spot
still on the phone with my boyfriend, call was fine, no issues.
Then I got home and tried to reconnect back to WiFi it would not connect. I
know my WiFi at home was working due to my daughter being on it and myself
being on it streaming Netflix all night.
I got to work this morning to try and reply back to this email, my phone
connected to the work WiFi and all my facebook notifications popped up.
I am unable to call or text. It is not reading Republic wireless SIM card,
I assume? I just got this phone and SIM card directly from Republic
Wireless a week ago!!
I have never had so many issues with one phone - I am beyond frustrated!! I
am a single mom, my daughter can’t get a hold of me, we are having terrible
weather, and I need service.
Someone please help.
I did the phone updates and still no luck. I have tried all the suggestions
listed above. I even deleted Facebook Messanger as I know that sometimes
causes issues with phone. No luck.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Message an
Expert customer