"Phone audio" disabled for all Bluetooth profiles (Moto G4 Plus)

device

#1

Hello. I recently signed up for Republic Wireless and bought a Moto G4 Plus phone. The phone was working fine initially, but recently the phone audio has stopped working on my Bluetooth headset and my car’s Bluetooth hands-free system. Initially I was able to delete the device profile, restart the phone, and re-pair with the device to get the audio working again. But now even that has stopped working. I can still connect to these Bluetooth devices, but as soon as I do and check the profile settings, I see that “Phone audio” is deselected and cannot be selected. (“Media audio” is selected and still works.)

I found the article below on the Lenovo site, which describes the problem well. They list it as “Resolved,” but the solutions they suggested (starting phone in Safe Mode and resetting networking settings) didn’t work for me. (Also, the original poster said that this only fixed the problem for him/her temporarily, and returned shortly afterwards.)

Has anybody else on RW run into this? Any ideas on how to fix?

Solved: Bluetooth will NOT let me select “Phone Audio” when connecting to headset/car. - Page 3 - Lenovo Community


#2

Hi @robertm.mvpgvo

I was wondering, did you find a fix for this issue?.

It looks like others are having success in the thread you linked, turning off BT scanning, not sure if it required an FDR though.


#3

Hi. Yes, this is resolved. Brittney helped me over chat. Here’s what she had me do. After this, I tried the headset again, and the phone audio option was selected, and phone audio worked.

===============

Thanks! I’d like to try a cache wipe to ensure it is not just an issue with the phone’s temporary data

  • Power off the device and unplug it.

  • Press and hold the Volume Down button. While still holding Volume Down button, press and release the Power button.

  • Press and release the Volume Down button until you reach Recovery Mode.

  • Press and release the Power button to select Recovery Mode. The device will restart. An image of an Android robot with a red exclamation mark will appear.

  • Press and hold the Power button, press the Volume Up button once and then release the Power button.

  • Use the Volume buttons to scroll to Wipe Cache Partition and press the Power button to select it. If an additional confirmation screen appears, use the Volume buttons to scroll to Yes and the Power button to select it.

  • Once the cache wipe has completed, press the Power button to select Reboot System Now.

I apologize for the length of the message, for a video of the process click here: https://www.youtube.…LSwixvN38&feature=youtu.be


#4

Hi @robertm.mvpgvo

Great to hear. For future reference, the Clearing the Cache procedure is a great remedy to all things abnormal when it comes to android, in my opinion.

It is something I perform on a regular basis (monthly) or as a first step in troubleshooting and/or housekeeping issues on my mobile phones.


#5

Hi, I’m having the same exact issue as Robert with my recently bought G4 Play from Republic Wireless.
Although clearing the system cache seems to work, the phone audio gets disabled again on all my bluetooth devices (handfree car system and headphones) as soon as I turn off and then back on the bluetooth


#6

I recommend disabling scanning.

Under Settings -> Location -> three dots -> Scanning -> Disable Bluetooth Scanning.


#7

It seems to have worked, thanks!


#8

You’re welcome!


#9

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.