Phone displays "No Network Available" after most recent RW App update

What phone do you have? Moto X4
What plan are you on? My Choice
Does your plan include data, or just talk & text? All the things


Issue Description

After the most recent update (3.28.0.47) to the RW App yesterday 5/6, my phone is now throwing a “No Network Available” message after it sits idle for a few minutes. Once I login to the phone, the message goes away and network connectivity is re-established. Anyone else seeing this?

2 Likes

Hi @stephenb.bfpi2u,

One of my household’s Republic phones may be or may have been displaying similar behavior. By “login to the phone”; do you mean unlocking it from the lock screen? Is the phone charging at the time or sleeping while off its charger?

Hi @rolandh,

Yup, I meant unlock, thanks. I believe the times I’ve seen the issue, the phone was not charging and in sleep mode.

Hi @stephenb.bfpi2u,

My experience is the “No Network Available” notification goes away immediately after the phone wakes up. Is that your experience as well? Do you have another phone to test with and, if so, have you tried calling your phone while it is in this state?

I’ve only seen this on a Pixel 4 XL when its on its charger. That said, the Pixel 4 XL uses facial recognition for unlocking the screen, so if I look at the phone any such notification goes away making it difficult for me to capture. I’ll try to see if I’m able to recreate it on other household Republic phones.

It appears (from looking at Recent Notification) log, it appears that this is what we used to see as ‘On Cell’ when a phone went into Doze Mode

2 Likes

Hi @rolandh,

That is my experience. Unfortunately I do not have another phone to test with, to see if the phone is totally cut off from receiving incoming calls, messages, etc. when in the no connection state.

Hi @stephenb.bfpi2u,

Thanks for the additional context! I do have ample other phones to test with and will do so the next time I see a household phone in this state.

Hi @jben,

Your work on the MacroDroid Doze Mode workaround is certainly of great benefit to the Community. Please correct me if I’m wrong but my understanding is Doze Mode is not an issue, so long as Republic is able to reach the phone on cell. Therefore, I’m curious if the no network connection notification changes that dynamic.

I don’t know, but in my limited experience with a fairly marginal CDMA signal even with the Google/Android workarounds that RW had previously put in place, my calls would come in on Cell or go to Voicemail. I have put an update in the RW App Preview thread to hopefully gather additional information.

Right, that’s what I’m trying to determine. For me, a call coming in on cell isn’t a deal breaker. I view Republic service as blended WiFi/cell with WiFi being preferable but don’t view Republic service optimally as WiFi only. I very much appreciate for folks with lousy cell coverage, Doze Mode is a problem.

Thank you @rolandh and @jben for your assistance on this! Question/clarification: So is the consensus that prior to the most recent RW App update, my phone was already exhibiting this behavior, but not throwing the “No network connection” message? I’ve noticed that in the past, my phone has shown an empty RW arc symbol (not solid), or no symbol at all when in doze mode and I wave my hand over the screen, or tap the phone, but not unlock it.
I’ve also continually have issues with not receiving text messages and the occasional call not coming thru, but seeing I have a voicemail later. I’m thinking this is all related : /

I have a help ticket for same issue. They keep referring me the the Doze Mode article. I don’t thing republic support is on the same page with me.

I have occasionally seen the same “No Network Available” message on household Republic phones since the last Republic app update and believe it might very well be related to Android’s Doze Mode. On one occasion after noticing the notification (which goes away immediately upon waking the phone up), I dialed the phone from another household phone. Despite the notification, the call was received and on WiFi.

Are you experiencing a service issue? Or, is it just seeing the notification?

It takes awhile for it to go into this mode. When I see the network error again ,I’ll call the phone and see what happens. Yes, I believe the last Republic App is what caused this bug.

1 Like

Getting a warning triangle popping up upper left side. Happens sporadically. Also sometimes after waking phone up .just started today. Cell and wifi signal seems good.Phone restarted and powered off then on. Wifi settings reset.

Hi @donalde

Please see if this Republic article helps you :slight_smile:

Hi @donalde and welcome back to the Member Community. If you access the quick notifications using the article @SuperT provided, and it turns out to be related to RW connectivity, the following guide explains – What are the Connectivity Status Notifications? – Republic Help

Hopefully between the two we articles we can start narrowing down the issue!

I have noticed this as well on my S10. There doesn’t seem to be any service related problems, but the warning does say “no service”. It seems to be when wifi has been sleeping, and I wake it up. When awake the notice disappears. I’m not sure of the timing exactly, but I did a security update a week or two ago. I wonder if this could be related?

Moto X4 here, same issue. Just started a few days ago. White triangle with black exclamation sign on lock screen appears sporadically and immediately disappears on waking up. No other issues that I’m aware of yet. Calls, texts, apps all seem to be working normally. Hopefully this “warning” (it seems to be telling me something’s up…) gets some attention from the engineers at Republic Wireless. Just hope it’s a software bug and not an indication my phone’s hardware is heading south.

2 Likes

Yeah I think this is on Republics side. I hope they see this conversation.

1 Like
Message an
Expert customer