Phone displays "No Network Available" after most recent RW App update

Just wondering if this is somehow related to ‘Battery Optimization’ in the Android settings? And should this be set to ‘Not Optimized’ for the RW app?

In the testing that I have done, the Battery Optimization setting has made no detectable difference in operation (this was limited to my Moto X4 9.0 phone), but as always YMMV with different mfgs

Same phone, same issues. I’m afraid I don’t get calls, emails and texts in a timely manner.

Moto X4 same issue. Not sure about calls, but emails are definitely delayed. I’ve applied the Doze “fix” of 05/23, with no apparent change to the symptoms. Pretty sure this is a problem in the latest update of some software - Republic app? Carrier Services? I dunno. Seems more like the Republic app, just because Carrier Services was updated longer ago…

Hi @davejordan,

There’s nothing the Republic app does that would affect your E-mail delivery, unless you have Data Freeze turned on.

Most apps are affected by the Android Doze Mode, particularly since Android P, and it seems more aggressive on some phones than others. When the phone has been idle for a while, typically an hour, Doze Mode kicks in and puts apps that ought to run in the background into a deep sleep in a helpful attempt to conserve battery consumption. That’s all independent of Republic Wireless and our app is impacted by it, too.

What we’re seeing with this “No network available” notification may be related to Doze Mode only in that it may possibly be a signal to you that the RW app can no longer reach our servers because Doze Mode has knocked us unconscious. The notification doesn’t mean our app has done something to disconnect your phone from all networks.

Here’s something to try on your X4 if you’re seeing your E-mail delivery impacted. Please let me know if it helps.

  1. Open the apps drawer.
  2. Launch the Settings app
  3. Tap Apps & notifications
  4. Scroll to the bottom and tap Advanced
  5. Tap Special app access
  6. Tap Battery Optimization
  7. Tap the green Not optimized drop-down bar and select All apps
  8. Scroll down to your E-mail app. (Gmail?) If it indicates Optimizing battery use tap it and change it to Don’t optimize.

Hello to both of you. I own both the Pixel 3A and the Moto G7 and i have been complaining to republic about this very same issue. Whenever my phone goes into a deep sleep mode, WIFI is kicked off and i get that triangle stating that i am connected to the cellular signal and not wifi. As soon as i pick up either phone, they immediately return back to wifi. This has all happened since the last RW update. I have tried everything recommended to me by RW including the deleting of over 20 apps. Still the same problem. My Pixel #A is only a week old and i downloaded nothing for it. It is the way it came out of the box new. and i still get dropped wifi in deep sleep mode.

Hi @ronf.cd82t5,

Welcome back to our Member Community!

I moved your post into a different Community topic about the “No Network Available” notifications. The topic you originally posted in is one where @jben JBen and another member are working through a potential third-party app workaround, but this topic is more of a collection of members who have noticed this notification.

While the notification looks alarming, we’re not seeing any impact to service associated with it. Are you? If not, there’s really no need to go to great lengths to try to make the notifcations stop showing up, you can simply ignore it.

While you may see my reply to you as well as other replies in this Community topic in your E-mail, please know that this conversation is taking place publicly in our Member Community. It is not necessary to reply by E-mail to each one you receive.

(I’ve also removed your offer to share your E-mail address from your post. Our staff already have your E-mail address and it’s better if you didn’t share it with others who may see your post on the internet. If they want to contact you, they can do so in our Community, without needing to know your E-mail address.)

1 Like

So i have noticed that when i get that little triangle saying i am not connected to any cellular service, i begin to use up a lot of data. I am retired and at home during the pandemic. For the past 4 months, ive been 100% wifi and only use maybe 100mb per month. I recently renewed my 1gb of data use and now i am down to less than 500mb remaining and 27 days until i renew my data plan again.
I see which app is taking the most data and i restricted the data on that app to reduce my data usage. I also have to turn off my phone at night. Jben advised another member to download the Macrodroid app, so i have done so as well. I setup the app as he advised to turn the phone on again before it falls into a doze mode, the doze mode is when i get that triangle of no service.
I will see if that app works today as i downloaded it late last night and set it up as per Jben’s advice. I turned off the phone before i had a chance to see if it works. If i had not turned it off and the app didnt work, i was in fear of burning up my allotment of data in 1 night in doze mode.
TY for helping and i will let you know if this app works as it should later today…

1 Like

Hello southpaw - I definitely think there’s an impact to service. My g7 does this multiple times daily, and I receive no texts, calls, emails, etc. when this happens. Notifications then flood in once I “wake up” the phone. However, the loss of service never happens when the phone is plugged into the charger.

Hello jben.
I did reply but was on another members post.
I have same problem with my pixel 3a phone. Doze mode, triangle pops up and says no cellular connection available. I download macro Droid and set it up as per your instructions that I had seen on another post… But I am still having the same problem. Triangle shows up sporadically. Now due to the pandemic, I am self quarantined and on wifi 100%. I am on the rw choice plan with only 1gb of data needed as I average 100 mb per month. I just had my data renewed less than 7 days ago and I am down to 500 mb. So I am desperately losing data since the rw update. I have 26 days remaining until my data plan renews itself. I turned on data saver and restricted data to the app using the most data. So any suggestions? The app didn’t work for me… Ty… Ron

Sorry that it didn’t help with your particular phone/problem. If you could provide some details like a screenshot of the time that it failed, it might help me figure out how to improve my MD Doze routine.

I dont see a time when it failed?? 6:13am is when i turned my phone on this morning. I left the phone on my desk and the triangle showing no service popped up at around 8am which is the last trigger point here.

As far as the battery optimization… I went into settings /battery / “battery saver” or “adaptive battery” and “full charge” is all i see. I own the Pixel 3A, have owned it for 9 days so I’m still trying to learn the phone. It is Android 10.

I verified that im using mode

My phone just went off during our dinner, the triangle came back on and i missed 1 call and 2 texts.

I really wouldnt worry about this so much, but each time it kicks off the wifi, my battery drains quicker and my data gets burned up.

Please help…PS…I am forced to turn off the phone at night now to avoid data usage. Like i said before. I am home 99% of the time on wifi. I averaged 100 mb per month. My plan was renewed a few days ago and i have burned almost 500MBs. I have 26 days until my plan renews the data.

I have also been experiencing this issue for several weeks, on multiple phones. I had assumed that it was due to using an old crappy phone (a several-years-old Moto-something), but I purchased a new Pixel 3a last week and the issue has persisted.

The sequence of events is that the phone goes to sleep or is otherwise locked, and then after an indeterminate amount of time, it displays the triangle/exclamation mark with a message to the effect of “no network available, try to find wifi”, even though I haven’t moved from my desk where it was working fine minutes ago.

There is definitely an impact to service - text messages, emails, notifications from apps, etc will not appear until the phone is unlocked. My plan is wifi-only (I do not purchase data), so this issue completely prevents me from receiving emergency calls, texts, and emails if the issue appears while I am on call (I work in healthcare).

Hi @Mile-High-Mikey,

This suggests the cause is Doze Mode, which does not kick in while charging. The notification would actually be accurate in this scenario.

1 Like

Hi @abmo,

This would also suggest that what’s causing notifications to stop rolling in is Doze Mode, and that in your case the notification is an accurate description of the scenario. Does the same thing happen when the phone is on the charger?

1 Like

You could put the phone in airplane mode with Wi-Fi enabled. This would prevent the phone from using cellular data. If you keep the phone on the charger overnight, do you find it in this state in the morning?

1 Like

No sense puting in airplane mode…turn off phone each night.

Anyway i was working with Jben and his Macrodroid app. I did notice this:

I turned on the phone. Waited about 50 minutes before the phone went into deep doze mode. The Macrodroid app kicked in as soon as the phone went into doze mode. It awoke my screen but the “Bermuda” triangle stayed on stating no cellular service was available. This tells me that the app needs to awake my phone before the doze mode. Maybe every 40 minutes or so?

With the triangle of no service was still on, i did try calling the phone and it did ring and the wifi was only restored once i picked up my phone.

Any suggestions on how to awake the phone before the deep sleep mode function? Google Pixel 3A.

As i mentioned earlier…Ive only pwned this phone for 10 days. The 1st few days i had no problem and the phone was purchased with Android 9. Now i have the update to Android 10 and also had the RW update as well including a security update. This was all in the 1st 2 days ive owned this phone. Since then after these “UPDATES”, i now have this problem. I had this exact same problem with my Moto G7. My wife owns the Moto G6 Play with Android 9 and she does NOT have the same experiences.

Please help? Maybe another RW update is in order to fix this bug? I deactivated the 2 apps that i use the most to conserve the remaining data i have left for the next 25 days.


To restrict the use of Data when not on WiFi to just those essential to providing Republic the data it needs to function properly they provide the following:

1 Like

Perhaps you would try using @BillG’s original app that got me into this in the first place. It currently is set at 50 minutes, but you could easily modify this to whatever works in your phone by adjusting the time (use Configure in the Trigger section)
My version Triggers on detecting On Cell OR ‘no network’ as the time based KISS version wasn’t working on all phones.
Give it a cry, if you run into trouble building/modifying Bill’s just give a holler and one of the community will help you out

1 Like