Phone displays "No Network Available" after most recent RW App update

A couple of MacroDroid screen images - user log and system log - below. The screen images show MacroDroid activity at around 15:00. At 17:15 the dreaded triangle of death was shown on the screen - I suspect that I hadn’t touched the phone in between…but I can’t be sure.

I’m on a Moto X4, running Android 9, PPWS29.69-39-6-4, which the phone reports is up-to-date. I’m running Republic app version 3.28.0.47 with a 1GB data allotment. I’m running MacrDroid version 5.1 with Doze Detect 0.9.6.5. I’ve disabled “Battery Saver” and I’ve turned off Battery optimization for almost everything in sight.

Here are the screen images:

I have been working with jben on this issue using the MacroDroid work around. I have turned off Battery Optimization for both the Republic app and MacroDroid. So far, nothing we have done prevents the “No Network Connection” problem. I am also seeing delayed notifications and texts. I am NOT seeing cell data use, however. I have also turned off Battery Optimization for Google Assistant, thinking this might help with notification delivery, but it did not help.

I am hoping we find a solution soon.

Phone has been on charger for ~3 hours without the issue appearing. I’ll try messing with Doze mode now.

Send me the link for the other app. You only mentioned BillG and not the name of his app.

TY…Ron

A picture of @billg’ fix is featured as the 2nd solution in Managing Doze Mode - (phone is on WiFi) calls via cell | calls go to voicemail | calls are missed
It is a DIY for building it yourself …

Ok you lost me…Its the same app? What do i need to do to get this to work on a timed sequence?

A picture of @billg is featured as the 2nd solution in https://forums.republicwireless.com/t/managing-doze-mode-phone-is-on-wifi-calls-via-cell-calls-go-to-voicemail-calls-are-missed/20002
It is a DIY for building it yourself …

I just built and published it as Doze Detect “BillG-30” with the time set to 30 minutes.
Find and download, and only turn this or 0.9.6.5 on … one or the other … not both

  • Please Note: the Screen off has been Disabled, if a user determines that they just want/need to the screen to flash on it would need to be manually Enabled. As an alternative to letting the screen stay on and turn off based on your screen time out would be to insert a wait of xx seconds between the commands and Enable the screen off
1 Like

@southpaw I switched every single app on my phone to “Not optimized” and then experienced the issue within about an hour. I then switched every single app to “Optimizing battery use” and again lost cell/wifi connection about an hour later.

Hi @abmo,

Unfortunately, and this isn’t limited to Republic Wireless, Doze Mode isn’t the same as battery optimization.

What we need to do in this topic is be very careful not to confuse troubleshooting steps to try to conquer Doze Mode, and questions about the alert itself.

If you want to further explore trying to work around Doze Mode, I’d like to separate your posts into their own topic so we can study the matter in a more focused manner. Would you like me to do so?

I’m just trying to get my phone to work

A “coincidence” that a seemingly large number of members have begun to encounter the doze “curse” after the latest RW app update?

I dealt with the intolerable curse for more than a year with my Moto X Pure prior to upgrading to my current Moto X4 over a year ago. Before getting the X4 I had seriously considered leaving RW because RW had failed to adequately address the issue.

My belief is that RW app changes/updates can cause the reported Doze issues by instituting changes that reduce the amount/frequency of data/communication between the RW and the phones. IMO RW needs fess up rather placing the blame on Android and spend the extra data charges they may incur to insure we get the good service we are paying more.

I for one will taking my X4 to another provider after having my present number at RW for seven years if the Doze curse starts affecting my service again.

:flight_departure:

Or perhaps they’ve been experiencing it all along, but the very alarming notification has brought it to their attention.

The internet is rife with complaints by app developers about Doze Mode. Because it’s built into Android and non-bundled apps are very limited as to what they can do to counter it, app developers find it to be quite a challenge, even building a website dedicated to working around it. I’m sure you’ve seen @jben’s many iterations of trying to persuade Macrodroid to keep the phone awake so WiFi connectivity isn’t lost.

I’m very surprised to learn you don’t experience it on your X4. If you know any particular setting you’ve adjusted to make your phone maintain its WiFi connectivity, I hope you’ll share the details.

Ok. There could be unintended consequences to changes that are made. But then why isn’t everyone’s phone equally affected when an update is pushed.

I hope we won’t see that happen. You’ve been a valued participant in the Community.

I’m really not here to argue and place blame. Any posts I make describing it as an Android issue are meant to help work through the issues our members are experiencing, and I hope they are understood that way. Our developers have Doze Mode on their list, as they look for ways to circumvent the disconnects it can cause. They are also looking into why we’re all seeing the “No Network Available” notification suddenly and what steps they need to take to clear that up. Are you also seeing that notification, despite not seeing Doze Mode disconnects?

@davejordan,
I have the Moto X4 same code levels as yours and have never seen either of my logs with nulls (the user log) or the Errors in the System Log.

  • I would ask you to delete the MacroDroid App, reload from their site, and accept all permissions and change nothing. Hopefully this will get us both on the same page and perhaps I will be able to see something different?

My X4 is a Android One version purchased from Google Fi and I haven’t installed app version 3.28.0.47 due to the reported issues. That’s all I know that may be different. On @jben’s Doze Mgt. post another member said his wife’s Android One X4 was affected by the update in question.

Do you mean all 3.0 phones, all of a particular model phone or different symptoms reported among same model? Does RW check out the updates on every model of compatible phone prior to the Soak Releases? Thanks.

:flight_departure:

You experienced trouble with Doze Mode on your X Pure and replaced it with an X4 long before RW app version 3.28 existed. The “it” in my sentence referred to Doze Mode and the fact that you didn’t experience it in similar circumstances to having experienced in on the X Pure.

I meant only that what you were suggesting,

would seem to be something that would affect all our 3.0 members, and may even sound to some like you’re suggesting it’s something RW would do intentionally from time to time.

No. We support over 70 phone models at this time. QA testing is done on a representative subset.

Hi @abmo,

I understand, and I want your phone to work, too. This is why I’m asking if you’d like me to pull your posts into a separate conversation so we can focus on trying to work around Doze Mode.

Did you notice that

happened before you updated your Republic app to 3.28.0, or has it always been on this version? You mentioned you had the same experience on an older Motorola phone, so that would have predated the app update, right?

I have been unable to convince myself that Android/Googles ‘Battery Optimization’ is 100% effective. My testing is limited to a single Moto X4 with all codes at the latest levels.

  • All I can state with any level of certainty is that none of the ‘Legacy’ (Moto X1/2,G1/3 and E1/2) are affected by Doze as it did not exist in Android until 6.0 was officially released in October 2015.
  • If you would care to start your own discussion, I will try to see if there is anything that I can suggest to improve your connectivity.

I don’t know, I bought the phone last week and immediately installed whatever updates it prompted me to do. Should I factory reset and then not do the updates?

No. If you factory reset the phone you will not have a working version of the Republic app at all. There’s not a way to get an earlier version from the Play Store.

Hi everyone. I got the Pixel 3a XL about 2 weeks ago. I have this same problem, but it seemed like it started when my phone automatically updated to Android 10. I don’t recall seeing an update for RW app, although I do have the latest one. Like others, I normally see this error notification after not having used my phone for some time. BUT I also saw it DURING a call that I was on (cellular call). It wasn’t a handover to cellular but a full 30 minute call that started and ended on cellular. I happened to look at my notifications during the call and saw that it popped up at about the 15 minute mark while I was on that call. Does the fact that I saw the “no network connection” notification message during a call tell us anything about it’s potential connection to Doze?

Message an
Expert customer