Phone displays "No Network Available" after most recent RW App update

No. If you factory reset the phone you will not have a working version of the Republic app at all. There’s not a way to get an earlier version from the Play Store.

Hi everyone. I got the Pixel 3a XL about 2 weeks ago. I have this same problem, but it seemed like it started when my phone automatically updated to Android 10. I don’t recall seeing an update for RW app, although I do have the latest one. Like others, I normally see this error notification after not having used my phone for some time. BUT I also saw it DURING a call that I was on (cellular call). It wasn’t a handover to cellular but a full 30 minute call that started and ended on cellular. I happened to look at my notifications during the call and saw that it popped up at about the 15 minute mark while I was on that call. Does the fact that I saw the “no network connection” notification message during a call tell us anything about it’s potential connection to Doze?

  • Doze only affects our Internet connection, not cellular (unable to confirm), but your answers to the following questions will help with a catch-up of community knowledge.
    • Did the call drop at that time you indicated? +15 into call
    • How did you place the call on ‘cell’?
      • Did you turn off WiFi via the Android Settings?
        • Did you take any steps to prevent the phone from reverting back to your WiFi?

fyi: Here is a definition I found in the Verizon forum … Note: I am not implying that these all may apply to Republic Wireless

Doze Mode:

  • starts when the device is stationary and not charging and the screen is off.
  • prevents the device from syncing and accessing the network, Wi-Fi from scanning, etc.
  • allows SMS, MMS, phone calls, alarms, and Amber Alerts to still function.
  • stops when the device is moved, the screen turns on, or the alarm clock sounds/vibrates.
  • isn’t affected by notifications.

@jben Hello! The call did not drop at the time I saw the notification and I did not notice a difference in call quality. I placed the call on cell while I was at home. I turned off wifi and forced it to cellular, so that I could test the quality of my cellular since it was a new phone. I turned off wifi by swiping down at the top and tapping wifi icon to turn off. That step prevented the phone from reverting back to wifi.

@brandong.i1aaku,
Thanks for the well-documented feedback … it helps

@jben
I reinstalled MacroDroid and the No Doze template. The phone (Moto X4) has been running in this mode for about 30 hours and I have not encountered the triangle of death during this time (absence of evidence isn’t the same as evidence of absence…) But, the MacroDroid log looks good. The system log shows No Doze being invoked and turning on the screen every 55 minutes.

Looks like No Doze works, though the process of getting there may be more complex than the average user is likely to put up with…

Dave Jordan

@davejordan,
Thanks for the feedback … any suggested changes to my instruction would be greatly appreciated.

@jben
I’m not sure what I’d do with the instructions. I had two issues.

The first was tracking down the settings on my phone that would prevent battery optimization for specific apps (had to do that for MacroDroid…I think). (My problem was when I got to the “Not optimized” green bar where I failed to recognize that the down arrow wasn’t pointing to the “Not optimized” apps, but was suggesting that there was a menu underneath. I probably should have recognized that…but didn’t until I saw a post that explicitly said that you had to tap on the bar.

The second was just the process of getting MacroDroid (the right version…I already had a version that, I guess, wasn’t compatible), loading the template, and making sure that both MacroDroid and the No Doze macro would run.

All in all, if you break it down into individual gestures, it’s probably 20 to 30 different things that the user has to do to get it all running. And those may vary some depending on the phone and OS version.

As I mentioned before, I suspect that the Doze behavior has been around for a while, but the triangle of sleepiness maybe just showed up recently due to a change in the Republic app. Prior to that, the phone probably slept, messages were left hanging, etc., but it wasn’t so obvious. It would be super handy if the Republic app just implemented something similar to your No Doze behavior.

Dave

Because the “no network available” notification is not a reliable indicator of the actual connectivity state for most phones when the phone has entered Doze Mode, our developers have released an update that will remove the notification when the phone is dozing.

1 Like

I still receive the “no network available” notification. This should probably be separate post, but my main issue with Doze mode is that google messages for web does not work when my phone is in doze mode. I can receive texts but I cannot send any unless I wake my cell phone up. It’s super annoying. Any ideas on how to overcome that issue?

Hi @brandong.i1aaku please see reply to your other post Google Messages for Web - Can't send texts when phone is asleep in Doze mode

Check your RW App level, some changes were made with the latest (3.28.2.1) … it is still in the roll out stages

1 Like

Does the latest update mean that I no longer need your macro…or just that the notification is no longer being displayed, but the underlying problem (phone not getting mail & messages) remains so the macro continues to be needed?

@jben i just checked and i have 3.28.2.1 and the issue still persists…

Hi @davejordan,

With the latest RW app version, the notifications have been updated to be more precise and display only what the RW app can verify to be true.

If you’re missing E-mail and text messages at times, that’s something that we may need to troubleshoot in a separate topic.

1 Like

Did this problem just disappear? I haven’t had a recurrence in the last week!!

Did you perhaps get the updated RW App that @southpaw mentioned above?
That would have updated you to 3.28.3.1 (RW App/Settings/About)

Nope. I am on 3.28.2.1

App version 3.28.2.1 is the version that removes the “No network available” messaging when the phone is idle.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer