Phone doesn't ring every time, many calls go directly to voicemail

What phone do you have? Moto e5 Play

What plan are you on? My Choice + 1GB

Does your plan include data, or just talk & text? Data


Issue Description

Very often I get a voicemail notification but my phone did not ring. Other times it will ring normally. This is when I am home using my wifi (fiber optic speed). At home here there is very minimal cell tower connection, but this should not matter as the wifi is fine. And as I stated above, the ringing/not ringing is an intermittent occurance.
  • To me it sounds like you are between a rock and a hard place, by that I mean here is what I would think is happening.
    • Android, in an attempt to make cellphone batteries last will turn off our WiFi Transmitter and Receivers, this occurs after a period of time (observed as short as a couple of mins and close to an hour) depending on the manufacture and model
    • When this occurs and Republic tries to establish a phone call, they will send a wake up to the phone via the cellular connection, which isn’t the greatest … this can result in call failure and probably is what you are seeing. This is what is called ‘Doze’ and it has been around since Android 6.0
  • For you to rule this out, I would suggest you do the following
    • In the Android Settings, set the phone to Airplane Mode, and then turn the WiFi back on. (you will not see the Republic Arc change from empty to filled, again complements of Android)
      • If after some period of time with the screen off, you are called and it fails to go through … its Doze
  • Next take the phone out of Airplane Mode, and reconnect to your WiFi
    • Plug the phone into its charger (this is one of only two ways to overcome Doze)
    • Now if all your calls come through, this again points to Doze.
  • For a long time, with help from many of the other members/users a ‘workaround’ of sorts has been developed. This is documented in the Tips & Tricks titled Managing Doze Mode - (While on WiFi) calls arrive via cell | calls go to voicemail | calls are missed

Sorry for the long-winded intro, but hopefully you can give it a go

1 Like

Thanks for the detailed (not long-winded) explanation.

So I put phone in airplane mode and then turned wifi back on. The phone stayed in airplane mode, wifi turned on. I called a couple of times and the phone rang. (Maybe I didn’t wait long enough? I am testing this again and waiting 1 hour to see if cell phone rings).

Also, I am thinking of leaving my phone permanently connected to the charger when home to see if that solves my problem. Does that make sense to you?

Thanks for your help!

1 Like

Thanks for the update, the new wrinkle is the full Republic Arc in Airplane Mode … first time I remember seeing that mentioned.
AFIK leaving it on the charger will actually do what Android says (and prevent Doze), does sort of take us back a few years to the ‘corded devices’

1 Like

No-- I amended my post-- I got the arc confused with the wifi symbol. Sorry. There was no Republic Arc!!!

So this time I waited an hour and called and the cell did not ring-- went directly to voice mail proving your explanation that Doze mode is the problem.

Leaving the phone attached to charger is not a problem for me so that is what I will do to solve this problem.

Thanks again for the fast help.

3 Likes

Thank you, I have sent a private message via the forums DM (direct message), you will see a green 1 icon next to your user icon (top right) just click on it

1 Like

I am using Doze workarounds. However, I still have issues. I just called my wife - we’re both on WiFi at home - and her phone did not ring, and went straight to voicemail.

I reset the connections (via app, settings, advanced) on both phones, and the phone rang, and the call went thru.

Just a thought.

1 Like

The macrodroid script you suggested does seem to work. I still miss an occasional call but it appears that more are coming through than before.

Message an
Expert customer