Phone doesn't ring, goes straight to voicemail

Hi. I have a Samsung S8. This has happened before. The phoe doesn’t ring, goes straight to voicemail. Does not give a missed call notification. But does give a voicemail notification most of the time.
I opened a help ticket but nothing seems to work consistently
2 days ago, I found a conversation that said to dial ##72786##
It worked for 2 days and back to not ringing
Any thoughts?

1 Like
  1. Do you have a strong cellular signal? (3 bars or more)
    • Yes or No
      • If No … is your Carrier GSM or CDMA?, and what is your zipcode?
  2. Does this happen when your phone has been idle (screen off) for some period of time?
    • If Yes, this may be an indication that you are running into the problem known as Doze (Google’s method of saving battery, by turning off our phones WiFi) … more discussion would be required, to determine for sure and offer a possible solution

Hi
Yes I have 4 bars.
And I was just on my phone and had my nephew call me and did not ring.
R

1 Like

I only have 2 phones a Moto X4 and a Samsung Galaxy Note 20, and I have seen the time to ‘Doze’ as short as 2-3 mins and as much as 30 mins.

  • As a test, could you leave your phone on the charger for a period of time and see if the problem occurs?

Ok thanks! I will try this.
So if someone calls while my phone is being charged and it doesn’t ring. That would eliminate the “doze” as the problem???
R

1 Like

That would be my belief, however I have been following Doze since Google introduced it in 6.0 and it continues to bring new ‘challenges’ to all.

It says
WiFi
Calls over cell, messages and data over wifi
R

At what time did the Republic ‘Notification’ say that? This would lead me to move our effort towards looking at your WiFi, as this indicates the quality of your WiFi didn’t support Calling and Republic has to shift you over to Cellular

So maybe a bad wifi router?

I think it happens when I am not at home also. Like driving in the car

Let’s stick with ‘at home’ as you should not have any WiFi in the car, unless your are using a hotspot?

  • At home where your phone is usually sitting, could you do the following?
    • Access the Republic Wireless App, then the (?) tab and run the Diagnostics? This will run approx 55 test over a couple of mins and will provide a graphic of the results (a screenshot posted is easiest)

Hi @rhondag.ve5bj7,

Since you have a Samsung phone, another thing to check is the battery management setting described here:

I have been having this issue as well on my S10e and it seems like my wife’s X4 is also having the issue some of the time. This has been happening for probably the past couple weeks. I have run the RW diagnostics and the only 2 issues found are: no cell signal (I live in a valley and there is rarely any signal); and a “crowded” channel. I have a Deck S4 mesh setup with 3 APs and I cannot change the channel of the system. That being said, there is likely only 1 other broadcasting network within range because my closest neighbo’s house is over 200’ away from mine.

I have checked the settings and added the RW app to the never sleep setting, but I still rarely have calls ring through. 90% of the time they go straight to VM. I even turned off the spam call filtering to no avail.

Suggestions? Help?

1 Like
  • In looking at the user docs for your router, I see a couple of things you may want to check
    • Under Advanced
      • Check to see if IPV6 is Enabled, and unless you know you need this on, I would suggest you disable it (RW, afik, does not support IPV6)
      • Check to ensure SIP ALG is not enabled, this has been a constant source of problems with VoIP across all routers
      • Ensure that Beamforming is Enabled
  • Router Firmware, it looks like there have been 3 releases of this, and I would always suggest you keep at the latest level ( see: https://www.tp-link.com/us/support/download/deco-s4/#Firmware

Thanks for the tips! I believe that I solved the issue.

I noticed that in the RW app, there is the setting for “Show Samsung WiFi Calling enabled”. This is checked, and I haven’t seen any notifications about WiFi Calling enabled while I’m home. I have seen the notification when I’m out at other places that have public WiFi (like Walmart). I hadn’t really given any thought to the notification and didn’t know which app was sending the notification, and just assumed it was telling me that my calling was going through WiFi instead of the network.

Long story short, I looked in my S10e’s settings (had to search for “WiFi Calling”) to find the setting and sure enough it was enabled. The RW app states that if that setting is enabled, RW calls via WiFi won’t function properly. So I unchecked that setting and now it appears that I can receive calls while on WiFi (I was able to make calls without issue before, jut not receive them).

Thanks! (I also verified that my router is setup as you suggested and all is fine on that front)

1 Like

@arrow,
Thanks for the feedback that highlights the importance of turning off the Samsungs WiFi calling, which apparently removed the contention between the device code and Republics WiFi calling, however, I don’t see that this will fix the problem at home, where the Android Doze code will turn off the WiFi when the phone is idle and the screen is off. This probably is a totally un-related issue that many of us experience.

Any feedback on your TP-Link Deco S4 mesh network?, Some real user feedback would be key for some us to try to stay current with the many products in a field that is still rapidly expanding.

A post was merged into an existing topic: Mesh WiFi - a coming of age technology?

Hi.
Thank you for your help
It was an issue with my cell subscription. Hopefully will not have anymore issues.
Appreciate you reaching out

Rhonda

1 Like

Thank you all!
Ends up it was the way my cell subscription was configured or lack of.
All good so far!
Rhonda

So, I am still having the issue. I believe that I’ve tracked it down though. For some reason the RW app gets shutdown (arc notification disappears). When this happens, all calls go straight to VM.

I checked that the RW app isn’t optimized and this still happens. I even tried “locking” the app in recent apps since I was reading that would keep an app always open in the background - still experience the arc disappearing. I know that there’s a thread detailing a macro that can be run to keep the WiFi on which should theoretically help this issue. I will try that next. I have noticed something interesting though with battery optimization. The RW app shows up and I can uncheck it so that it doesn’t optimize it. Well at least after a fresh install of the RW app. Then at some point, it seems like the RW app disappears entirely from the list of apps that can be optimized (yes, I change the filter to “all”). The app just is gone from this list entirely. I have a feeling that this could be connected to the issue as it is possible that RW is in fact still being optimized because Android no longer sees it as an app to “not optimize”. The only way to get it to show back up in that list (that I’ve found) is to uninstall and reinstall the RW app. However, I’m not going to make this a daily (or more) routine just to test if that is really the issue.

Also, to be clear my phone has ZERO cell signal at my house which appears to be the only place where this happens (now at least).

Message an
Expert customer