Phone doesn't ring, goes straight to voicemail

I think it happens when I am not at home also. Like driving in the car

Let’s stick with ‘at home’ as you should not have any WiFi in the car, unless your are using a hotspot?

  • At home where your phone is usually sitting, could you do the following?
    • Access the Republic Wireless App, then the (?) tab and run the Diagnostics? This will run approx 55 test over a couple of mins and will provide a graphic of the results (a screenshot posted is easiest)

Hi @rhondag.ve5bj7,

Since you have a Samsung phone, another thing to check is the battery management setting described here:

I have been having this issue as well on my S10e and it seems like my wife’s X4 is also having the issue some of the time. This has been happening for probably the past couple weeks. I have run the RW diagnostics and the only 2 issues found are: no cell signal (I live in a valley and there is rarely any signal); and a “crowded” channel. I have a Deck S4 mesh setup with 3 APs and I cannot change the channel of the system. That being said, there is likely only 1 other broadcasting network within range because my closest neighbo’s house is over 200’ away from mine.

I have checked the settings and added the RW app to the never sleep setting, but I still rarely have calls ring through. 90% of the time they go straight to VM. I even turned off the spam call filtering to no avail.

Suggestions? Help?

1 Like
  • In looking at the user docs for your router, I see a couple of things you may want to check
    • Under Advanced
      • Check to see if IPV6 is Enabled, and unless you know you need this on, I would suggest you disable it (RW, afik, does not support IPV6)
      • Check to ensure SIP ALG is not enabled, this has been a constant source of problems with VoIP across all routers
      • Ensure that Beamforming is Enabled
  • Router Firmware, it looks like there have been 3 releases of this, and I would always suggest you keep at the latest level ( see: https://www.tp-link.com/us/support/download/deco-s4/#Firmware

Thanks for the tips! I believe that I solved the issue.

I noticed that in the RW app, there is the setting for “Show Samsung WiFi Calling enabled”. This is checked, and I haven’t seen any notifications about WiFi Calling enabled while I’m home. I have seen the notification when I’m out at other places that have public WiFi (like Walmart). I hadn’t really given any thought to the notification and didn’t know which app was sending the notification, and just assumed it was telling me that my calling was going through WiFi instead of the network.

Long story short, I looked in my S10e’s settings (had to search for “WiFi Calling”) to find the setting and sure enough it was enabled. The RW app states that if that setting is enabled, RW calls via WiFi won’t function properly. So I unchecked that setting and now it appears that I can receive calls while on WiFi (I was able to make calls without issue before, jut not receive them).

Thanks! (I also verified that my router is setup as you suggested and all is fine on that front)

1 Like

@arrow,
Thanks for the feedback that highlights the importance of turning off the Samsungs WiFi calling, which apparently removed the contention between the device code and Republics WiFi calling, however, I don’t see that this will fix the problem at home, where the Android Doze code will turn off the WiFi when the phone is idle and the screen is off. This probably is a totally un-related issue that many of us experience.

Any feedback on your TP-Link Deco S4 mesh network?, Some real user feedback would be key for some us to try to stay current with the many products in a field that is still rapidly expanding.

A post was merged into an existing topic: Mesh WiFi - a coming of age technology?

Hi.
Thank you for your help
It was an issue with my cell subscription. Hopefully will not have anymore issues.
Appreciate you reaching out

Rhonda

1 Like

Thank you all!
Ends up it was the way my cell subscription was configured or lack of.
All good so far!
Rhonda

So, I am still having the issue. I believe that I’ve tracked it down though. For some reason the RW app gets shutdown (arc notification disappears). When this happens, all calls go straight to VM.

I checked that the RW app isn’t optimized and this still happens. I even tried “locking” the app in recent apps since I was reading that would keep an app always open in the background - still experience the arc disappearing. I know that there’s a thread detailing a macro that can be run to keep the WiFi on which should theoretically help this issue. I will try that next. I have noticed something interesting though with battery optimization. The RW app shows up and I can uncheck it so that it doesn’t optimize it. Well at least after a fresh install of the RW app. Then at some point, it seems like the RW app disappears entirely from the list of apps that can be optimized (yes, I change the filter to “all”). The app just is gone from this list entirely. I have a feeling that this could be connected to the issue as it is possible that RW is in fact still being optimized because Android no longer sees it as an app to “not optimize”. The only way to get it to show back up in that list (that I’ve found) is to uninstall and reinstall the RW app. However, I’m not going to make this a daily (or more) routine just to test if that is really the issue.

Also, to be clear my phone has ZERO cell signal at my house which appears to be the only place where this happens (now at least).

This, in my estimation, is a classic example of the Android initiated ‘Doze’ … it shuts down your WiFi’s ability to transmit or receive signals. This has been around in various forms on all Android phones from 6.0 to the latest 11.0. I have been joined by many others in the community in trying to provide relief for this situation.

The Phone will Doze and kill your WiFi in a time frame of 60+ to 2-3 minutes.
Work is still in progress but the latest available Doze Detect Macro is discussed and available in Managing Doze Mode - (phone is on WiFi) calls via cell | calls go to voicemail | calls are missed

Thanks for the direct link. The strange thing is that for me, it appears to also happen when the phone is on the charger (wireless). Another odd thing is that I still receive other notifications and texts even if my calls go straight to VM. I will try the macro and see if that cures it though and will report back here.

Does anyone have any guess as to why the RW app disappears from the listed apps under battery optimization? I feel like this may be a smoking gun and if solved, could fix this issue for others. Since I still get other notifications that come in via WiFi, it could be that the RW app is getting turned off by Android since it’s no longer excluded from optimization.

The new ‘strange thing’ (fails when on the charger) is something that would need further examination (not sure how the code detects on charger, but have never seen Doze kick in on any phone while charging that I have had since Android 6.0 came out). I will test on my Samsung Note 20, which has wireless charging, but if you could try your phone on a hardwire charger it would be best to confirm in your environment.

So, new development discovered while testing today… I called my phone while it was on the wireless charger and it went straight to VM. Called a couple times to be sure. Then I turned on the screen (w/o unlocking it). Called. Same thing. Then I unlocked the phone and called it. Same thing. This time I could verify that the RW arc was visible. I then opened the RW app. Still no change when calling it. Opened the Phone app. No change. Next, I called out from the phone (which worked fine). Then I could receive calls once again.

I didn’t try to turn off the screen and see if it would ring, but I should have. Might try that tonight.

This was all with the macro you shared running on my phone (at least I assume it is running as I followed the steps linked). Actually, what made me think to start testing it was that the screen came on while it was charging and then turned off (assuming that was the macro running).

So basically, I’m really scratching my head now…

UPDATE: apparently I didn’t have the MacroDroid macro running. Will see how things fair with it running now.

UPDATE #2: Calls still going directly to VM when the screen is off. Will try with the screen on. Seems like the only thing that the MacroDroid macro is doing is resulting in me having to unlock my phone twice (PIN). I unlock the phone and then the screen flashes like it’s unlocking and then goes black and back to the Always On display and I have to unlock it again.

The macro developer has a disclaimer on unlocking, it doesn’t always work. So try it with the security lock turned off, and on the wireless charger if you could.

Unfortunately, I don’t think that I can easily turn off the lock because I use my phone for work and it requires the phone to have the security lock on it. I will see if I can do that temporarily without having to uninstall the entire Office365 suite that I use for work.

1 Like

Update on the MarcoDroid macro: it seems as though it doesn’t actually trigger anything until I unlock my phone and once I do, if the RW notification isn’t on, then it turns off the screen once the notification displays again resulting in me have to unlock the phone again.

Seems like it’s unable to run the macro while my phone is locked (even though the MacroDroid notification is present and I have it on the list of apps not to sleep - well it was an app that wasn’t “optimized”, but that also means that it won’t show up in the list to add it to the “never sleep” list. I am going to test it on the never sleep list and see if that changes it’s behavior.

Changing those settings resulted in no change of app behavior.

Still scratching my head on this and trying to find a solution.

At least if my cell goes straight to VM, someone can call my work number and MS Teams rings right on through regardless of the state of the RW app.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.

Message an
Expert customer