Phone doesn't ring on my end

#1

My wife calls me and hears multiple rings as the dialer. I hear only one ring, and it seems like the last one before a transfer to voice mail because when I answer, there’s no one there. Very frustrating.

0 Likes

#2

Please provide answers to the following:

  1. Which phone do you have?
  2. Does this occur when at Work or home? (assuming both are WiFi)
  3. Has the phone been idle for some period of time before the incoming call fails? (usually about an hour)
1 Like

#3

1.Samsung S9.

  1. Both places, and yes, both generally are on wifi. However, sometimes the work wifi signal fades in and out.

  2. Probably it’s been idle for a while.

0 Likes

#4

There may be multiple issues at play. At work the WiFi signal fading issue is best dealt with by your IT folks.

0 Likes

#5

I did the alternative MacroDroid/Doze detect RW option. I browsed as a guest, found the Macro, clicked + and enabled notification for the app. Is that all that I do? No configuration needed?

Thanks.

0 Likes

#6

Just make sure you Enable it … both the MacroDroid and the macro itself … it should look like this

1 Like

automatically bumped #7
0 Likes

automatically bumped #8
0 Likes

#9

Did the Doze fix that was provided help your problem?

0 Likes

#10

I have no idea whether Doze Detect is properly installed or enabled. I also can’t find that image.

MacroDroid is installed. It shows (1) on the app page icon. I see the “M” logo in the notification bar. But I can’t find anywhere in the app that shows me the macros installed, nor any way to bring up the image you link to.

0 Likes

#11

If you see the “M” image in the notification/status bar then it is enabled. A 1 finger swipe down from the top should show its notification (probably along with Republics)

  • This should expose the 6 panels
  • Top left (dark blue) should show Macros (1)
    • Tap this and you should see two grey panels at the top …both should have the sliders to the right
    • A tap of this will show the Macro in the Edit Mode (and you don’t need to do anything here, just a reference point)
0 Likes

#12

Can’t find the image. If I swipe down from the notification bar, I get the Republic notifications. I’m shown MacroDroid Mode: Standard. If I touch that, it takes me to the app.

The horizontal centered line, if swiped down, shows lots Republic apps, but not the MacroDroid.

0 Likes

#13

I don’t have the Samsung S9 that you are using (have Moto X Pure) so am unable to verify that we should see the same thing. I have searched the macrodroid forum and don’t see any mention of failures at that level.
Hopefully another user with the S9 could join in and help us out?

0 Likes

#17

Hi @jaylh,

Are you still having trouble with your phone not ringing for inbound calls, and have you been able to get the Macrodroid automation set up?

0 Likes

#18

I think I’ve got Macrodroid set up. I need more time to see whether the ringing issue is resolved. It was a “sometimes” problem that particularly annoyed my wife. I see how things go over time.

1 Like

#19

If you open the MacroDroid app and select the :menu: Menu top left the the ‘User Log’ you should see a log with periodic date/times of the On Cell and On WiFi events (if it is working as intended)

0 Likes

#20

I opened the user log and saw the initial instruction, and clicked “got it.” Currently there is nothing in the log but a reference to a text notification. No calls are logged, but maybe the log wasn’t enabled.

Is there anything else I should be doing to check if I have this set up right? The phone’s notification bar shows the logo.

0 Likes

#21

When you open the MD app you should see this view:


Tap the Macros section and you should see this view … both toggles should be to the right

0 Likes

#22

Ok, the Doze Detect macro wasn’t installed at all. Now it is, and the two switches are toggled right (on).

The second grey box (Doze Detect - Ver. 0.9.4 began with “never activated”) which I suppose makes sense, since nothing could have happened before installation. Now its says "last activated: 0 minutes ago.

I’ll have to see what experience I have now. For two weeks, I’ve been thinking the macro was installed.

Thank you.

0 Likes

automatically bumped #23
0 Likes

Message an
Expert customer