Phone not defaulting to WiFi, even though connected

New phone, new user. Phone - Moto G4. I live in area with no cell service, hence WiFi based phone. When I came from town today, phone connected correctly to my WiFi but when I call I get message: Cellular network not available for voice calls. Why is the phone not using the connected WiFi as a default?

I know this is old but did you ever get this fixed? I’m having the exact same problem on my G5 Plus. WiFi is solid and data is fine but I can’t make calls.

Have you received a response yet? I have the same problem and I can’t even get a Republic Wireless person to respond to my opened ticket.

I did get a response. I turned off Cell Data in the Data Usage section of
Settings. Seems to work OK now. When I need to have it, I just turn it back
on.

Since my DSL at home gets wonky, I occasionally have to disconnect my WiFi
in Settings (even though it says ‘Connected’) and then re-select it. I
think that when the DSL ‘blips’ in the background, the phone gets
disconnected and needs to be reset. That process is a little annoying, but
seems to have solved the problem.

I have had little or no problem while out-and-about where a local business
has WiFi. My query had to do with my home setup.

Message an
Expert customer