Phone not using WiFi at home

What phone do you have?

What plan are you on?

Does your plan include data, or just talk & text?


Issue Description

I have a Motorola 5 phone. The phone has been switching off wifi access while not being used for awhile. Now I am connected to the internet WiFi at my house but cannot make the phone connected. It says connected to the internet. Calls will be made over cellular network. I ran a diagnostics on the phone and it brought up the possible issue of cross signal. When I look for available networks, I see a Xfinity open network. I do not have Xfinity, it says it is available to Xfinity customers but my phone connects to it regardless. I have tried removing it from my phones list of saved networks and have chosen to be asked when joining a network not on the list but my phone still automatically joins this network. My husband has the same phone and we are both having this issue. I tried resetting my network settings with no change. Does anyone know how I can block this unknown and unwanted network from my phone so that it does not interfere with my home networks?

If it is an ‘Open Network’ (no lock shown), when you display available WiFi then you should be able to prevent connecting by making sure that you do not have ‘Connect to open networks’ Enabled.
As various OS’s and phones have chosen to hide things for us in the Settings, I have resorted to using the Search (Magnifying Glass) once I navigate to Settings.
Search on Connect found it for me
Else on my Moto X4 it is Settings (Android) / Network & Internet /Wi-Fi / Wi-Fi preferences / Connect to open networks (slide to left greyed out)

Hi @karenr.1,

It’s been about a week since we heard from you. Were you able to prevent your phone from connecting to the Xfinity network using the steps @jben provided?

Not having issue currently

Message an
Expert customer