Phone often does not ring - @home with wifi & weak cell signal

moto e4, android 7.1

background: we live in a mobile dead zone. on a good day, in the right part of the house, we might get “one bar” for a cell signal. So, we rely entirely on wifi calling while at home. When at home, I regularly set my phone to airplane mode. My wife just leaves wifi and cell on all the time…mostly because she’s afraid that she’ll forget to turn off airplane mode when she leaves the house.

I am in the middle of debugging a issue where her phone does not ring, and calls go directly to voicemail. I don’t seem to have that problem, so I started looking for differences. It does not seem to be related to the so-called “doze” issue, as the problem happens when the phone is plugged in.

I then tried putting her phone in airplane mode, and that seemed to make a difference. My test calls (from my phone to hers) caused her phone to ring when in airplane mode, vs. straight to voicemail when she was not in airplane mode.

Anyway, I am stopping to check with the experts here on a theory I have…

Is it possible, given that we have a weak cell signal, that the phone is confused when a call comes in? In other words, could the phone be trying to take the call via cell, but ends up going to voicemail, because the signal is not strong enough? Ideally, I was hoping that the phone would use the stronger path, but maybe that’s asking too much.

I currently have her phone on airplane mode, and will monitor over the next few days. I welcome your thoughts and insight. Thanks!

Stay safe!

A few days ago I created a Tips & Tricks article titled WiFi Help - Internet connectivity - COVID-19 and the current times
I added this to this statement

When troubleshooting any connectivity problem it is always a good idea to observe (and make note of) what the Republic code has detected & reported (via a Notification) … these may be seen by swiping down from the top (Status line)

You are correct in your statement that it would not be a Doze problem when your wife’s phone fails and it is plugged in to the charger.

  • My understanding of the call set up is as follows:
    • Phone is connected to Republic via your WiFi and the public Internet, this completes a SIP register with the Republic server and then the device maintains this connection via ‘keep alive’s’
    • A call cones in to Republic for your wife’s phone and an ‘Invite’ is routed to the phone … if acknowledged properly the call is initiated and 2 way communication begins
    • If the call is not initiated via by the VoIP routine, or the phone has lost the SIP session (poor WiFi in you house or any problem within the public Internet connection … the call will be handed over to Cell for completion
    • If the connection can’t be made via cell it will be passed to the voicemail
  • Cellphones are very good at hanging onto a signal, even a poor one … so possibly she is being caught with a very poor cell (known) a weak WiFi (unknown) and a WiFi adapter in the phone that is not as good as yours?

I would suggest the following course of action

  1. Go through the 3 steps that are outlined in WiFi Help - Internet connectivity - COVID-19 and the current times
  2. Unless the phone is always plugged in, I would install the ‘fix’ outlined in Managing Doze Mode - (phone is on WiFi) calls via cell | calls go to voicemail | calls are missed
  3. On the next failure, make note of the Notification What are the Connectivity Status Notifications? – Republic Help
  4. Observe the MacroDroid ‘user log’ by accessing the app’s :menu: Menu and provide a snippet of the log.

Thanks for the tips. I will continue testing.

FYI: wifi is very strong. diag apps show no channel interference from neighbors (I live in a sparsely populated area anyway). When this issue happened this morning, the phone was plugged in, and connected to wifi, so that’s why i did not suspect “doze.”

Don’t you just love intermittents?

There all ‘intermittent’ until it’s possible to re-create the exact steps up to the point of failure. :slight_smile: That is one of the reasons that I feel the RW Notification is so important. As this failure appears to happen quite often, there is the possibility that once you capture that a complete description including what the code logged could be combined with the host data that the Republic folks can access would lead to a better understanding.

I’ve run a few tests with the phone in airplane mode. RW notification reports that phone is connected to WiFi. Phone rings consistently - plugged in or not. Left it unplugged overnight, and it rang this morning when I called it.
I now plan to take it out of airplane mode, and do same test. This is how it’s been for several years: WiFi on, cell and data on (albeit without a decent signal)…and working fine until lately. Stay tuned!

Phone sat overnight, unplugged, not in airplane mode. Full WiFi, marginal cell. I called it this morning, and it rang. I haven’t implemented the macro droid workaround yet.

So, I’m nowhere! Standing down for now. Stay safe, my RW friends.

I’m going to move the topic to #discussions, then, but if you need to resume troubleshooting, we can easily move it back into #problems

After a few days of working fine, the phone did not ring this morning. Instead, it went straight to v-mail. Here’s the background:

  • phone is on (strong) wifi and (weak) cell, as it has been for several days (and was ringing). it sat idle overnight and was not plugged in.
  • this morning, no RW “mustache” at top of screen
  • I ran the diags. I got one error: “cell network operator test failed to read MCC/MNC…” It goes on to note that it may not be a problem
  • reset connection via app
  • phone now rings
  • I re-ran the diags, and I still get the MCC/MNC error message.
  • still no “mustache” - even after connection reset
  • I enabled airplane mode, then re-enabled wifi, and immediately got the “not connected to the cellular network” RW notification
  • I then exited airplane mode (wifi still enabled), and now have “connected to ‘mySSID’” notification

So, it seems that the “error” may not be causing the issue. Every time I’ve had this issue, it’s been cleared up (albeit temporarily) by doing a connection reset. I do have a log file that I can share.

I’m now stuck again. Thanks.

Ps - i just realized that I did not save the log file generated before I did the reset. So, this log file may not be helpful. Dang.

Hi @ceedee,

I’m going to copy and paste your list below, and see if you can futher isolate when and where things start to change.

  • phone is on (strong) wifi and (weak) cell, as it has been for several days (and was ringing). it sat idle overnight and was not plugged in.
  • :arrow_right: this morning, no RW “mustache” at top of screen
    • If you pull down to view the notification, how does the RW app describe its current state?
    • Would it ring in this state?
    • Can it surf internet sites you’ve never before visited?
  • I ran the diags. I got one error: “cell network operator test failed to read MCC/MNC…” It goes on to note that it may not be a problem
  • reset connection via app
  • phone now rings
  • I re-ran the diags, and I still get the MCC/MNC error message.
  • :arrow_right: still no “mustache” - even after connection reset
    • If you pull down to view the notification, how does the RW app describe its current state?
  • I enabled airplane mode, then re-enabled wifi, and immediately got the “not connected to the cellular network” RW notification
  • :arrow_right: I then exited airplane mode (wifi still enabled), and now have “connected to ‘mySSID’” notification
    • If you went back into airplane mode with WiFi enabled at this point, does the RW arc/status change again?

hi @southpaw,

Phone did not ring this morning, so I should be able to tackle most/all of your questions.


On 4/4/2020 9:31 PM, southpaw via Republic Community wrote:

Hi [@ceedee](file:///u/ceedee),

I’m going to copy and paste your list below, and see if you can futher isolate when and where things start to change.

  • phone is on (strong) wifi and (weak) cell, as it has been for several days (and was ringing). it sat idle overnight and was not plugged in.
  • :arrow_right: this morning, no RW “mustache” at top of screen
    • If you pull down to view the notification, how does the RW app describe its current state?
      When I first posted this a few days ago, there was no notification at all. Nada. Today, I have a filled-in arc, with message saying that it’s attached to my wifi
    • Can it surf internet sites you’ve never before visited?
      Yes
  • I ran the diags. I got one error: “cell network operator test failed to read MCC/MNC…” It goes on to note that it may not be a problem
  • reset connection via app
  • phone now rings
  • I re-ran the diags, and I still get the MCC/MNC error message.
  • :arrow_right: still no “mustache” - even after connection reset
    • If you pull down to view the notification, how does the RW app describe its current state?

Just did a reset. Message is now “calls over cell. no access to messages or voicemails. check your network connection.” Note that wifi is fully enabled and I can access sites via a browser.

Just ran the diags. no ringing. note that my phone does not give me a ringing tone either. After about 10-12 seconds, I get my wife’s vmail. That’s it. So, no indication on my end that it’s trying to place a call.

  • I enabled airplane mode, then re-enabled wifi, and immediately got the “not connected to the cellular network” RW notification
  • :arrow_right: I then exited airplane mode (wifi still enabled), and now have “connected to ‘mySSID’” notification
    • If you went back into airplane mode with WiFi enabled at this point, does the RW arc/status change again?

I just enabled airplane mode. Message is now “not connected to the cellular network.” Wifi is still enabled and working. I just placed a call, and the phone rang. I then took the phone off airplane mode. Message is now “connected to ‘mySSID’” Phone rings.

I hope this helps. I also have a diag log that I saved before doing all of this.

Thanks,

Chris

While poking around again this morning, the phone once again did not ring. I put it on airplane mode, and it rang. Took it off airplane mode, and it rang. I did not do a connection reset this time.

I need a more rigorous test methodology. I’m not happy with my current approach. Not structured enough IMO.

What kind of router do you have?

When you’re in that state where the the status is “calls over cell” but the phone is able to use the internet, could you try rebotting your network?

It looks like you’re staying connected to the internet, but losing just the MQTT connection to our servers. I’m wondering whether that’s happening on the phone or on the router.

TP-Link AC1750. I will reboot when it happens again.

Her phone has been fine for several years,just started acting up. My G5+ does not seem to have this issue, although I’m always in airplane mode when I’m home (if that’s a factor).

Hi again,
The phone was sitting idle for a bit, so I picked it up to check the RW notification. It was a solid arc, and the text indicated that it was connected to wifi. I tried to make a call, and the phone did not ring…going to vmail after about 10-12 sec - so same behavior. I immediately ran the diags and MQTT was true. I put the phone down, rebooted the router, and made another call. The phone rang.

Oh, but the plot thickens. After typing in this post, I tried the phone again - I figure less than 10 minutes since prior call. No ringing.

If I then put the phone on airplane mode, it rings. Then, 5 minutes later, it doesn’t. So, I disabled airplane mode. No ring. Then, I re-enabled it again. Phone rings.

Standing by…

Maybe try rebooting the router next time, with no interaction with the phone, just to rule out that interacting with the phone is somehow cleariing this state?

I’m not sure if that makes sense… I’m just wondering if MQTT was restored to “true” simply by running the diagnostics.

As the timing for various phones and various OS levels have change the timing for the device WiFi transmitters/receivers to be put to sleep by the battery saving Doze function (that was initiated by Android in 6.0 and has been constantly changed since) I would still consider this could possibly attributed to Doze.

Ok. BTW, toggling airplane mode seems to always reset “something” and the phone rings. Very consistent.

Android on this phone has been stuck at 7.1 for some time. I’ve had the router for two years, with no config changes. The phone “behaved” itself for quite some time before this issue. Still, we all know that something has changed! It bugs me that I don’t know what did.

I’m holding the phone. It’s quite awake. I call it. Does not ring. I toggle airplane mode. It rings.

Still not convinced that it’s a doze issue.

Good Morning!
I called the phone this morning and it did not ring. I did not touch it, and immediately rebooted the router. The phone rang after the reboot,

When I did pick up the phone, the arc was solid, and was “connected to ‘mySSID’”

@jben i added a macro to wake up the phone every 50 minutes.

Thanks.

@jben, would you be willing to try to dive into the TP-Link AC1750 specs to see if you see anything there that might be closing down MQTT or SIP after a period of time? Or maybe some configurable QOS settings to keep the phone prioritized?

Thanks @ceedee,

Next, if you’re still game, would you mind creating a log the next few times you try this that provides the last 4 digits of the calling phone, the time of the call, the state of the G5+'s RW notification, any steps you took, and whether the call was successful.

Like:

From 1234 at 4/5/2020 10:33 a.m. ET, RW notification “cell calls”, after a period of inactivity, call fails.
From 1234 at 4/5/2020 10:35 a.m. ET, RW notification “connected to” my network, rebooted router, call succeeds.

I’d like to gather a few call samples, pull the device logs, and create a ticket on your behalf to see if our technicians have any insight.

Message an
Expert customer