Phone often does not ring - @home with wifi & weak cell signal

While poking around again this morning, the phone once again did not ring. I put it on airplane mode, and it rang. Took it off airplane mode, and it rang. I did not do a connection reset this time.

I need a more rigorous test methodology. I’m not happy with my current approach. Not structured enough IMO.

What kind of router do you have?

When you’re in that state where the the status is “calls over cell” but the phone is able to use the internet, could you try rebotting your network?

It looks like you’re staying connected to the internet, but losing just the MQTT connection to our servers. I’m wondering whether that’s happening on the phone or on the router.

TP-Link AC1750. I will reboot when it happens again.

Her phone has been fine for several years,just started acting up. My G5+ does not seem to have this issue, although I’m always in airplane mode when I’m home (if that’s a factor).

Hi again,
The phone was sitting idle for a bit, so I picked it up to check the RW notification. It was a solid arc, and the text indicated that it was connected to wifi. I tried to make a call, and the phone did not ring…going to vmail after about 10-12 sec - so same behavior. I immediately ran the diags and MQTT was true. I put the phone down, rebooted the router, and made another call. The phone rang.

Oh, but the plot thickens. After typing in this post, I tried the phone again - I figure less than 10 minutes since prior call. No ringing.

If I then put the phone on airplane mode, it rings. Then, 5 minutes later, it doesn’t. So, I disabled airplane mode. No ring. Then, I re-enabled it again. Phone rings.

Standing by…

Maybe try rebooting the router next time, with no interaction with the phone, just to rule out that interacting with the phone is somehow cleariing this state?

I’m not sure if that makes sense… I’m just wondering if MQTT was restored to “true” simply by running the diagnostics.

As the timing for various phones and various OS levels have change the timing for the device WiFi transmitters/receivers to be put to sleep by the battery saving Doze function (that was initiated by Android in 6.0 and has been constantly changed since) I would still consider this could possibly attributed to Doze.

Ok. BTW, toggling airplane mode seems to always reset “something” and the phone rings. Very consistent.

Android on this phone has been stuck at 7.1 for some time. I’ve had the router for two years, with no config changes. The phone “behaved” itself for quite some time before this issue. Still, we all know that something has changed! It bugs me that I don’t know what did.

I’m holding the phone. It’s quite awake. I call it. Does not ring. I toggle airplane mode. It rings.

Still not convinced that it’s a doze issue.

Good Morning!
I called the phone this morning and it did not ring. I did not touch it, and immediately rebooted the router. The phone rang after the reboot,

When I did pick up the phone, the arc was solid, and was “connected to ‘mySSID’”

@jben i added a macro to wake up the phone every 50 minutes.

Thanks.

@jben, would you be willing to try to dive into the TP-Link AC1750 specs to see if you see anything there that might be closing down MQTT or SIP after a period of time? Or maybe some configurable QOS settings to keep the phone prioritized?

Thanks @ceedee,

Next, if you’re still game, would you mind creating a log the next few times you try this that provides the last 4 digits of the calling phone, the time of the call, the state of the G5+'s RW notification, any steps you took, and whether the call was successful.

Like:

From 1234 at 4/5/2020 10:33 a.m. ET, RW notification “cell calls”, after a period of inactivity, call fails.
From 1234 at 4/5/2020 10:35 a.m. ET, RW notification “connected to” my network, rebooted router, call succeeds.

I’d like to gather a few call samples, pull the device logs, and create a ticket on your behalf to see if our technicians have any insight.

Will do!

  • I can’t find anything that would allow checking SIP ALG, and it is something that all VoIP providers suggest be disabled.

    • I did find in their community a response for a different TP link router where the user was told: “If you need disable SIP ALG, you would better contact support@tp-link.com
  • I really find no mention of MQTT outside of how a certain IOT device could be affected

  • I find nothing that discusses WMM, which should be enabled to provide QoS at the WiFi level

  • I am making an assumption that @ceede is using it as a basic home router, and not as a gaming router or as part of a mesh network … could you confirm?

Things that I would suggest

  • Ensure that the router is at the latest level of firmware, as it appears there have been 3 updates
  • Router has the ability to configure a time based ‘Reboot’ … how to is in the User Guide
  • Router appears to have extensive logging, however I have no idea what they might show, perhaps @ceedee could explore
1 Like

Started the log while I was eating lunch. I have the phone on WiFi and cell - no airplane mode. I called at 11:51; no ring. I enabled AM, and it rang. Took it off AM. Waited 10 minutes. Same failure. Same actions taken as above. Waited another 10 minutes. Same failure, same actions taken. Waited 5 minutes, same results.

I will look at the log. Firmware is up-to-date. WMM is enabled.
Here are my ALG settings

Ok, I couldn’t find that page in any of the online manuals

  • I would definitely UNCHECK the Enable SIP ALG, as I have never seen any updates from any SIP provider that think it works.
1 Like

Just disabled it.

1 Like

Thanks, at this time perhaps we should consider no further changes until this has been proven effective/in-effective … what are your thoughts?

Yes, a soak is in order. I’ll track for a few days. Thanks!

2 Likes

I have been comparing settings of my wife’s 7.1 vs my 8.1. I noticed that her RW app was set for “battery optimized,” while my app on 8.1:apparently does not allow optimization.

I changed hers to “not optimized,”. but I wonder if it matters.

I have violated the debugging code of conduct by changing too many things at once! I disabled SIP, I added a MacroDroid macro to wake up the phone, and I disabled battery optimization. Yikes!

But at least you know what you’ve changed, so once the issue is resolved, you could change each thing back individually until you break it again to discover the culprit!

Except, husband code of conduct probably overrules debugging code of conduct.

1 Like
Message an
Expert customer