Phone often does not ring - @home with wifi & weak cell signal

Will do!

  • I can’t find anything that would allow checking SIP ALG, and it is something that all VoIP providers suggest be disabled.

    • I did find in their community a response for a different TP link router where the user was told: “If you need disable SIP ALG, you would better contact support@tp-link.com
  • I really find no mention of MQTT outside of how a certain IOT device could be affected

  • I find nothing that discusses WMM, which should be enabled to provide QoS at the WiFi level

  • I am making an assumption that @ceede is using it as a basic home router, and not as a gaming router or as part of a mesh network … could you confirm?

Things that I would suggest

  • Ensure that the router is at the latest level of firmware, as it appears there have been 3 updates
  • Router has the ability to configure a time based ‘Reboot’ … how to is in the User Guide
  • Router appears to have extensive logging, however I have no idea what they might show, perhaps @ceedee could explore
1 Like

Started the log while I was eating lunch. I have the phone on WiFi and cell - no airplane mode. I called at 11:51; no ring. I enabled AM, and it rang. Took it off AM. Waited 10 minutes. Same failure. Same actions taken as above. Waited another 10 minutes. Same failure, same actions taken. Waited 5 minutes, same results.

I will look at the log. Firmware is up-to-date. WMM is enabled.
Here are my ALG settings

Ok, I couldn’t find that page in any of the online manuals

  • I would definitely UNCHECK the Enable SIP ALG, as I have never seen any updates from any SIP provider that think it works.
1 Like

Just disabled it.

1 Like

Thanks, at this time perhaps we should consider no further changes until this has been proven effective/in-effective … what are your thoughts?

Yes, a soak is in order. I’ll track for a few days. Thanks!

2 Likes

I have been comparing settings of my wife’s 7.1 vs my 8.1. I noticed that her RW app was set for “battery optimized,” while my app on 8.1:apparently does not allow optimization.

I changed hers to “not optimized,”. but I wonder if it matters.

I have violated the debugging code of conduct by changing too many things at once! I disabled SIP, I added a MacroDroid macro to wake up the phone, and I disabled battery optimization. Yikes!

But at least you know what you’ve changed, so once the issue is resolved, you could change each thing back individually until you break it again to discover the culprit!

Except, husband code of conduct probably overrules debugging code of conduct.

1 Like

Oh, yea. My curiosity will come into play, but the goal is a phone that rings 100% of the time. Once that happens, I will stop! It’s gonna kill me! :grin:

1 Like

I’ve been calling the phone randomly for the last two days. So far, so good. It sat unplugged overnight, and it rang this morning.

I am optimistic, but I will still give it a few more days.

Thanks @southpaw & @jben for helping me out.

4/9 update:
I’ve been calling the phone randomly at all hours of the day. Most calls are with the phone unplugged. Wifi is active, as is cell (ie. not on airplane mode). For the last few days, the doze fix has been disabled, but SIP ALG is still disabled in my router, and battery optimization has been disabled on the RW app.

As of this morning, 100% success with calls. So, once again, standing down. Let’s hope we solved this once and for all! Thank you, and stay safe.

2 Likes

@ceedee
Thanks for the feedback … at this point it appears that SIP ALG is the culprit … your feedback provides an additional wrinkle that this can cause. Please feedback any changes you encounter, and after some soak time it will incorporated into Router Tweaks so others can benefit from your misfortune

Will do. I’m scratching my head over the fact that it’s a new issue, does not (apparently) affect my G5+, and SIP has been active in this router - and most likely prior routers - with no known issues. Then again, maybe SIP has been an issue, and I didn’t notice it.

I’ve been reading lots of articles about SIP and VoIP. Unfortunately, I don’t know enough about the internals of my router, the RW software, network protocols, etc. to understand what may have been happening. I trust your expertise that enabling SIP is not good!

After this, I need a “SIP” !!! :beer:

2 Likes

Greetings,
After a few days of random testing, I figured all was good. Phone seemed to operate fine since my last post here.

This morning, I called the phone from my car. It was plugged in and connected to WiFi and cellular (ie not airplane mode). The phone did not ring, and didn’t even go to voicemail…which is new. The call was initiated, but I did not hear any ringing on my end, and I hung up after 30 or so seconds. I tried several times with the same result. I contacted my wife on a landline, and she put the phone on airplane mode, and I was able to get thru on her mobile.

No action required…this is just an FYI, as I’m not sure what else we can do. I will re-enable the doze macro, although this recent issue was with the phone plugged in, so doze should not have been a factor.

Cheers.

Thanks for keeping counting the worms in this can :slight_smile:
This may not have anything to do with what your chasing, but after you Disabled SIP ALG, did you reboot the router and then reconnect your phone?
This article seems to imply that the algorithm implemented by the router could possibly kick it at unexpected time and cause previously un-seen problems
Reference => https://www.yay.com/faq/sip/alg/

Question for you, is your TP-Link AC1750 router connected directly to the cable modem, or do you happen to have a modem/router combo like the ISP’s usually provide?

  • I have been doing some reading this afternoon on the problems that Double NAT can cause with VoIP, and have so far learned enough to at least ask the question :slight_smile:
    • Double NAT is cause when two devices are piggybacked and both provide DHCP and one of the ways this can be detected is as follows:

The 3 available Private Address ranges (shown below)
image

The router connected to a standard CM. Thanks for your post!

1 Like

@jben…I did, thanks.