Phone rings but there's no way to answer the call

What phone do you have? Moto x4

What plan are you on? My Choice + 1 GB

Does your plan include data, or just talk & text? 1 GB Data


Issue Description

First thing this morning my phone rang but there was no notification on the screen so I couldn’t answer it. I’ve already restarted the phone several times, cleared the cache, checked the notification settings on the Phone app, and started it in Safe Mode to see if the problem went away (it didn’t).

Hi @marcies.m3uvax and welcome to the Member Community. Let’s start here and see if this helps –

I would also make sure the RW app is updated.

1 Like

Already checked my notifications. I already checked for Motorola updates. How would I make sure the RW app is updated?

You can open the RW app>tap gear in upper right>tap About and see what version is installed. RW released Version 3.28.4.0 on 7/12/2020 and started rolling it out gradually. You might already have the latest version if your phone is set to update apps automatically.

From Google Play help if you do need to check for an update –

Update Android apps manually

To update apps individually or in bulk using the Google Play Store app on your mobile device:

  1. Open the Google Play Store app Google Play|autox18.

  2. Tap Menu Menu|autox18 and then My apps & games .

  3. Apps with an update available are labeled “Update.” You can also search for a specific app.

  4. Tap Update

@marcies.m3uvax,

Is this happening while you are connected to WiFi (and not cell)?
Is it happening in all locations or only at your home?

If you check your Republic app and you’re on a lower version than what @freddyp mentioned

Try opening the Republic Wireless app.
Then tap the settings gear :gear: at top right.
tap call and voicemail settings
tap configure spam call blocking
and make sure it’s set to allow all calls.

Once that’s selected, reboot the phone.

And see if that helps.

Another cause could be a case on the phone. If you have one, try removing it for a test.

Hope this helps.

1 Like

Thank you! I just checked and already have the latest version.

Thanks SuperT. It is happening at home on WIFI and out on Cell. I had already checked that setting and it’s fine. I will remove the case tomorrow and see if that works.

1 Like

Problem solved! I had to clear the data/storage in addition to the cache. Here’s the steps I followed:

  1. Start the Settings app
  2. Tap Apps & notifications
  3. Tap “See all xxx apps”
  4. Find Phone in the list of apps, and tap it.
  5. Tap Storage
  6. Tap either “Clear data” or “Clear storage”, whichever is shown, and confirm by tapping OK. Nothing that you care about is being erased by doing this.
  7. Hold down the Power button, then tap Restart on the screen.
4 Likes

Hi @marcies.m3uvax,

Thank you for confirming that the steps one of our Experts gave you solved the issue.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer