Phone rings once or not at all, and goes straight to voicemail

There was extensive troubleshooting, involving RW looking at calls on their end from the contacts that did it all the time. They could not find anything amiss on their end routing wise, so i figured that it must be something with the other persons provider (Csipire) though it did it a few times, very rarely with a RW contact.

The “doze” macro does not do anything to address this odd calling issue, on the Pixels, as far as the few folks that did test it said, myself included observed.

For me, the issue is random, sometime it happens alot for a time, then not at all for ages.
It has happened across the OG Pixel, and its 2 OS versions it had, and my Pixel 3 with A9 and 10.

If other user has the issue all the time, then could be different issue/cause.

Won’t hurt for them to give it a try though.

@SpeedingCheetah,

Would you be willing to use a ADB hack to disable Doze mode altogether and see if the issue persists on your Pixel?

What frequency are you using on your network?

The issue happens so scarcely now…and i have never been able to replicate it myslef calling my phone from a spare or secondary phone in hand.

I really think it is on the other callers end somehow.
The contact on Cspire that it happens with, was using a flip phone for a while, and it did it almost every-time he called. He got back his smartphone, 2 weeks ago, and it hasnt done it since. (but it did do it in the past with the same phone when he call me.)

But like i said, the issue can happen constantly, for days at a time, then not at all for as much as a month or 2. If it starts up again, perhaps, i can try something more…but he only calls me maybe 2x a week now, as apposed to pretty much each day back when issue first was noticed.

I was not aware that u can disable Doze mode globally via ADB.
That sounds like it would cause battery drain.

Assume u mean WiFi network? I use 5ghz. (80mhz.(5490-5570 MHz) chan 100 main channel. (100-114). What wifi i use makes no difference, as it has done this issue on my grandparents as well as works wifi, all different network equipment. I also have replaced my entire network setup since having my OG Pixel XL. (Asus consumer router, to full Ubiquiti router, switch and enterprise class AP) Made no change. ( i don’t recall if this issue happens when on cell only, i am very rarely away from wifi)

I didn’t mean to hijack this thread…the OP user @janicem.5rzxej maybe can give the ADB hack a try, see if that helps them if they are having the issue much more frequent.

I only have like 2 people that call me semi-often, so I am not very active with calls.

Ok, thanks for the additional details.

I only want to try the ADB solution with a few people who have proven technical acumen. No discredit to the OP, but we simply don’t know her as well in Community. :slightly_smiling_face: Personally, I can’t tell any difference in battery life with Doze completely disabled, but I don’t use my phone as much as some people, so my single experience definitely isn’t gospel.

I have seen an example where a phone was exhibiting this behavior until the member switch from 5 GHz to 2.4 GHz, so I wanted to compare your experience.

Interesting. Though, for me, I was on 2.4ghz band when at work and when visiting my grandparent’s home. And the issue happened in those environments.
2.4ghz is not usable at my home. There are 70+ networks in range. When i do put my phone on that band, it gets very slow speeds, and calls almost always get handedover to cell.

I also do not think it is DOZE related (in the case of Pixel phones), as, to my understanding of that function, that kicks in after a period of inactivity. I have literally used the phone less than 30 secs before, and I see the screen light up, ring once, then stop, with no missed call notification to follow. It has even happened while i was using the phone 2x at some point. The incoming call window came up, one ring, then it gone, and i touched nothing.

Back when in was on 1yr of Sprint, with my OG Pixel XL, the same contact on Cspire woudl call me very often…and this issue never happened for that whole time, or before when i was on Tmobile Pre-paid, or VZW before that. Only once after i switched to RW did it crop up at some point.

I downloaded MacroDroid, as suggested, but need to give it more time to see if it does anything. I don’t get very many calls but when a call goes to voicemail and doesn’t even show a missed call and only has one short ring, it seems to be from one caller. However, I have been told by others that they were unable to reach me - exactly why I don’t know. Perhaps I wasn’t near my phone and didn’t hear the one ring. I don’t have the “technical acumen” necessary to try the ADB solution - I don’t even know what that is! But I appreciate all the helpful folks trying to work on this glitch. I wonder, if I switched to Verizon, which I am not going to do in the foreseeable future, would the same thing happen?

@janicem.5rzxej,
If you encounter any problems implementing the Doze app with MacroDroid, please don’t hesitate to post back for additional help

I’m afraid we don’t have the answer to that. It would depend on whether the issue is entirely something to do with the phone, or if it is something to do with Republic’s hybrid blend of Wi-Fi and Cellular call delivery.

One thing we I see got skipped in this conversation is a very basic question. When you are aware of this behavior, was the phone powered on and was it on Wi-Fi or cell?
If it the phone was off straight to voicemail and no missed call notification is normal.
If it was on cell, this would suggest the phone was in an area of no coverage at the time of the call. If the call can’t “find” the phone (because there’s no coverage) then it won’t ring, and there won’t be a “missed call” notification (those are to alert of you of calls that actually rang the phone, but you missed).
If it was on Wi-Fi, this suggests that there’s something about the combination of the Wi-Fi network, the phone’s state at the time, and the cellular network that’s preventing the call from “finding” the phone.

There are a lot of factors at play, so there may one be one “fix-all” solution depending on your specific situation.

The phone was powered on but asleep and in wi-fi. Thanks for that explanation though. I have noticed in the morning that the phone will say “on cell no access to voicemail or messages.”. Then when I turn it on, it shows that it is on Wi-Fi.

Is it on a charger when this happens?

No it’s not

The next time you have the opportunity to do so, would you mind leaving the phone on the charger overnight, then check in the morning to see if it’s that same state you described?

My understanding is that the phone will not go into Doze Mode while on the charger, so if you confirm it’s not in that state in the morning when on a charger, but is in that state in the morning when off the charger, we’ve at least identified Doze Mode as the culprit.

I forgot to charge it last night, but I did this morning. It’s a fast charging phone, so in an hour or so I looked at it and it was at 100% and it did not say “on cell, etc”, so I guess you are right, Doze Mode must be the culprit. Sometimes during the day I will get that same message after the phone has been lying around unused for awhile. And I haven’t had a repeat of the original problem since I downloaded Macro/Droid.

2 Likes

Hi Southpaw - You seem to be very knowledgeable on all things Republic Wireless and phones. I’d like to ask you a question regarding the doze mode. Do you think it’s the Google phone which is at fault or is it Republic Wireless? I have been thinking of getting an iphone and switching to Consumer Cellular. Not for a few months though, since I prepaid my bill to Republic through June. Wondering if that would make a difference.

I can’t speak for @southpaw, however I have been heavily involved with many community members as we have worked with Republic Tech folks since Doze was first implemented by the Android OS (6.0)
Doze is part of the Android OS that helps reduce the battery drain on any device that uses the OS. over the various releases since 6.0 there have some changes, mainly in the timing of the shutdown of the WiFi.
From a users perspective it still fails, as the WiFi receivers/transmitters are shut off after a ‘period’ of inactivity. This essentially breaks our Internet connection to the Republic Servers, so when a call is routed to us, a probe is issued via cellular to wake up the WiFi. This was a function implemented by the Android (Google) developers to help mitigate the problem. There are some instances, that even with this helper (which Republic has implemented) we can still be connected to late for the call to reach us.

  • The only way for a user to fully disable Doze is to have the phone plugged into the power.
    • Google search will let you know that carriers other than Republic have experienced the effect of loss of Internet connection. It is just more noticeable for us as the Republic system is WiFi first.
  • The ‘fixes’ documented in Managing Doze Mode - (phone is on WiFi) calls via cell | calls go to voicemail | calls are missed were built and tested within the user community, and if any user still have a problem with the Doze fix implemented and provides feedback changes will be attempted by fellow users.

Hi @janicem.5rzxej,

@jben’s answer is very likely more thorough than mine would have been. If the problem has persisted despite implementing the Macrodroid workaround, I hope you’ll let the Community work through that with you.

I’ve created a bug ticket for the matter that is still pending technical review, but I hope we’ll be able to have our engineers take another look at what’s happening and see if they can develop any further workaround to prevent missed calls when the phone goes into this “Doze” mode.

2 Likes

Yes his reply was very thorough and explained very well what is happening so that even a simple person such as I can understand it. . As long as I keep the Macrodroid on my phone, that seems to prevent the missed calls. I had deactivated it to see whether or not the same thing would happen, and it did, so I will have to keep it. Thanks for your help. :laughing:

1 Like

Thank you so much for your detailed reply. You have explained very well why this happens. As long as I keep the MacroDroid app on my phone I do not miss calls. I had deactivated it to see what would happen, and sure enough, same thing again with the missed calls. So I will keep it and decide in the next few months whether I want to change to another carrier. I have had the Pixel phone for only a year, and it was not cheap, so I want to keep that for at least another year or more. :laughing:

Hi @janicem.5rzxej,
Thanks for the feedback on your double verification … feedback on suggested ‘fixes’ (good or bad) is very important to those of us who try to support our fellow Republic Wireless Members. It is how we all keep learning in this ever changing tech world we live in, and for some of us who have been at it for a long time it is one of the key ways we have fun.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.

Message an
Expert customer