Phone (Samsung J7) temporarily bricked itself when it ran out of data yesterday

Yesterday while I was away from home and in kind of a bad service area (showed one bar LTE), I got the notifications that I had used 90% and then 95% of my data, so I knew I was low. Shortly after, I completely lost the ability to send/receive texts, and do anything that would require data.

I suspected I ran out, but wasn’t sure. When I opened the Republic app, it said I had 102MB available, but was stuck updating. I tried (repeatedly) to buy an extra 1GB, but it wouldn’t process.

I didn’t try to make any calls, but that probably would have worked. The fact remains that I couldn’t really even use my phone, for what I needed/wanted to do at the time, until I got back home today and connected to wifi again.

Isn’t Anywhere supposed to work for sending/receiving texts (SMS) even if I’m “out” of data, but still has an available data connection? That’s always been my understanding of how the app worked.

Shouldn’t I have been able to buy additional data even though I was “out” as well? I swear I have done this a number of times, when it’s been necessary.

When I got back on the road and into better service areas (full bars LTE), I still couldn’t do either thing.

I’m home and on wifi now, and will probably go ahead and purchase the additional 1GB, so I didn’t think I needed to file a help ticket – but it just seemed to me that things weren’t working right at all last night and this morning. I also tried a phone reboot, and force-stopping the Republic and Anywhere apps.

(Related question, but perhaps should be a topic of its own: Is there no longer any way to send/receive texts without a data connection? Occasionally I be in areas that show “full” service, but no data connection. I know that Anywhere works on data, and suspect it needs it for texts. But on this phone I’ve tried Google Messages (or whatever it’s currently called) in the past, and it simply wouldn’t send SMS when I was in one of those areas. No matter what, I needed to show a data connection.)

Hi @anthonyd.osfjjs ,

Yes. That is how messaging is supposed to work, regardless of whether you’re using Anywhere or the Google Messages app for SMS and MMS.

Yes. This is also how it is intended to work.

Is there any chance you have a warning or limit set for your data usage in the Android settings menu?

If you turn off WiFi now at home, assuming you have LTE data showing on the phone but have not yet purchased an addiitional GB, are you able to send a text message?

This is correct. Messaging, except for on our legacy phones, does require data.

1 Like

No, I didn’t have a warning or limit turned on. I did, however, have “Data saver” turned on.

I’ve since turned it off.

I just tested, and no, still unable to send/receive texts with the wifi off.

I should’ve included this information in the original post:

Phone: Samsung Galaxy J7 SM-J727U
Android Version: 8.1.0
Republic App Version: 3.28.7.0
Anywhere App Version: 2.0.62

SIM card status page shows that I do have a signal, Service state indicates “In service,” not roaming, and Mobile network state is “Connected.”

Do you have RCS enabled?

I don’t know what RCS is or how to check, so I’m going to assume no.

Oh, you mentioned Anywhere, so that means you’re not using RCS. Sorry.

We do have a bug we are investigating where a few members have experienced what you’re describing - no text messages when data runs out.

So I’m curious to know whether you’d like (and have the conveniences of not being in a situation where text messages on cell are of the utmost importance for the moment) to help us try to troubleshoot the issue to find the cause, or if you’d prefer I just add some data to your line to get you going again?

1 Like

I still haven’t bought additional data, so I would be willing to troubleshoot the issue further.

3 Likes

Thanks @anthonyd.osfjjs ,

I’m going to open a ticket on your behalf and wlll continue the conversation with you there, because there are some screenshots that our technicians would like you to take, but they may contain personal information like phone numbers, so I don’t want you sharing those in Community.

If we do find a solution that would benefit Community - something people can do on their own without support intervention, then we can follow up here with that information later.

2 Likes

Just to follow up on this topic in case anyone else experiences text messages that won’t send when your plan does not have any purchased data (either you are on the Talk and Text plan, or you have used up all your purchased data):

  1. If you are sure your phone is connected to cellular data (3G, 4G, LTE or 5G icon is present)
  2. and if, for users of the Messages app by Google, you are sure RCS is disabled
  3. and if, when you try to send an SMS or MMS text message you get a “not sent, try again” message (or something similar) when away from WiFi

then
please open a Help Ticket, describe the issue, and ask that it be investigated as part of master ticket 2051010.

@anthonyd.osfjjs graciously provide some examples and log files that have given our engineers additional insight into the issue, but they have not yet determined the cause or a solution. We are able to make a change on the accounts of affected users so that messaging is restored.

We are also looking for confirmation as to whether inbound text messages reach the phone in the absence of WiFi when the phone is in this state.

1 Like

For what it’s worth, when this happened it seemed I wasn’t getting incoming texts either. I didn’t receive any incoming texts for the evening and morning that I had this behavior, and when I finally connected to wifi again I had several texts come in all at once,

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.

Message an
Expert customer