Phone says credit card info has beeh updated.. Cannot activate

What phone do you have? moto z4 play

What plan are you on? My choice +3b

Does your plan include data, or just talk & text? both


Issue Description

cannot activate phone…shows payment went through… shows0.0 balance… I have to get this working… internet is fine
shows payment processed and says wait for update… 6 hours now… I desperately need this phone active now!

Hi @smb3973!

Welcome to the forums!

Is this device a replacement device for an existing service line or are you opening a new account or adding a new line? Have you tried rebooting your phone? Also, what does the Republic app show if you open it up?

2 Likes

If the phone was completely deactivated, and not just suspended then you’ll have to reactivate it from the Republic App on the phone and open a ticket to request that your number be reestablished on the phone (assuming it has been no more than 30 days, this should be possible).

1 Like

Hi @smb3973,

Are you able to view the replies in your Help Ticket? Our Help Team has sent you a couple of replies.

1 Like

Hi @smb3973,

Please try again now.

1 Like

@smb3973 Are you still having this issue?

Yes. This issue described in the top post is resolved. The specific issue required a back-end update that I took care of before asking him to try again.

If activation stalls with the message, “Your credit card info has been updated and we’re processing your outstanding balance of 0.0” then a Help Ticket is required, as there’s data in the database that requires an update from staff.

Problem solved deleting and reentering Republic software

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer