Phone stays connected for 5 second then disconnects

#1

Info

Phone Brand : Motorola
Phone Model : Defy XT
Plan : Beta $19
Plan Data : data on cell Yes


Issue Description

I make a call, it disconnects after 5 seconds, then it automatically calls the person back. It does this with 75% of my contacts.

#2

Hi @basilp.7bnqjt,

On the DEFY XT, there’s no seamless handover. When a call cannot be maintained on Wi-Fi, the phone will disconnect and reconnect the call on cell.

Is this happening on a specific Wi-Fi network?

#3

Upon further testing it sometimes makes the recipient of the call automatically call me back. I’ve tested it with my son who also has the same phone and plan. I just tried calling him on his phone, 5 seconds later it automatically hangs up and then he automatically called me back (he didn’t call me back on his own). When my phone rang I looked at the screen and it showed 2 profile pics (one behind the other) as though my first call was now on hold while I answered his “automatic” call.
I also made a call to my grandmother who has a landline with Verizon and it hung up on her after 5 seconds, then my phone automatically called her back.
On both scenarios above I’ve tested this while on wifi and with wifi disconnected with the same result.

#4

The blog WiFi 1st - Maximize your WiFi/Router - Community Guide applies to all phones and provides a collection of information on WiFi that has been gathered over the life of Republic Wireless phones.

2 Likes
#5

You’re having the same result when making calls when the wifi is off?

2 Likes
#6

I’ve just tested it with my wifi off and the same thing happened. I again disconnected, my son “automatically” called and I looked at my screen, and see 2 profiles with the option to “swap” between the calls (both are my son on his only phone).
Now I just tested it with both of our phones disconnected from wifi and there was no disconnect. We recently installed a new router (TP Link AC 1350). It must be the router.

1 Like
#7

If the failure occurs on both WiFi and Cell (with the WiFi turned off) I would not suspect your WiFi.
There appears to be multiple AC1350’s from TP-Link, can you find a 3 digit number like C59 or something like that. (needed to see if I can find the manual and check if SIP-ALG is enabled, which could cause the problem if it was only failing on WiFi)

2 Likes
#8

Yes, it’s an Archer C59. When we are both off wifi, we no longer have issues. But if even just one of us are on wifi, the problem comes back.

#9

I haven’t found how to disable SIP ALG (Application Level Gateway) but for some models of the TP-Link it appears that Enabled is the default.
You may want to contact their Tech Support and see if it is enabled by default, and if so enlist their help in disabling it. Any VoIP will not function properly with the majority of routers implementation of SIP ALG.

1 Like
#10

Thank you for your help. I’ve just done as you suggested and contacted TP-Link Tech Support.

2 Likes
#11

If they provide you a method to disable SIP ALG, please post back the info

#12

Here’s the unfortunate response I received from tech support:
“Sorry that we can’t solve the problem in a short time. C59 is not designed for VoIP phone and we has enable the SIP ALG for default. Right now we don’t have any tool to disable this feature. If it is a new router, my suggestion it to contact the shop and ask for a return/replace another model.
I will email you if I get any update from firmware engineer.”

#13

Hopefully you can find one to replace it with. SIP ALG rarely works with any VoIP device, including the hardware implementations that many vendors offer for home phone replacement. The majority of devices available have the ability to Disable the function, but if you post back what you might consider buying the community will probably be able to verify for you.

#14

Sorry for the late bump, but can anyone give me router recommendations for use with Republic Wireless phones? Preferably one that is comparable to the above mentioned Archer C59.

#15

Here is a link to another discussion … user @fords.jmk6yx has recommended an ASUS in approx the same category
See: Spectrum-Charter using Sagemcom F@ST 5260 router prevents users from making WiFi calls

1 Like
#16

The router he recommends seems to be the Asus RT-ARCH13. My only issue with it is this review:

“I have been very happy with the range and speed of this router, but less than satisfied with VOIP calls through the router. I looked for a VOIP setting to priorities VOIP in the QOS settings, but there is no setting to priorities VOIP that I could find. I am trying to make use Republic Wireless VOIP WIFI calls”.

Do you think this will be an issue?

#17

The manual contains a section on Traffic Manager, unfortunatly without the router in hand it would not be possible for me to provide additional help.
Two things that I have put an inquiry into ASUS about is

  • SIP ALG (needs to be disabled if it is present)
  • WMM (WiFi Multi-Media) They mention it in the Spec, but don’t say if enabled,
    WMM maintains the priority of audio, video and voice, over other applications which are less time critical. Using QoS (Quality of Service) Wi-Fi Multi-Media (WMM) ensures that the applications that require better throughput and performance,are inserted in queues with higher priority … this is really the only QoS that works with the phones

I will update when I get further information

1 Like
#18

I just noticed that the TP Link AC 1350 mentioned earlier in this thread has the option to disable SIP ALG (contrary to what their customer service stated). I disabled it but the Republic Wireless phone is still giving me the same issues as in the first post. Here are the options it has in the ALG section of the router, would any others help?

Enable FTP ALG
Enable TFTP ALG
Enable H323 ALG
Enable RTSP ALG
Enable SIP ALG (I have it off but still have the issues mentioned)
Enable PTTP Passthrough
Enable L2TP Passthrough
Enable IPSec Passthrough

#19

I am having this exact same issue. But if I am at work, I don’t have control over the (numerous) wifi routers - how do I force my phone to not use wifi for phone calls?

I’ve only been on RW for a few weeks but if I can’t control the wifi source, then I can’t make/receive calls. This is certainly a deal breaker for me, and I’m already thinking I need to go back to Ting.

My phone is a Moto G5 Plus running Nougat.

#20

If you don’t know the IT folks and want to keep a low work profile when at work or other area with with an unreliable WiFi you can turn off/disable WiFi in the phone Settings. As long as you have a decent cell signal you should be able to make/receive your calls.
:flight_departure:

Message an
Expert customer