Phone stays on cell when I'm on wifi


What phone do you have? Moto g4

What plan are you on? choice

Does your plan include data, or just talk & text? 1 gig data

Issue Description

my phone switches to cell when I'm on Wi-Fi.



Hi @franh,

Could you tell us a little more about the situation, how you’re noticing, and what the impact is? Just switching to cell when you’re on Wi-Fi is by design in some cases. What actual problem are we trying to help you solve?


It uses data. I’m at home. I have wifi. I want to use it.


Are you able to connect the phone to your Wi-Fi network so that the Republic Wireless arc in the top left corner becomes solid?


Yes. But my phone disables the wifi. I have to check it often. It will disable wifi and connect to cell.

  • When you say it ‘disables’ WiFi, does the Android Setting for Wi-Fi actually change the slide from the right (Green/Blue) to left (Grey)?
  • Do a 1 finger swipe down from the top and what does the Republic Notification say? (include verbiage and color of the arc)


Arc is clear. I check settings and wifi is disabled. I change it and go back to wifi. Later i look at phone and wifi is diabled again.


I have not seen (nor remember hearing) of a condition that ‘turns off the WiFi’

  • I would suggest you capture a couple of screenshots to include with Opening a Ticket
  1. A one finger swipe down and display the Republic Notification
  2. The Wi-Fi Screen showing the switch

ETA: Per @drm186’s suggestion: Try running in Safe Mode to see if the problem is caused by a 3rd party app, if the problem persist then my suggestion probably makes sense


have you tried running in safe mode to see the behavior the same?


Hi @franh,

It sounds like perhaps a third-party app is disabling Wi-Fi. Do you have any apps on the phone that claim to boost performance or improve battery life? Any anti-virus apps or “cleaner” apps on the phone?


yes. I’ll try to check each one and see if it makes the difference.


how do i turn on safe mode on my phone



  1. Press and hold the Power button for 2-3 seconds until the Power off pop-up message appears
  2. Press and hold the on-screen Power off pop-up message until you see Reboot to safe mode
  • Note: If you are running Android 8.0 Oreo or higher on a Nexus, Google, or Motorola phone, this will automatically reboot the phone into Safe Mode without showing the pop-up
  1. Tap OK when the Reboot to safe mode pop-up appears
  2. Your phone will reboot and Safe Mode will appear in the bottom-left corner
  3. Try using or testing the issue you were experiencing while in Safe Mode

Additional Notes

Safe mode disables third-party applications, making this a good step to take to help ensure an app on your phone isn’t causing any issues.

When you are finished operating your phone in safe mode, simply restart your phone to exit safe mode.

If you were asked in a help ticket to place your phone in safe mode, respond to the ticket letting Republic Help know if the issue persisted in safe mode.



Hi @franh,

Have you been able to determine which third-party app might be disabling Wi-Fi?



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.