Phone uses poor cell signal over strong home wifi signal

wifi

#1

When calling from home, we sometimes get poor (unacceptable) quality. We can see the phone is using cell signal when this happens, although the WIFI signal is strong. Cell signal is poor at our location.

Wifi analizer shows -50dB on 2.4GHz channel 6. There are no competing signals, as we live in remote area.
5G is -70dB, but we removed 5G password from phone in attempt to solve this problem

Comcast Cable
Archer C7 v2 00000000
3.15.2 Build 170525 Rel.37571n

We have WMM enabled. VOIP test showed good connection over wired computer. Ping 19ms, Jitter 2ms, latency 19ms. Upload 63 Download 6. These are with wired computer. From phone we are getting 49M down 5.5M up


#2

try
open RW app on the phone
right upper tap gear
advanced settings
down in the manage handover
make sure allow manual handover is checked
make sure handover to wifi when appropriate is checked
and where enable handover on networks
tap and make sure it shows home wifi networks
after all that
at the bottom
tap reset degraded service checks

let us know


#3

Thanks for providing all the necessary information … it really helps cut down on all the questions :slight_smile:

  • I see that there is a newer release of firmware, and the release notes indicate that some improvement was made to improve 2.4 performance
    It was new as of Jan 17, 2018 https://www.tp-link.com/us/download/Archer-C7_V2.html#Firmware
  • Which phone are you experiencing the problem with?
  • Additionally, the information provided by @TheDoctor does a great job of simplifying the settings … you may want to ‘disable’ the Handover on your connected network as a test (with it enabled the phone will handover to Cell whenever it feels the WiFi signal is not able to sustain a quality connection)
    • RW App/Settings/Advanced Settings/Enable handover on networks then Deselect your home WiFi Network

#4

This phone is Motorola G Play.


#5

Thanks, then the RW settings suggested by me for testing should work (I have a Moto X Pure)
Edited to correct my name error


#6

Oops. We have Moto X play instead of G. We just did a test call and it worked fine, so it will be hard to know when problem is fixed. I’m going to try router firmware update.


#7

there have never been Moto X Play for the US Market (their was one for international markets in 2015)
the Moto X line has included the Legacy phones Moto X and Moto X 2014 (aka Moto X2) and the 3.0 Phones Moto X Pure (aka Moto X3) and the Moto X4
the Moto G line has had the Lrgacy phones Moto G and Moto G 3rd (the 2nd Moto G did not work on Republic) and the 3.0 phones of the Moto G4, Moto G4 Play, Moto G4 Plus, Moto G5 Plus, and the Moto G5S Plus.
the Moto E line had the Legacy phones of the Moto E, and Moto E 2nd (the 3rd Gen did not work on Republic) and the 3.0 phones of the Moto E4, and Moto E4 Plus
the 3.0 also have the Moto Z line - Moto Z, Moto Z Play and Moto Z2 Play


#8

Sorry Moto Z Play. I checked all the RW settings. The only thing I did was last step “reset degraded service checks”. Everything else was already set.


#9

oops. some of those options were not checked on my wife’s phone. (We have identical phones) Perhaps that and/or updating router will help. Thanks for your assistance.


#10

I made suggested changes to my wife’s phone and also updated firmware in my router. Yesterday, the phone went to cell signal during a call and as before, got poor call quality.


#11

Ok, thanks … this still sounds like the normal results of a WiFi signal that is not up to snuff possibly combined with a fringe area cell signal.
You may want to check out the the Quick Checks section of the WiFi 1st - Maximize your WiFi/Router - Community Guide


#12

I’ve read that document several times, but I will read it again.


#13

Hi @michaelm.m0csx7,

I see some conflicting advice here in what you’ve been told, so just to back up and make sure we’re all on the same page…

On your wife’s phone, please open the RW app and follow these steps:
Tap the gear :gear: at top right.
Tap Advanced Settings
Tap Enable handover on networks
Scroll through the list and find your home network’s name. Uncheck that box.

Now, understand, when the phone is handing over, it’s because our system determines that something about the Wi-Fi network is not providing adequate call quality. But if you are certain that cellular coverage in your area is not good, it might be best to disable the handover using these steps.

How are you determining that the call moves to cell?

What is your Wi-Fi environment like? Are you in an apartment building or compact neighborhood where other Wi-Fi networks may be causing interference? (See the *Router Channel section of @jben’s guide.)


#14

Thanks. We live in a rural area with no interfering wifi. Since we had that trouble I got a new wifi router and relocated it and have not had problems since. The location provides stronger signal than before and the new router is a stronger signal when in same location as old router.


#15

We got a new router and a new phone and are still randomly having call problems, even in the same room with the router. I did a test calling our home ooma phone. I walked all over the house and could not reproduce a problem, i switched back and forth to cell, but tonight, my wife started a call outdoors and lost call quality when walking inside, where there is poor cell but strong wifi. I did a ping test with my phone and its showing 65 to 100ms in us. What ping speed is needed?


#16

Anything less than 250 ms is considered acceptable. It can take a bit of time for a call to transfer from cell to Wi-Fi if my memory serves me correctly (you wouldn’t want to drive by a remembered Wi-Fi hotspot and have the call transfer to Wi-Fi only to drive out of range seconds later).


#17

I guess my “problem” is similar. I have a Moto G4 and I live in a rural area with pathetic cell coverage (like < -120 dbm and frequent “no connection”). So WiFi is my primary mode. I have excellent WiFi coverage with 3 access points in my home. Frequently (especially for incoming calls) my phone comes up in cell mode for voice (but WiFi for data) despite a crappy cell signal and a very good WiFi signal. I don’t know if this is a Republic or Android thing, but it is certainly annoying. Any clues?


#18

As you have good/excellent WFi coverage, I would suggest this may be occuring when the phone has been at rest for some period of time (entering Doze Mode). This is discussed thoroughly in Are your calls coming in on Cell or going to voicemail when your phone is sleeping? which was championed by @billg and a method is provided that prevents the problem for many of us


#19

jben, Thanks. That’s some thread! This (no WiFi while in sleep) is one of my minor issues. But also I have instances (that eventually self correct) where I see I have voice on (crappy) cell but data on good WiFi. This is not a show-stopper for me, but it is annoying.


#20

It still sounds a bit like you ‘good WiFi’ could be the problem … perhaps a neighbors router is on the same channel as yours … I try to address this in Router Tweaks in Quick Start item 2