Phone will not update the republic app

My phone shows the version 3.24.2.1 of the republic app is ready for update, not every time I try to update it says I need to be signed into my Google account. I am signed in and even when I attempt to update it from my republic app it can’t do it. Any ideas?

the Republic app updates via the Google Play store :playstore:
to try and force the update open the google play store app :playstore:
search for Republic Wireless app :rw_3:
update should be an option there

2 Likes

Tried that also. No matter how I try to update it the image with “authentication is required. You need to sign into your Google account” shows up. I’m signed into my Google acct. It doesn’t make sense.

Try locating the Republic Wireless app in the Playstore under
My apps and games
And then try tapping Update from over there

If that doesn’t work…try clearing the cache for the Play Store app
and then try again.

1 Like

Hi there, I’ve tried all these things and so far no luck at updating. Just keeps going back to the same screen that I need authentication/need to sign in (I’m already signed in!)

Can you post a screenshot of the error message you are receiving? This is a public forum so delete/mask out any personal info before posting the screenshot.

1 Like

Can you post a screenshot of the error message you are receiving? This is a public forum so delete/mask out any personal info before posting the screenshot.


Visit Topic or reply to this email to post a public response in our Community.

To unsubscribe from these emails, click here.

If you go to Settings – Accounts – Google do you see your Google account there? When you click it, do you get an error message or does it show sync errors?

1 Like

Try uninstalling/reinstalling to the updates to the Google Play Store app

1 Like

I cleared the cache, if I try to clear the data it would erase everything. Not sure how I can uninstall and reinstall the play store app. Anything else I need updating works, I updated my republic relay app just fine.

@susieb, you are getting that error because you either don’t have a Google account on your phone or your Google account password changed. Please try the steps that @louisdi suggested and let us know what you get.

Here’s an alternative way of doing this.

From your laptop/computer, login to

search for “republic wireless”
Click on Installed (you might have to enter your password again)
There it will give you the opportunity to install it on your phone.

This should update the app on your phone.

Ultimately… there is a broken link somewhere between your phone’s Google Play Store app and the Republic Wireless app…maybe the update will kick it out of it…or maybe a future update to Google Play Store will do the trick…but for now the above workaround should do the trick.

I guess the bigger question is are you having any issues with your phone or do you just want to make sure that your RW app is up to date?

2 Likes

To uninstall updates to the Play Store app
Go to
Settings -> Apps -> Google Play Store (make sure you select Store and not Services)
On the top right three vertical dots -> Uninstall Updates

Great! This step via my laptop worked! Thank you so much for all the help! I had been having troubles with my phone and answering incoming calls. I’m hopeful with this update the problem with disappear.
Thank you again!!

1 Like

You’re welcome! Let us know if that helps with your issues for incoming calls.
If not, I would recommend starting a new thread outlining the steps you have already taken
so that the community can keep the suggestions focussed on new things to try…or if it makes
sense to submit a ticket and get individualized help.

Message an
Expert customer