Phone won't ring when sleeping


#1

I recently activated my Moto Z Play that I bought from Republic and my home doesn’t get cellular service so I rely on wi-fi only when at home.

When my phone is asleep it won’t accept calls. Calls to that phone go directly to voicemail. No record of the attempted call shows up. When the phone is awake it works perfectly fine.

I have double-checked the settings and everything is set up properly, including the setting to tell it to stay connected to wi-fi when it goes to sleep. Also, I am not running any power-saving applications. The phone has the same apps and basic settings as my old Moto X which didn’t have this issue.

Is there something that I’m missing? It is very important that my phone works on wi-fi only.


#2

I had this problem. It was a setting in my ASUS router. What kind of router do you have?


#3

Thank you for the response. My router is Netgear. I wasn’t thinking the router could be the problem since my other four Republic phones are on the same router and they don’t have the issue. But I’m open to the idea that the router could be causing the issue with this new phone since the other phones are on the older Sprint plans and the new phone is on the newer T-mobile service that doesn’t have cellular service at my house.

So what router setting did you have to change?


#4

@williams ,

You can check to see if **Keep Wi-Fi- on during sleep **is set to always, phone Settings, WiFi, Settings(vertical dots), Advanced.


#5

It was a setting called WMM-APSD. This setting is supposed to save energy by buffering packets sent to a sleeping device. When a call comes in RW looks for you on WiFi. They send packets and the phone responds with packets. With WMM-APSD enabled the phone didn’t receive those packets so, naturally, it didn’t send replies. RW would then forward the call to cell but with my lousy cell service the carrier couldn’t find me either so the call would go to voice mail.

Yes, it is possible the router is causing your problem and not just for your phone. Sprint might be able to find their phones but T-Mobile can’t. If this is the case they can look at their phones when a call comes in to see if it is on cell or WiFi. If it is on cell then RW couldn’t find them on WiFi.


Spectrum-Charter using Sagemcom F@ST 5260 router prevents users from making WiFi calls
#6

Not expected to ‘fix’ but may gather additional information

  1. Do you see the effect of Marshmallow Doze failure that allows the RW Status line to change from SWA (Solid White Arc) to OWA (Open White Arc) … usually after an hour or so
  • When you wake the phone it will be OWA for a few secs then change to SWA and the time stamp on the RW Notification will be same as the current phone time
  1. Does it fail if you have it attached to your charger? (a certain Doze function is bypassed while charging)
  2. Have you experienced a failure while the phone is in Airplane mode with WiFi enabled?

#7

@williamo.vkbg0s

Reading is a vastly underrated skill.


#8

I don’t see an Open White Arc. When I wake the phone it shows a triangle with an exclamation mark in the status bar the turns to a solid arc within a couple seconds. I haven’t tried it with the phone plugged in. This phone charges quickly and has a very long battery life so it hasn’t been on the charger long enough to go to sleep.

I disabled WMM on my router as suggested by billg and I’m hoping for the best. In the meantime I’ll look a little more into Marshmallow Doze to see if that could be contributing to the issue. The one-hour time frame seems consistent with the amount of time that passes before the phone stops taking calls.


#9

The WMM-APSD that @billg disabled …** is not the basic QoS WMM** that provides prioritization of the Voice signals on the airways (and is normally endabled). APSD is for power management (see https://routerguide.net/wmm-apsd-on-or-off/ that Bill previously provided)

  • Here is a link to a discussion on SNB (Small Network Builder) that indicates other have problems with it on Androids

#10

That triangle you are seeing indicates the phone is disconnection from WiFi while sleeping. Without cell service this explains why your phone isn’t ringing.


#11

Yes. I’m still hoping the WMM tweak works. The problem is that it takes an hour for the phone to enter deep sleep so it takes a long time to test.

I also went into the battery optimizer and de-optimized “Droid Over WiFi” as well as “Android OS”. Hoping for the best.


#12

@williams,

What Netgear router are you using? …to repeat WMM-APSD is to be disabled not WMM


#13

The WMM-APSD fix won’t fix the problem you are experiencing. In that case the phone maintains its connection to WiFi but the interrogation packets don’t get to it. In you case the WiFi connection is dropping. Your problem might be tied to the doze problem @jben mentioned. I don’t know if there is a fix for that. Ben, do you?


#14

Well, it looks like some progress was made. I let the phone go into snooze then I called it and it went directly to voicemail. I called it again and it rang, plus it showed the missed call.

The two things I did were: 1. De-optimized the “Droid over WiFi” and “Android OS” services, and 2. Turned off WMM-APSD on the router. I know ya’ll advised against this but in the documentation I found it looks like Netgear acknowledges that the QoS WMM includes power-saving but there was no option to disable the power saving part. I figured it was worth a try.

I’ll do some further testing to see if I can narrow down which of these things helped.


#15

Netgear appears to still call it by the Power Save handle … it is a subset of WMM so disabling WMM should kill it but you may loose some thruput on the router without WMM QoS enabled

You should be able to just disable Power Save … I doubt that this is the router you have, but it shows the Powersave


#16

Thanks. It looks like the one success I had with disabling WMM was a fluke. I tried several times after that and it didn’t ring. So I guess we can rule out WMM on my Netgear router as the cause. My router also does not have the power save feature that you showed in the screen shot.

I rebooted in safe mode earlier this morning. Now I am just waiting for the phone to go into snooze so I can see if I still have the issue in safe mode.


#17

@williams

You found the cause for your calls going to voicemail when you discovered this:

“I don’t see an Open White Arc. When I wake the phone it shows a triangle with an exclamation mark in the status bar the turns to a solid arc within a couple seconds.”

This means your phone is disconnecting from WiFi when sleeping. RW can’t find your phone on WiFi so they are forwarding your calls to cell. T-Mobile can’t find your phone on cell so the calls are going to voice mail.

No router setting is involved in your phone losing its connection to WiFi. Not being familiar with your particular model, and knowing you have already told the phone to not turn WiFi off when sleeping, it’s hard for me to suggest other phone settings your model might have. Be sure to make it clear to RW support that you are seeing this triangle when the phone wakes up. If they have a solution that will keep it connected to WiFi please let us know what it is.

Bill


#18

@williams,

If you could post back which Netgear router are you using and the current level of firmware, I would like to do a bit of digging


#19

Thanks. It’s a Netgear DGN2200v3. Firmware version is V1.1.00.23_1.00.23NA. I also have a couple Netgear routers that I flashed with DDWRT but there is no setting for WMM power saving. The only thing left of I can think to try is to get an ASUS router, disable WMM power savings, and set up a subnet for my phone to connect to to see if it holds connection.

Latest info is that I did a factory reset as per Republic Wireless Support’s instructions. However, the problem persists. They are going to call this evening for a debug session. Hopefully they can gather the logs and figure something out but I’m starting to think that they aren’t going to be able to figure it out.

Since the factory reset didn’t work I don’t think the issue is specific to my particular phone. This is starting to feel like there is something either in the Android Marshmallow software or in the Republic app that is allowing the WiFi disconnect. Perhaps they didn’t test this phone model for WiFi only in a snooze situation. Most people wouldn’t notice the issue anyway since they can fall back on cellular signal.

I tried to fashion a workaround using Google Hangout to receive calls but it seems I can’t do that unless I verify the phone number with Google Voice. Although I can do that with my older Sprint-based RW phone, it won’t take the verification code for my new T-Mobile-based phone. The only other workaround I can think to try is to leave the phone plugged into the charger all the time and see if that works. But I hesitate to do that for concern of what it would do to the battery, especially since the battery can’t be replaced by the consumer.

Does anybody have any other ideas to work around this?


#20

I asked the community for some volunteer testing but nobody responded.

Is your phone losing its WiFi connection while sleeping?