Phone won't ring when sleeping


#21

billg, are you affiliated or employed by Republic? I would be a valuable tester for Republic since I make my living in IT plus I seem to run into way more than my share of issues with the RW phones. I was the one who discovered that the Huawei Ascend did not have a gyroscope and got RW to change the website info on the phone accordingly. I also found the issue on the Ascends where they can’t call or receive calls in a WiFi-only environment. I needed the phones to work right away, plus the issue felt like it would require an update of the RW app to fix, so rather than wait to debug the issue I returned the 2 Huawei Ascend phones and bought the Moto Z Play for my wife, expecting it to work properly. I’m still making do with my old first-gen Moto X which has no connectivity issues.

While the old phones appear to have been rigorously tested, there appears to be a gap in the WiFi-only testing of the newer phones. So does RW provide the phones for testing? I don’t mind smoke-testing phones…


#22

No, I have no affiliation with RW but I have made a few friends there. About a month ago I was treated to a tour of their facilities and had a couple of dinners with some of their staff. They are a nice, sharp bunch of young men and women.

I’m a retired EE and keep myself occupied trying to solve technical problems. Spontaneous disconnects have been one of my favorite challenges. In that thread where I asked people to perform a simple test Sean mentioned the hollow arc upon awakening not being significant but your phone awoke to a triangle and that is an entirely different matter.


#23
  • I see where Netgear published a note that included reference to Power Save (the name they use for WMM-APSD)

Power Save:

The Wi-Fi Alliance has added Power Save Certification to the WMM specification. Power Save uses mechanisms from 802.11e and legacy 802.11,to save power (for battery powered equipment) and fine-tune power consumption.

This feature of WMM to save power might cause disconnects under certain conditions. (my bolding)


#24

Yeah - I saw the firmware update was available but didn’t see any reference to power saving so I didn’t install it. Since I do IT support and development for a living I know better than to install firmware updates unless needed.

But I think I came up with a good workaround. I downloaded an app called WiFi Keep Alive from the play store and that seems to have done the trick. This app forces the phone to keep the WiFi connection even when the phone goes to sleep, even with WMM enabled. I ran a test first thing this morning and the phone rang as it should. I’ll test it again a few more times when I have time to let the phone snooze to confirm it.

I’ll report back later after some validation testing.


#25

I also found the issue on the Ascends where they can’t call or receive calls in a WiFi-only environment. I needed the phones to work right away, plus the issue felt like it would require an update of the RW app to fix, so rather than wait to debug the issue I returned the 2 Huawei Ascend phones…
I realize it’s off-topic to the issue you’re currently trying to solve, however, I’m interested in your experience with the Ascend. You’re not alone in reporting issues making calls on the Ascend in a WiFi only environment. I’m able to easily duplicate that issue by engaging Airplane mode then toggling WiFi back on and have reported this to Republic support. I’m told the issue making calls in a WiFi only environment has been traced to an issue with Huawei’s EMUI Dialer and that the fix is not an update to Republic’s 3.0 app but rather a forthcoming system build update from Huawei. This makes sense as, in the interim, I’m able to work around the issue by using an alternative Dialer.

For what it’s worth, receiving calls on my Ascend in a WiFi only environment has not been an issue for me, nor have I seen widespread reports of this in Community.


#26

Yeah - you must have been the expert that SouthPaw was talking about who was using a 3rd-party dialer to work around the Huawei issue. Thanks for the update on the root cause. I discovered the Airplane mode with Wi-Fi on capability last night but the Huawei phones are long gone. However, my scenario was a bit different in that I wasn’t in Airplane mode and I experienced the issues.

When I tested that phone it definitely would not make a call with the built-in dialer but I was able to call out using Google Hangouts dialer. As I recall I also tried to call the Huawei from my other phone a couple times and it did not pick up. I didn’t re-run the test enough times to validate/confirm the issue at that point because I had made up my mind that I was going to send the phones back. So I can’t be completely certain that my Huawei was unable to receive WiFi calls. I would need to re-obtain and retest that phone in my WiFi-only scenario to really be able to tell for sure one way or the other.

The good news is that soon I should have a much better idea of whether the WiFi Keep Alive workaround truly resolved the issue. Preliminary tests were encouraging.


#27

Well, the WiFi Keep Alive app didn’t work this morning. The phone wouldn’t take calls. I woke it up and there was the triangle with the exclamation mark again for a couple seconds until it turned to a solid white arc. So back to trying to figure out the issue…


#28

I’ve had very similar issues with my Moto E (1st gen), running KitKat. I recently upgraded to lollipop and found that my phone would now lose its WiFi connection almost any time it went to sleep, even while at home, where it is never far from our router. I wonder if this is similar to what was happening with KitKat; maybe it just happens much more frequently with lollipop. In any event, some of the postings - I apologize, but I can’t provide a pointer to the same - suggest that Bluetooth may be involved, and that the problem may be ameliorated by either turning Bluetooth off or deleting some of the saved Bluetooth device pairings. I do use Bluetooth fairly extensively and did have a lot of stored device pairings. After deleting those that I haven’t used recently, it does seem as though my phone’s behavior has improved. I don’t know if the problem is completely gone, but I’ve now had four straight days without noticing my phone dropping its WiFi connection while at home.


#29

Has anyone found a solution to this? I am on call many nights, I may wake up and see a voicemail, but I don’t have any missed calls. I know that at least two of the times the call never reached my phone, I did not have it on the charger. After reading this thread, I am wondering if it will help. I have a Moto G5 Plus and have great cell coverage in my area. Is the WiFi just disconnecting and just eventually making the call timeout and go to voicemail before my phone is notified? I also recall in the past where the phone would do half a ring and then it would go to voicemail. I will research some more, but just wondering if anyone found a solution.


#30

I have never seen the 'sleeping WiFi problem occur while my Moto X Pure was on the charger, and have tested multiple times.

  • afik, at this point the only ‘fix’ is use the suggested MacroDroid helper for daytime and leave on charger at night

#31

I have a moto G4. I have the same issue. People try to call and they get a message the (can’t remember the exact message) is not available. So my caller will text me to call them.
I also get “Restricted access changed. Voice service is blocked”.
Didn’t know if they were connected.
I’ve went through every setting but cannot find the fix.


#32

Sounds like they are getting your un-edited (default) voicemail. You should re-record it so they know they reached the right place. How to Record Your Voicemail Greeting or Name in the Republic Wireless App – Republic Help


#33

“Restricted access changed. Voice service is blocked” generally indicates poor cellular reception (unsuitable for voice calls). You have stated before that you have poor cellular coverage. As far as the phone not ringing and going to voicemail while on Wi-Fi, you might want to review:


#34

The message a caller hears is not a voicemail message but a message like you get when you do not have any service and someone is trying to call you.


#35

Can you have them tell us the message that may help with what the issue is.


#36

My husband told me this is what he heard when trying to call me, “the republic wireless member you are trying to reach is unavailable”.


#37

Does this only occur if your phone has been idle for greater than an hour?


#38

Yes, usually in the morning before I pick up my phone. I keep it on a charger all night.


#39

It I think it happens whenever my phone isn’t used for awhile.


#40

@cbwahlstrom pointed you to a discussion above that may possibly provide you a solution