Phone won't send or accept texts when out of data



I was wondering if anyone can help. My husband and I are on the $20 plan and his data is gone for the month. (We don’t need more data at this point.) BUT his phone won’t text unless he is on wi-fi now and it shows the ! next to the signal strength. Is there a setting to change? I’ve already read the forums and saw a RW employee post that the plans should have talk/text on wifi or cell - no matter what. Thanks for any help.


Did he turn off data when he ran out? (People often do this because they’re worried about overages, which don’t exist with Republic). If not, this is likely coincidental and an issue we can resolve. Can you tell us what model phone your husband has?


He has a Nexus 6 and cellular data is on.


Please try these steps:

  1. Reboot the phone in an area that has a strong cell signal. (Some people have simply needed to step outside and reboot.) If this fixes it, stop.

  2. Please ensure the data is turned on in Android Settings. Settings > Data Usage > Cellular Data (some phones may say Mobile Data). If this fixes it, stop.

  3. This one is more complicated. This step will clear out any saved connections for Wi-Fi and Bluetooth that you may have already made. We’re going to reset the network settings.
    Go to Settings > Backup and Reset > Network settings reset
    Read the warning, tap “Reset settings.” You will be warned a second time. Tap “Reset settings” to confirm. The process will usually take 5-10 seconds and the cellular signal bars icon will go away for a moment. Once the cell signal bars icon returns, you should reboot the phone.


OK - working on that. We had a similar problem in the past and dropped RW. The phone quit making calls after it stopped being able to text…


OK - #3 seemed to work and we got a text to go through. (Nothing changed after 1 and 2 - just so you have that data point.) Thanks for your help!


You’re quite welcome!


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.