Pie Update Problem - Moto G6

I tried to install the Pie update that was pushed down. After 2 hours, it still did not finish (supposed to take 10 minutes) and so I tried to turn off/restart. When it did turn on, I lost everything and it keeps sending me to the republic log in but then says “an unexpected error occurred” and I can’t log in nor do anything on the phone. Please help.

This may not be the problem you are seeing, but I have experienced a problem updating the OS in the past and the ‘fix’ was to move to a place in the house with a better WiFi connection

1 Like

Hi @virginiat.to1txf,

I noticed you opened a ticket and were able to restore functionality to your phone with a factory reset. Please let us know how it goes if you try the update again.

We had success on both of our G6’s following the steps listed in this post –

Thought it might be worth mentioning to see if it helps on the next update attempt.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.

Message an
Expert customer