Pixel 2: Only does "calls over cell" when connected to wifi

incomplete

#1

I barely get regular cell service at my house so that’s why I got Republic. Haven’t had issues before. But now it only says " calls over cell" when connected to WiFi. Which means no calls because only wifi works at my place.

Tried reinstalling republic app. Restarting phone. Haven’t tried restarting wifi yet.

Any ideas?


#2

Typically, I would recommend unplugging your router for 60 seconds and plugging it back in for this issue to start. If no improvement. Who is your internet service provider?


#3

Just tried that. Unfortunately, it doesn’t fix the problem.

I did notice that for about 10 minutes earlier tonight it connected to WiFi, how it should, saying “connected to Wifi” and all calls/texts then worked through it.

My carrier is True North Broadband running 100/100 speeds. It’s always been flawless.

Thanks for the help!


#4

I recommend you enter *#*#8647#*#* into the dialer to resolve this issue. This link will give you video directions on the process. https://community.republicwireless.com/videos/1040


#5

Okay I tried that. Still same problem. Any other ideas?
Thanks again for helping!


#6

are you using a VPN app, of some sort
try safe mode


#7

Hi @elliotd.ncvb96,

Generally, what you are experiencing is the result of the Republic app’s opinion that your WiFi network won’t support a quality call, so it wants to route the call over cellular. Network speed is the least important metric regarding whether a WiFi network will support a quality call. Far more important are latency, jitter and packet loss. Please see here for more on optimizing one’s WiFi network: Router Tweaks - Keep WiFi 1st - a Community Guide.

I understand in your circumstances, that’s not the best choice nor is the Republic app’s opinion of a particular WiFi network’s ability to handle calling infallible. You can test that by engaging Airplane mode, then manually reenabling WiFi. Doing so turns off your phone’s cellular radios. Does this result in the ability to make WiFi calls and are they OK?


#8

At what point did you start having issues? Does it correlate to any Android updates, Republic Wireless app updates, other significant (or seemingly insignificant) changes?


#9

I didn’t notice any big updates or anything. It happened two days ago.


#10

I’ve tried the airplane mode trick and it still doesn’t work over WiFi when this problem is happening.
I’m also noticing it not connecting as readily (same problem) when I’m on other networks as well. So I have a hunch it’s my phone. I’ll goes through those steps with my router and see if it helps. I’ve never had this issue before, but maybe due to having better service (any service) at my place this time of year, it’s getting confused. I’ll keep prodding. Thanks all for the help.


#11

OK, my mom was having trouble with that, and when I went to figure it out, her phone had set to have roaming turned off. I clicked it “on” because phone said it would not affect her plan or something…and that fixed the problem immediately.


#12

Hi @elliotd.ncvb96,

It has been a few days since we’ve heard from you. Have you been able to get the phone to call over Wi-Fi? Does the issue persist on other Wi-Fi networks?


#14

Another idea… RW uses a couple of TCP/IP ports for WIFi calls, which aren’t the standard ones for Voice-over-internet (VOIP). IF those are blocked by your router, WIFi calling won’t work.


#15

It has been working as of late. Better than before. I still wonder if it will happen again. I didn’t do anything that fixed it as far as I know. It just started working.
I doubt that it was my wifi blocking those tcp/ip ports due to the phone sometimes working properly.


#16

Thanks for the update @elliotd.ncvb96,

Intermittent issues are some of the hardest to solve. It could be that another app was interfering. We’ve seen some apps that use Bluetooth cause some Wi-Fi connectivity issues in the past. If you see it happening again, see if you have Bluetooth turned on. It could be an app that was updated, starting causing trouble, and then was updated again.

Another thing you might look into if you experience the issue again is whether any other Wi-Fi networks are crowding your airspace. @jben has instructions to help you check on that in the “router channel selection” section of his Router Tweaks - Keep WiFi 1st - a Community Guide topic, which Roland pointed to earlier.

We’ll leave this topic open for another week to see if you have any recurrences.


#17

#18

@elliotd.ncvb96 Has the issue come back in the last five days?


#19