Pixel 4a google assistant

What phone do you have? pixel 4a

What plan are you on? my choice

Does your plan include data, or just talk & text? all


Issue Description

Just got pixel 4a, When I try to use google assistant I get the screen response of “Hi, How can I help?” but regardless of the question I ask the message comes up “Can’r reach google at the moment.” I still use my Moto G5 plus for a few things on wifi and the assistant of there will answer. I redid the voice match, restarted the phone and tried to do some things I found online, but the instructions didn’t match what I have on my phone. Any ideas?

Basic question here. You can web browse and otherwise access the internet on the phone, correct?

yes, I can

I guess I would check Google Play and see if there are any app updates available.

  1. Open the Google Play Store app Google Play|autox18.
  2. Tap Menu Menu|autox18 and then My apps & games .
  3. Apps with an update available are labeled “Update.” You can also search for a specific app.
  4. Tap Update .
1 Like

Thank you. I did that. I also uninstalled and reinstalled google and am on the current android version- 11

1 Like

Hi @wendym.m7vlod,

Does the issue persist after checking to be sure everything is updated?

yes, the issue continues

do you think it could be the phone and I need to return it?

What happens if you type your question after “Hey Google” rather than speak your question?

Sorry to add to the 20 questions, but I see one that hasn’t yet been asked.

  1. Does this fail on WiFi as well as it does on Cell?

hadn’t tried that yet

I got the answer typed out

Check to make sure you have a Google Assistant voice set up under Settings > Apps & notifications > Assistant > See all Assistant settings > Assistant voice

I’ve only tried on wifi, let me try on cell

never too many questions or ideas, I’m hoping to get it working :slight_smile:

on cell, same response- it responds to my “hey google” with the typed words “Hi, how can I help?” but when I speak something it says “Can’t reach google at the moment”, Typing it in gets me a voice reply

assistance voice is set up, I changed it and still doesn’t work

Check permissions for the Google and Gboard app and make sure they have microphone permission.

both those permissions are allowed. I just came across this:

I have a Pixel 4 and recently upgraded to Android 11. It turns out Android 11 has a bug on the Pixel 4 and once you upgrade the OS you can no longer launch the Assistant by voice. The Google Assistant will instead keep saying “can’t reach Google at the moment”. I have tried every normal fix and have tried a session with Google Help chat including a factory reset. The problem only occurs when starting the Assistant via voice. However, when I click in the search field in the Google app and then ask for a search via voice, it works fine. So the problem is in the handoff from saying OK Google to getting the Assistant to listen and respond. You might say this is Not OK Google! And it’s not the account, as the same account on my older Pixel with Android 10 is fine, so it’s only after upgrading to Android 11 on the Pixel 4 that I’ve had this issue. So I’m 99% sure there’s a bug that Google needs to patch here. This should be elevated to the respective device and product teams ASAP. I’m an executive in the wireless business, so I’m not an alarmist or confused consumer, I’m pretty sure of this information for the reasons stated.

1 Like

Interesting. My wife has a 4a with Android 11. When she gets back from the dentist I’ll check it out.

1 Like

thanks!

Her assistant won’t talk back to her. It searches fine. But no assistant voice (even though it’s enabled).

Based on the information you provided and the info back from @cbwahlstrom wife, would it be possible for both of you to check this bug that has been filed by others to see if this is consistent with what you’re experiencing? https://issuetracker.google.com/issues/153853966

Message an
Expert customer