Pixel2 not answering WiFi network calls

What phone do you have? Google Pixel2

What plan are you on? the lowest price/mo, whatever that is.

Does your plan include data, or just talk & text? all three, 1 Gb data cap.

Issue Description

When I am on my home network or my work network, the phone will ring, but then immediately drops the call. Likewise, if I call out, it will ring the other person, but drops the call before they can answer.
It works fine when I am traveling…as long as I have a signal.
Note that I have the ‘extender’ box from RW installed, and it worked at first, it is not working to intercept calls anymore.
I have already tried updating, rebooting, etc. I messed with several settings noted in the forum and from other Internet sources.
Thanks for any insights.

“messed with several settings” not very definitive :slight_smile:
The first thing I would check is to ensure that the GP2’s WiFi calling is not enabled

Google Pixel 2 - Turn Wi-Fi Calling On / Off
From a Home screen, tap the. Phone icon. (lower-left). If unavailable, swipe up from the bottom of the display then tap. Phone
2. Tap the. Menu icon.
3. Tap. Settings. .
4. Tap. Calls. .
5. Tap. Wi-Fi Calling. .
6. Tap the. Wi-Fi calling switch. to turn on or off.

Thanks for responding. Your suggestion was one of many in the various online forums. My phone does not have a (Step 5) “Wi-Fi Calling” option.
In the ‘Calls’ screen area, I have:

    1. Calling Accounts
    1. Fixed Dialing Numbers
    1. Call Forwarding
    1. Additional Settings (which also had no wifi options.)
      I have a son who tells me if I switch to Google Fi, it will fix it, but I am not so sure.

ok, so you probably saw/tried these two https://www.technipages.com/google-pixel-enable-or-disable-wi-fi-calling

It’s very likely we’ll be asking you to repeat some steps, since we can’t know what you’ve found and tried. So we appreciate your patience with us as the Community sends you suggestions.

Here are a couple of things to try:

  1. Have you tried resetting your WiFi network?

  2. Could you please make sure the option to hand over to WiFi is disabled?
    Open the Republic app
    Tap the Settings gear at top right :gear:
    Tap Advanced Settings
    Uncheck “Handover to WiFi when appropriate”

In the Advanced Settings, Manage Handover sections, I have two options. The one that is checked is
-Allow manual handover
The other option is labeled 'Enable handover on networks". However, it is grayed out and does not respond to an attempt to tap it.

Interesting, I was not aware certain phones lack the third option.

Just as a test, then, what if you deny the Google app permission to use the microphone?
Can you then make a call on WiFi?

Settings > Apps and Notifications > Google > Permissions
Tap Microphone
Tap Deny

Continuing issue with Google Pixel 2Xl from earlier:
As instructed:

  • Tried denying microphone.
  • Removed and reinserted SIM.

no luck.
You are welcome to try to reach me on it at■■■■■■■■■■■■■■ but I have tried calling myself already. I can be reached from another number if needed.

Hi @mike.d.taylor,

Have you tried resetting your WiFi network? I didn’t see you confirm that one. To do so:

  1. Turn off the phone
  2. Turn off or unplug your router
  3. If you have a separate modem, turn off or unplug that.
  4. Wait 1 minute
  5. Plug in the modem (if it is separate from the router) and wait for it to fully boot up
  6. Then plug in the router and wait for it to fully boot up and all of its lights to indicate it is online
  7. Turn the phone back on.

Have you made sure your router’s SIP ALG is disabled? It can cause calls to drop almost as quickly as they are established. See: Router Tweaks - Keep WiFi 1st - a Community Guide

The concept of getting help from our Member Community is that the knowledge and availability of our entire Community is far greater than that of any one individual. I wouldn’t be much help by calling you, especially if the phone is just going to drop the call.

If you’d like help from our Help Team (who would be able to call you), you can open a Help Ticket.

Southpaw,
I am at work, on their network, so resetting their router is not an option. However, I don’t think that is the issue. No one else here is having the problem. Plus the wifi issue is happening on BOTH this network and my home network…and the issue started on the same day/week on both. It would be weird for both networks to do that, right? I can reply to you via email, but the forum links are just spinning away…looking at nothing. BTW: The RW forum has been flaky all day. Just does not seem to want to connect…on either the phone or my desktop. The rest of the Internet connections seem solid.
Oh wait, a page just came up…but its all text, no graphics and does not address the SIP issue in the link.
That said, SIP could be a local phone issue. I see that in the phone app “Use SIP calling” is set ‘For all calls’. However, when I tap ‘SIP accounts’ nothing is displayed.

So, a couple of other things: Settings version says tmobile_us plus a long number, ending in .21.
Also,
Sim status reads: Network/Emergency Calls Only - Republic
Mobile Network state: Disconnected (expected, I am in a cellular no signal pocket)
Service State: Out of Service
Mobile Voice Network type: unknown
Mobile Data Network Type: unknown
Thanks,
Mike

Hi @mike.d.taylor,

I understand that resetting the work router is not an option. I was hoping to focus on such troubleshooting on your home network. Sometimes when people have what seems to be the same problem in two places, it can have different causes.

I’ve not seen anything in the Community’s error logs, nor other complaints, that would explain why you were having trouble accessing the Community. Does that problem persist?

I don’t have a Pixel available and am not familiar with this setting. Perhaps one of our Pixel users can check that setting, or you could turn it off and see if it makes a difference for your calls.

I’m not sure what you were referring to when you mentioned “Settings version” Is that the app version for the settings app?

None of the other settings you mentioned would really have anything to do with WiFi calling.

Since you mentioned that the Extend Home adapter is no longer working, have you dis-associated it from your account? That might be a good next step.

I don’t believe this is related to the issue. SIP calling refers to Android’s native SIP support, which Republic does not use. Republic does use SIP but bypasses Android’s native SIP support with its app. As an aside, and not related to your Pixel 2, native SIP support has been removed from Android as of Android 12.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer