Plan 3.0 SMS/MMS Issue

#1

I just activated my moto X pure over the weekend. I installed Signal SMS/MMS app and it works for a day then all of a sudden sporadic SMS/MMS issue of sending/receiving. Here are some symptoms: (I might missed a few scenarios.)

Over cell network:

  • first, can receive/send SMS but not MMS

  • next, can receive SMS but not send

  • now, cannot receive or send SMS or MMS

Over wifi:

  • first, can receive/send SMS and MMS

  • next, can receive SMS and MMS sporadically

I have family and friends using RW and with Signal app and they have no issues over cell or wifi. The difference is they bought their phones with RW while I purchased mine on Amazon, then get the SIM with RW to insert. I reviewed my account and the IMEI is that of the new phone. Not sure, if I need to do any “trick” reboot or reset APN or let phone “soak” on LTE network? I noticed the underlying routing number is different than that of my previous phone on plan 2.0. (using ##4636## to view more info.)

Slightly frustrated and possibly not providing useful info to community, just let me know what else I can provide. (I prefer not to use Google Messenger, whereas, everyone else is using Signal app w/out issue.)

moto X pure with plan 3.0, talk, text and wifi data ($15/month).

Thank you.

#2

You will typically get a different underlying routing number with a different phone. The underlying number doens’t follow you like your actual phone number does. You won’t get RW support for Signal, since it’s not their app, nor native to Android. You might be better rewarded by posting in the Signal user fourms, assuming such exists. Otherwise, you can always try the 3Rs (remove app, reboot phone, reinstall app). I doubt it matters what plan you’re on (GSM vs CDMA).

#3

I tried the 3Rs, with RW app and Signal. It’s weird that others are not having issue with Signal app over cell connection. I’m wondering if Tmobile LTE network here has anything to do with it. Scratching my head, why it works for others, my family and friends and not for me (or it used to work then gradually stop).

#4

After so many 3Rs, the Signal app can receive sms/mms fine over cell or wifi but cannot send over cell or wifi. Some sort of “blockage” at the network? I’ve review the Signal app permission and it has all the necessary, including making changes to system. Getting weirder :frowning:

#5

Have you tried checking the app settings to see if there are any changes you may be able to make to it? I’ve been using GM until recently changing to Textra on my Pure. Both apps have worked fine. Is there a particular reason you want to stay with the Signal app?

#6

I reviewed all the settings and permissions, from the app and from system settings, everything looks fine. The reason I’m using Signal is that my family and friends are using it and provides privacy. The weird part is that Signal can receive sms/mms fine now on cell or wifi. But sending part, just in pending state or the app indicated messages sent but no one receive it.

#7

@moto.x

Have you tried the app support people on this issue and your updates?

*** ~~ßocephous™***

#8

I think I figured out the issue. It seems I did not “unregister” the app from Signal’s network before uninstall. I performed the 3Rs and keep registering the device with Signal. In other words, too many registrations from same device. I went and searched whispersystems.org site and found the below. I can send from my new phone and Signal app now. Will see what happen in next few days…

Open Whisper Systems >> Unregister

#9

So, solved then, eh?

#10

So far so good…I found that the Signal app can send unencrypted message with long press of the “send” button. Still navigating this app, some useful links for Signal app.

Android – Support

How do I unregister? – Support

How do I know if a message has been delivered? – Support

My contact is no longer using Signal, how can I send an SMS? – Support

closed #11
Message an
Expert customer