"Please turn off Samsung WiFi Calling" error mgs

Samsung J7, MyChoice 1 Gig, Yes I have data

So recently, I’ve started getting an error msg in my notifications. The error is coming from RW. It says:
“Please turn off Samsung WiFi Calling. Samsung WiFi Calling must be turned off for Republic…” (wireless to work or something like that at the end.)

I’m not sure when this started, but it’s been going on for at least the last month, maybe 2 months.
I get this message intermittently. It comes and then it eventually goes away.

Things I’ve tried:

  1. searching in the RW Member Community for anyone with a similar problem (didn’t find any.)
  2. google searched - “please turn off samsung wifi calling j7” and got directions from Verizon on how to turn this off - but I don’t have the same menu as what Verizon tells me to do. With Verizon it seems I should have a menu item in the settings called “Advanced Calling”. I can’t find that, even when I search within the settings.
  3. I can see within the RW app, Advanced Settings, that a check box is selected “Show Samsung WiFi Calling enabled - A notification will be shown when (this) is enabled. The RW application requires Samsung WiFi Calling to be disabled in order for calls over Wifi to work properly.” [Well, that’s great, but I never turned it on, and can’t figure out where to turn it off. So does that mean that when I have this error msg that I can’t receive calls? I have no idea but I am concerned if that is the case.]

So apparently this is something RW knows about since the error is coming from the RW app. But the question remains - how do I shut off Samsung WiFi Calling on a Samsung J7?

I found this How to Turn off WiFi Calling – Republic Help and it appears to cover your problem

3 Likes

So yes, this does look like the right topic/instructions…
But when I follow those Samsung instructions (2nd half of your linked solution) I see that my choices are Disabled or ???Disabled. Yep, you read that right. hahaha. No matter how i toggle that “WiFi Calling” on or off, it just stays disabled. Which maybe is a good thing? Maybe there was a fix I missed. I guess for now I’ll just sit tight and see if the error msg comes up anymore…

Thanks @jben for pulling out that topic!

1 Like

Hi @bobbiec1,

Would you be willing to post a screenshot of what you see on your Samsung phone. For reference, this is what I see on a Republic activated household Samsung phone when following the Help Center article @jben linked and I’m not seeing “Disabled or ???Disabled”:

If needed:

3 Likes

Hey so here’s what I see from Phone > Menu > Settings.
This picture is the menu

when I go into the Wi-Fi calling, there’s a toggle - but no matter which way I turn the toggle, the WiFi calling never changes from “disabled”.

I guess I should mention - I’m on Android 8.1.0, so the above instructions that jben mentioned - I should be using the first set… But under Mobile Networks I do not have the “Advanced” choice. I only have: Data roaming, VoLTE calls, Network mode, Access Point Names, and Network operators.

When you tap the switch at the very top, does it move to the left and turn gray? If so, that’s the position you want it in to get rid of the error message.

2 Likes

Hi @louisdi,
Yes, if i tap that switch and turn it grey/off, it appears grey and off, and it says “disabled”. But even if the switch is blue/on, it still says wifi is disabled. (Which is why I’m not sure this is the fix - it seems this selection is DISABLED, regardless of what I choose.) But I’ll try it in the greyed out position, and hopefully that’s it…
Thanks!

1 Like

It should be. It says disabled in either position because it doesn’t work with Republic. When it is on however it tries to connect causing the error you were seeing. With it off, that should stop as the connections won’t be attempted.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer